Problem with webmail & gmail smtp relay

Discussion in 'General' started by pattone, Aug 23, 2013.

  1. pattone

    pattone New Member

    Hello, first of all sorry for my english, I'm from Argentine. I use ispconfig 3 with postfix, dovecot & debian squeeze. I was using smtp relay with the smtp server of my ISP and was working OK, now my ISP blocks the mail relay and I had configured smtp relay with gmail and it's working but when I use webmail (roundcube) the system sends the mail but when the people receives the mail in the from field shows my google account and not mydomain account. If I use a mail client (thunderbird or any other) it works ok. Any ideas?? Thanks in advance
    Last edited: Aug 23, 2013
  2. pattone

    pattone New Member

    anbody?? I really need to setup this quickly. Thanks in advance
  3. pattone

    pattone New Member

    In my server I have roundcube and squirrelmail with different alias and with both I have the same problem
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely google detects the different mail headers / delivery path and changes the from address then. You should consider to use a different relay host, e.g. the one of your isp.
  5. pattone

    pattone New Member

    Hello Till, thanks for your reply!! I was using smtp relay with the smtp server of my ISP and was working OK for a year; but now my ISP blocks mail relay so I have to use another server. The strange thing is this problem happens when I use webmail, if I use a mail client software (i.e thunderbird) everything works ok. I was thinking in updating roundcube or squirrelmail, what do you think?? thanks in advance
    Last edited: Aug 28, 2013
  6. kerrsmith

    kerrsmith Member

    I have seen this before when sending email via Gmail's SMTP server and the issue seems to be the message ends up containing a header 'Sender' that Thunderbird ignores whilst other clients show it to the user - which is where the 'On Behalf Of' comes from - I think this is your issue?

    To solve this I add the email to the Gmail account first using the 'Add another email address you own' option. In the part where you choose SMTP server (either Google's or your own) just choose your own but actually add Google's one instead.

    Once this is done the emails no longer have the 'On Behalf Of' attached to them when sent through Gmail's SMTP server.

    There is a blog post about it here:
    Last edited: Sep 10, 2013
  7. Hannie

    Hannie New Member

    You cannot get rid of the Gmail's "on behalf of". What I do, I use travel smtp ( and I can seriously recomment their service to everyone. Their support is fast and it's true what they claim: email never gets stuck again. I think they have some special technical thing going on cause my email problems are totally history since I use there service.

Share This Page