Problem with upgrade

Discussion in 'Installation/Configuration' started by Captain, Jun 20, 2010.

  1. Captain

    Captain Member

    It is physical server in local network. One static IP adress -> Router (forwarding on server local IP) --> Server with localIP
    May be reinstall Proftpd? Or ISPConfig?
    It is all happens after Ubuntu Upgrade from 9.10 to 10.04 and ISPConfig Upgrade from 35 to .36!
    Firstly I upgrade dist. after that ISPConfig.
     
  2. Captain

    Captain Member

    FTP still not work.
    Falko have you any ideas?
    Please help to find desition of this problem.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    You can try to reinstall ProFTPd, but I don't know if it works.
     
  4. Captain

    Captain Member

    When I try to remove proftpd ucf I have this Ubuntu atitude log:
    Code:
    [email protected]:~# aptitude remove proftpd ucf
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    The following packages are BROKEN:
      clamav-base clamav-freshclam fontconfig-config grub libapache2-mod-php5 libpaper1 libxml-sax-perl php5-cli php5-idn php5-imagick php5-memcache postgrey proftpd-basic
      rsyslog ufw unattended-upgrades
    The following packages will be REMOVED:
      ucf
    0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 266kB will be freed.
    The following packages have unmet dependencies:
      clamav-freshclam: Depends: ucf but it is not installable
      fontconfig-config: Depends: ucf (>= 0.29) but it is not installable
      clamav-base: Depends: ucf but it is not installable
      php5-memcache: Depends: ucf but it is not installable
      unattended-upgrades: Depends: ucf but it is not installable
      libxml-sax-perl: Depends: ucf (>= 0.28) but it is not installable
      ufw: Depends: ucf but it is not installable
      proftpd-basic: Depends: ucf (>= 0.30) but it is not installable
      php5-imagick: Depends: ucf but it is not installable
      grub: Depends: ucf (>= 3.004-0ubuntu2) but it is not installable
      rsyslog: Depends: ucf (>= 0.8) but it is not installable
      php5-cli: Depends: ucf but it is not installable
      libapache2-mod-php5: Depends: ucf but it is not installable
      php5-idn: Depends: ucf but it is not installable
      postgrey: Depends: ucf (>= 0.28) but it is not installable
      libpaper1: Depends: ucf (>= 0.28) but it is not installable
    The following actions will resolve these dependencies:
    
    Remove the following packages:
    clamav
    clamav-base
    clamav-freshclam
    fontconfig
    fontconfig-config
    ghostscript
    gpa
    grub
    libapache2-mod-php5
    libcairo2
    libfontconfig1
    libgd2-xpm
    libgs8
    libgtk2.0-0
    libgtk2.0-bin
    libpango1.0-0
    libpango1.0-common
    libpaper-utils
    libpaper1
    librpc-xml-perl
    librrd4
    librrds-perl
    libxft2
    libxml-libxml-perl
    libxml-sax-expat-perl
    libxml-sax-perl
    libxml-simple-perl
    logcheck
    php-pear
    php5
    php5-cli
    php5-curl
    php5-gd
    php5-idn
    php5-imagick
    php5-imap
    php5-mcrypt
    php5-memcache
    php5-ming
    php5-mysql
    php5-pspell
    php5-recode
    php5-snmp
    php5-sqlite
    php5-tidy
    php5-xmlrpc
    php5-xsl
    pinentry-gtk2
    postgrey
    proftpd-basic
    rrdtool
    rsyslog
    ubuntu-minimal
    ufw
    unattended-upgrades
    webalizer
    
    Install the following packages:
    lilo [1:22.8-8ubuntu1 (lucid)]
    mbr [1.1.10-2 (lucid)]
    pinentry-curses [0.7.6-1 (lucid)]
    
    Leave the following dependencies unresolved:
    libmagickcore2 recommends ghostscript
    ubuntu-standard recommends ufw
    libgtk2.0-common recommends libgtk2.0-0
    Score is -3567
    
    Accept this solution? [Y/n/q/?]
    
    I didnt accept this solution!
    Or it is right solution and need to accept it?

    Thnks!
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not uninstall proftpd as it breaks your setup. To reinstall proftpd, use this command:

    apt-get install --reinstall proftpd
     
  6. Captain

    Captain Member

    Thnks for help Till.
    I reinstall proftpd but problem still not solved.
    I dont know what to do.
    May be I will try to reinstall ISPConfig?
     

Share This Page