Problem with sub-domain

Discussion in 'General' started by da_Fohz, Oct 12, 2009.

  1. da_Fohz

    da_Fohz New Member

    Hi there!

    I have registered a domain example.com with GoDaddy and setup everything on their side and on my machine.

    I want to install RoundCube (which isn't a problem) but I would like to have it on webmail.example.com.

    On ISPConfig, I created the website for example.com, to which www.example.com and example.com respond fine. I then created the website 'webmail.example.com', so I could have RoundCube on a folder structure separate from the main website.

    On my DNS zone records, I have:

    A mail xxx.xxx.xxx.xxx
    A webmail xxx.xxx.xxx.xxx
    A www xxx.xxx.xxx.xxx
    MX mail.example.com

    I can dig any of these combinations:

    mail.example.com, www.example.com, example.com, webmail.example.com.

    But when I try webmail.example.com in the browser, it shows me the page of (www.)example.com, and not the index.html file in the webmail.example.com folder.

    What I believe is that the vhost registered in apache is directing all its traffice to the main site, and does not recognize the other.

    Can anyone help me out on this matter? I have been reading stuff everywhere for almost 3h and can't seem to sort this out.

    Thanks,
    Luís

    Edited:
    Do I need to set up any type of redirection?
     
    Last edited: Oct 12, 2009
  2. till

    till Super Moderator

    Remove the subdomain and create a nwe website "webmail.example.com" if you like to have a separate folder structure. Subdomains are aliaes for the site were you added them to and not a separate vhost. If you want a separate vhost, add the subdomain as new site.
     
  3. da_Fohz

    da_Fohz New Member

    Hi Till, thank you for your collaboration.

    As I said before:

    It's definitely something wrong with the vhost configuration ISPConfig creates in Apache2 (or I'm configuring something wrong in ISPConfig) because in the ISPConfig website panel, I selected my main domain example.com and put it as inactive. Thus, the vhost entry in Apache was removed and I was able to use webmail.example.com.

    Regards,
    Luís
     
  4. till

    till Super Moderator

    Please make sure that you selcted the correct IP address for all websites and not *.
     
  5. da_Fohz

    da_Fohz New Member

    What do you mean?

    In the apache directive? Sorry, you lost me there.
     
  6. till

    till Super Moderator

    There is just one field named "ip-address" in the website settings in ispconfig.
     
  7. da_Fohz

    da_Fohz New Member

    Mine doesn't show any ip address, just * in the dropbox.
     
  8. till

    till Super Moderator

    You can add the IP address in the system module.
     
  9. da_Fohz

    da_Fohz New Member

    I was trying to find screenshots of the control panel to see where in the System tab I could add that as I don't remember seeing that option.

    I will try once I get home, server is offline now. Danke schön!
     
  10. da_Fohz

    da_Fohz New Member

    Ok, added my static ip in system -> Edit server ip, and changed the ip in both websites, from * to 94.***.***.***.

    Now when I go to webmail.example.com, I get:

    And when I try www.example.com, example.com, it returns address not found, which means it's not even reaching my nameserver.

    Of course example.com is a registered and valid domain.
     
  11. till

    till Super Moderator

    then there must be another problem as the settings you changed have nothing to do with DNS. They are only related to the apache webserver.
     

Share This Page