problem with ssl on ispconfig site

Discussion in 'ISPConfig 3 Priority Support' started by saco721, Oct 16, 2015.

  1. saco721

    saco721 Member HowtoForge Supporter

    Hi I have multi-server setup with ISPconfig 3.0.5.3 on debian lenny. I have managed to get ssl working on the ispconfig interface, but it won't work with an ispconfig website. I thought that if I enabled the SSL check box on the domain tab, I would be able to connect to the site using https://www.mydomain.com, even if the valid certificate is not in place, but I can only connect using http://www.mydomain.com. Any help mwould be greatly appreciated. Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to create a self signed ssl certificate first on the ssl tab of this website. The detailed steps can also be found in the ISPConfig manual.
     
  3. saco721

    saco721 Member HowtoForge Supporter

    Hi Till, I have created a new website and created a self signed certificate on the ssl tab for the site, I then check the ssl check box for the site, but still nothing for https, thanks for your time.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    is the self signed ssl cert now visible on the ssl tab (in the ddl cert, key and csr field)?
     
  5. saco721

    saco721 Member HowtoForge Supporter

    Hi,

    Yes, the self signed cert is visible on the ssl tab, in ssl key, ssl request and ssl certificate.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, then please check the vhost file of this site if it contains an ssl section.
     
  7. saco721

    saco721 Member HowtoForge Supporter

    Hi Till,

    In ispconfig.vhost I have :
    # SSL Configuration
    SSLEngine On
    SSLProtocol All -SSLv2 -SSLv3
    SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt

    SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
    SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle

    </VirtualHost>

    in www.mysite.vhost I have :

    <IfModule mod_ssl.c>
    SSLEngine on
    SSLCertificateFile /var/www/clients/client0/web12/ssl/www.mysite.crt
    SSLCertificateKeyFile /var/www/clients/client0/web12/ssl/.www.mysite.key
    SSLCACertificateFile /var/www/clients/client0/web12/ssl/www.mysite.bundle
    </IfModule>


    thanks.
     
    Last edited: Oct 16, 2015
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Then ssl is enabled for that site in apache. Did you try to restart apache on the shell? Do you use a firewall, maybe port 443 is closed?
     
  9. saco721

    saco721 Member HowtoForge Supporter

    Thanks for your response Till.
     

Share This Page