problem with some apache directives (multiviews)

Discussion in 'Installation/Configuration' started by manarak, Jan 30, 2013.

  1. manarak

    manarak New Member

    I am using the gallery script piwigo on a domain hosted on a ISPC3 server (Apache2, Debian6) installed using Falko's How-To.

    I am confronted with strange problems.

    To enable SEO-friendly URLs in the gallery, I had to activate the following Apache directives:
    Code:
    AcceptPathInfo On
    Options +MultiViews
    But I get the following error in the error log:
    Does anyone know what could be the cause?
    I suppose it has something to do with ISPC3 default settings for websites or with default access rights, but I'm not sure.
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I guess it has to do with the secure permissions of the web/ directory. Usually you can ignore such warnings.
     
  3. manarak

    manarak New Member

    Thank you Falko - the problem is that the SEO friendly links produce a 404 - so I can't completely ignore it.
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you check the permissions of your .htaccess file?
     
  5. manarak

    manarak New Member

    I confess I did not - but I tried to put the Apache directives into Apache configuration, and the results were the same.
     
  6. manarak

    manarak New Member

    Solved!

    Apparently, multiviews requires higher file permissions when the webserver's user is not in the same group as the owner of the files.

    Setting file permissions to 750 solved my problem.
     
  7. manarak

    manarak New Member

    the problem came back... without me changing anything and inspite of everything being chmodded to 755.

    hmmm....
     
  8. manarak

    manarak New Member

    there were new files (templates, temp files, stats, etc.) that were being created by the webserver with 644 permissions - that disrupted multiviews.

    I got to find a solution around this.
     

Share This Page