Problem with setting root password for mysql

Discussion in 'Installation/Configuration' started by dealspiggy, Aug 29, 2008.

  1. dealspiggy

    dealspiggy New Member

    I'm following this tutorial http://www.howtoforge.com/creating-advanced-mysql-based-vhosts-on-lighttpd-debian-etch to install lighttpd and mysql, however, when I run

    I got this error:

    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'

    I wonder what's wrong with it. I use CentOS 5.2

    thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ? What's in /etc/hosts?
     
  3. dealspiggy

    dealspiggy New Member

    Out put of netstat -tap

    Code:
    ~: netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 *:mysql                     *:*                         LISTEN      17763/mysqld
    tcp        0      0 *:http                      *:*                         LISTEN      5093/lighttpd
    tcp        0      0 *:ftp                       *:*                         LISTEN      13661/proftpd: (acc
    tcp        0      0 *:smtp                      *:*                         LISTEN      5924/master
    tcp        0      0 server1.panda-greatwal:http 220.181.61.197:63603        TIME_WAIT   -
    tcp        0      0 server1.panda-greatwal:http 220.181.61.197:60311        TIME_WAIT   -
    tcp        0      0 server1.panda-greatwal:http 220.181.61.197:9526         TIME_WAIT   -
    tcp        0      0 server1.panda-greatwal:http 220.181.61.197:6303         TIME_WAIT   -
    tcp        0  21371 server1.panda-greatwal:http 220.181.61.197:13027        FIN_WAIT1   -
    tcp        0      0 server1.panda-greatwal:http 220.181.61.197:elvin_client TIME_WAIT   -
    tcp        0      0 server1.panda-greatwal:http 209.85.238.8:48272          TIME_WAIT   -
    tcp        0      0 *:imaps                     *:*                         LISTEN      5948/dovecot
    tcp        0      0 *:pop3s                     *:*                         LISTEN      5948/dovecot
    tcp        0      0 *:pop3                      *:*                         LISTEN      5948/dovecot
    tcp        0      0 *:imap                      *:*                         LISTEN      5948/dovecot
    tcp        0      0 *:remoteware-cl             *:*                         LISTEN      13909/sshd
    tcp        0   1892 server1.panda:remoteware-cl nagg217175.halls:bootserver ESTABLISHED 29232/sshd: uspie [
    
    Content of /etc/hosts:
    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1               localhost.localdomain localhost
    ::1             localhost6.localdomain6 localhost6
    69.57.252.128    server1.panda-greatwal.com
    thanks!
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you log in to MySQL when you use
    Code:
    mysql -u root -p
    ?
     
  5. dealspiggy

    dealspiggy New Member

    I'm asked to type password if I ran: mysql -u root -p

    Does this mean I've already set password for [email protected]?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    So you don't remember setting a MySQL password? Maybe you can log in without a password. Does
    Code:
    mysql -u root
    work?
     
  7. dealspiggy

    dealspiggy New Member

    I got this error:

     
  8. falko

    falko Super Moderator ISPConfig Developer

Share This Page