Problem with send mail... again

Discussion in 'Installation/Configuration' started by Brox, May 25, 2006.

  1. Brox

    Brox New Member

    Hello!

    1. Sorry for english :)
    2. I read another topics about this problem, but find not solution...
    System: Debian 3.1 (perfect_setup...) fresh...

    Problem with sending mail to external domain from external subnet:
    log:
    if i add My_IP to mynetworks, then mail send ok, but without auth.
    if i add Ext_domain to relay_domains, then ok too, w/o auth.
    "server requires auth." and "(SMTP) server requires SSL" in stmp-client checked - but not work...
    ...
    and... what i need input in "login" throw webmail (UebiMiau or Roundcube)? :D

    With best regards...
     
    Last edited: May 25, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    That's ok.
    That's ok, too.
    What's the output if you run
    Code:
    telnet localhost 25
    and then
    Code:
    ehlo localhost
    ?


    For Uebimiau you must login with an email address of the user and his password.
     
  3. Brox

    Brox New Member

    Code:
    ehlo localhost
    250-[U]Hostname[/U]
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME
    e-mail: user@domain.tld ?
    not work... say:
    Code:
    You cannot login with the username and password entered.
    Please check your username and password and try again.
    I just installed .pkg through ispconfig-web... need any extra configuration ?
     
    Last edited: May 26, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    That's ok. Is saslauthd running? Make sure your firewall doesn't block port 25, and enable "Server requires authentication" in your email client, as shown here: http://mail.cs.uiuc.edu/relay/outlook-config.html

    Does that email address belong to the user with which you want to log in?
     
  5. Brox

    Brox New Member

    Code:
    ps -ax |grep saslauthd
    Warning: bad syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
     2234 ?        Ss     0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
     2235 ?        S      0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
     2236 ?        S      0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
     2237 ?        S      0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
     2238 ?        S      0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
     7420 ?        Ss     0:00 saslauthd -a getpwent
     7421 ?        S      0:00 saslauthd -a getpwent
     7422 ?        S      0:00 saslauthd -a getpwent
     7423 ?        S      0:00 saslauthd -a getpwent
     7424 ?        S      0:00 saslauthd -a getpwent
    25714 pts/0    S+     0:00 grep saslauthd
    Firewall doesn't block... outlook config as in html...

    yes.
    username: web1_info
    email: info@domain.tld
    webmail:
    email: info@domain.tld
    password: password_for_web1_info
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/postfix/main.cf (please leave out the comments)?
     
  7. Brox

    Brox New Member

    In the begin, main.cf was fresh (by perfect setup), but mail wasn't sent then.
    Now, main.cf is a little changed and mail isn't sent again... :)

    ===/etc/postfix/main.cf===
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Please run

    Code:
    postconf -e 'smtpd_sasl_local_domain ='
    postconf -e 'smtpd_sasl_auth_enable = yes'
    postconf -e 'smtpd_sasl_security_options = noanonymous'
    postconf -e 'broken_sasl_auth_clients = yes'
    postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination'
    postconf -e 'inet_interfaces = all'
    postconf -e 'smtpd_tls_auth_only = no'
    postconf -e 'smtp_use_tls = yes'
    postconf -e 'smtpd_use_tls = yes'
    postconf -e 'smtp_tls_note_starttls_offer = yes'
    postconf -e 'smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key'
    postconf -e 'smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt'
    postconf -e 'smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem'
    postconf -e 'smtpd_tls_loglevel = 1'
    postconf -e 'smtpd_tls_received_header = yes'
    postconf -e 'smtpd_tls_session_cache_timeout = 3600s'
    postconf -e 'tls_random_source = dev:/dev/urandom'
    and comment out the
    Code:
    smtpd_client_restrictions = permit_sasl_authenticated
    line. Then restart Postfix.
     
  9. Brox

    Brox New Member

    done. It's work ! :)
    strange... this settings from perfect_setup... but didn't work in the begin...
    may be because i used ", not '? Distinction only in it... :)

    Thanks a lot !

    ...Problem solved...
     

Share This Page