Problem with saslauthd

Discussion in 'General' started by vogelor, Jan 25, 2007.

  1. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    i followed the perfect_setup_debian_sarge_p4 to set up saslauthd.
    the test with telnet shows the result needed.

    but when i try to send a mail i got the following lines in my log-file:

    Jan 25 20:07:52 www postfix/smtpd[19508]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Jan 25 20:07:52 www postfix/smtpd[19508]: warning: SASL authentication failure: Password verification failed
    Jan 25 20:07:52 www postfix/smtpd[19508]: warning: dslb-084-057-147-027.pools.arcor-ip.net[84.57.147.27]: SASL PLAIN authentication failed: generic failure
    Jan 25 20:07:53 www postfix/smtpd[19508]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory

    can anybody help me?
     
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    The telnet test will only show if Postfix is configured correctly. It will not test the authentication itself.

    To test that, you will need to do extra steps to a) generate a MD5 hashed / crypted uid/password and execute extra commands. Try Google and you'll find some examples.

    But the message appears to be clear. the saslauthd configuration has a directive that points to a non-existing file. Perhaps a typo?
    I'd start with the config files in /etc/postfix.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Please compare your /etc/default/saslauthd and /etc/init.d/saslauthd with the ones from the tutorial. Then make sure saslauthd is started.
     
  4. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    Got It!

    YEAH!
    i got it.

    the config files are all like the perfect debian sarge page 4 says.
    BUT i am using etch!
    in etch (maybe in sarge - don't know) there is something different!
    i created the dir with:

    Code:
    mkdir -p /var/spool/postfix/var/run/saslauthd
    and then i have to edit /etc/default/saslauthd. i have to remove # in front od start=yes to start the daemon.
    BUT THEN i DON'T have to add
    Code:
    PARAMS="-m /var/spool/postfix/var/run/saslauthd -r" 
    instead i have to change the line
    Code:
    OPTIONS="-c"
    to
    Code:
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd"
    editing of the file /etc/init.d/saslauthd is also not neccessary! i don't have to change the PIDFILE!

    the following steps are like the tutorial says.

    tip:
    after starting the saslauthd have a look at /var/spool/postfix/var/run/saslauthd
    if everything is ok, there must be some files in it (created by the deamon while starting). If you can't find these files there is something wrong with your rundir (with the OPTIONS=...)

    hope, this helps other!
     
  5. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    hint for falko

    @falko
    if the rundir is not set correct (to the chrooted dir) the daemon is still running! (ps aux |grep saslauthd finds some) and so everything seems to be ok. But then the error occours, because the chrooted postfix can't find the needed files. So checking for the daemon to run is not enought. you also have to search for the files in the run-dir. (maybe you like to change the howto ;-)
     
  6. falko

    falko Super Moderator ISPConfig Developer

    The tutorial was written for Sarge. A few things are different on Etch.
     
  7. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    i know - that's why i wrote it ;-)
     
  8. provell

    provell New Member

    info

    Yes, thanks for the info.

    As you can see in this tread:
    http://www.howtoforge.com/forums/showthread.php?t=9942&highlight=etch

    I have had about the same problem while setting this up.

    In the meas while I have done some testing with installing it on sarge and then upgrading to etch.
    Unfortunately the webserver had big problems with ISPconfig afterwards.

    As etch will be stable soon I rather try installing it on etch right away.

    Rgds Edo
     
  9. provell

    provell New Member

    working

    @vogelor: Do you now have a perfect working system?
    I do not have SASL error enymore but I can not send a mail to myself.
    This is bacause of the address resolution.

    I also don't have webmail working yet.
    Dit you?

    Rgds Edo
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
     
  11. provell

    provell New Member

    different way

    Yes, there are still errors:(

    But I'm giving up after 2 weeks of trying.
    My knowledge of linux debian is just to little to get it working.
    I now have a different kernel and the system is stable on sarge.
    This means that I can use het sarge perfect setup as it was supposed to.

    Anyway thanks verry much for all the help for so far.;)

    Rgds Edo
     
  12. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    SORRY!
    i haven't test to send a mail to myself, only to others and i haven't installed the webmail (is my next step for the next weeks)
     

Share This Page