Problem with Roundcube

Discussion in 'General' started by GCCM, Dec 19, 2019.

  1. GCCM

    GCCM New Member

    I'm new with Linux also ISPConfig.

    But my 2 Platformes working well (1 Nextcloud also 1 Wordpress).
    Now my Problem is in Roundcube:
    - My First "Testmail" was working. But after i tried to send a mail to an External Mail Adress (of me) i only have on roundcube (after pressing send mail) a # in my URL and Nothing is Working. It don't start to "sending E-Mail" or something. It just do Nothing after adding the # on URL.

    Roundcube Version: Roundcube Webmail 1.3.6
    ISPConfig Version: ISPConfig Version: 3.1dev
    PHP Version: 7.2.24-0ubuntu0.18.04.1
    OS: Ubuntu 18.04

    Thank you for your Assistance!
     
  2. Steini86

    Steini86 Active Member

    Please show logfiles from
    a) roundcube
    b) postfix

    I think I do not understand your problem. Can you describe it differently or show a screenshot?
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You run the dev for developer version of ISPConfig. Most of the time, that is not in a working condition. You should ask around from the developers if it right now is in such a shape that it can be used. Otherwise, if you are a developer yourself you should fix the problems you find and contribute the fixes back to the project.
    There is a stable version of ISPConfig that does work on supported Operating Systems.
     
  4. GCCM

    GCCM New Member

    So i updatet now to ISPConfig Version: 3.1.15p2
    but still same Problem. i don't know how i got dev Version after i used Always "stable" to update etc.

    How the Problem is:
    i press on:
    [​IMG] (send Button)
    [​IMG]
    and it only add on URL the last #
    [​IMG]
    [​IMG]
    i don't know how to get the log files.
    Installation was with this how to:
    https://www.howtoforge.com/tutorial...l-pureftpd-bind-postfix-doveot-and-ispconfig/

    Maybe i Need to change the first edited file (with the server URLS for Updates etc.) to get newest updates from roundcube?
     
    Last edited: Dec 20, 2019
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    3.1dev is the latest stable version plus bugfixes, so that's fine.
     
  6. GCCM

    GCCM New Member

    tested now with different mail boxes. All Mailboxes got the same Problem.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the error.log of the web server and also check the mail.log.
     
  8. GCCM

    GCCM New Member

    i got no entry on any log file (error / mail).. they are completly clean.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Any errors in /var/log/apache2/error.log ?
     
  10. GCCM

    GCCM New Member

    Yeah here i got some Errors. But they are more SSL. Hope you know how to fix it? :)

    Code:
    [Thu Dec 19 06:25:04.788818 2019] [:error] [pid 5839] python_init: Python executable found '/usr/bin/python'.
    [Thu Dec 19 06:25:04.788825 2019] [:error] [pid 5839] python_init: Python path being used '/usr/lib/python2.7:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Thu Dec 19 06:25:04.788841 2019] [:notice] [pid 5839] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Thu Dec 19 06:25:04.788853 2019] [:notice] [pid 5839] mod_python: using mutex_directory /tmp
    [Thu Dec 19 06:25:04.803616 2019] [ssl:warn] [pid 5839] AH01906: 127.0.1.1:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Dec 19 06:25:04.803692 2019] [ssl:warn] [pid 5839] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Dec 19 06:25:04.803835 2019] [ssl:error] [pid 5839] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: [email protected],CN=kis.gccm-informatik.com,OU=Hosting,O=GCCM Schmucki,L=Uzna$
    [Thu Dec 19 06:25:04.803846 2019] [ssl:error] [pid 5839] AH02604: Unable to configure certificate 127.0.1.1:443:0 for stapling
    [Thu Dec 19 06:25:04.804080 2019] [mpm_prefork:notice] [pid 5839] AH00163: Apache/2.4.29 (Ubuntu) mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.17 OpenSSL/1.1.1 configured -- resuming normal operations
    [Thu Dec 19 06:25:04.804100 2019] [core:notice] [pid 5839] AH00094: Command line: '/usr/sbin/apache2'
    [Thu Dec 19 06:25:04.804168 2019] [mpm_prefork:warn] [pid 5839] AH00167: long lost child came home! (pid 5840)
    [Thu Dec 19 07:16:01.581377 2019] [mpm_prefork:notice] [pid 5839] AH00171: Graceful restart requested, doing restart
    [Thu Dec 19 07:16:01.650786 2019] [fcgid:emerg] [pid 40711] (22)Invalid argument: [client 192.168.1.99:57097] mod_fcgid: can't lock process table in pid 40711, referer: https://192.168.1.112/index.php
    [Thu Dec 19 07:16:02.059296 2019] [fcgid:emerg] [pid 40710] (22)Invalid argument: [client 192.168.1.99:57089] mod_fcgid: can't lock process table in pid 40710, referer: https://192.168.1.112/index.php
    AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
    [Thu Dec 19 07:16:02.228051 2019] [:error] [pid 5839] python_init: Python version mismatch, expected '2.7.6', found '2.7.17'.
    [Thu Dec 19 07:16:02.228150 2019] [:error] [pid 5839] python_init: Python executable found '/usr/bin/python'.
    [Thu Dec 19 07:16:02.228157 2019] [:error] [pid 5839] python_init: Python path being used '/usr/lib/python2.7:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Thu Dec 19 07:16:02.228173 2019] [:notice] [pid 5839] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Thu Dec 19 07:16:02.228186 2019] [:notice] [pid 5839] mod_python: using mutex_directory /tmp
    [Thu Dec 19 07:16:02.242265 2019] [ssl:warn] [pid 5839] AH01906: 127.0.1.1:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Dec 19 07:16:02.242292 2019] [ssl:warn] [pid 5839] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Dec 19 07:16:02.242418 2019] [ssl:error] [pid 5839] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: emailAddress=host[email protected],CN=kis.gccm-informatik.com,OU=Hosting,O=GCCM Schmucki,L=Uzna$
    [Thu Dec 19 07:16:02.242438 2019] [ssl:error] [pid 5839] AH02604: Unable to configure certificate 127.0.1.1:443:0 for stapling
    [Thu Dec 19 07:16:02.242606 2019] [mpm_prefork:notice] [pid 5839] AH00163: Apache/2.4.29 (Ubuntu) mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.17 OpenSSL/1.1.1 configured -- resuming normal operations
    [Thu Dec 19 07:16:02.242624 2019] [core:notice] [pid 5839] AH00094: Command line: '/usr/sbin/apache2'
    [Thu Dec 19 07:16:02.242677 2019] [mpm_prefork:warn] [pid 5839] AH00167: long lost child came home! (pid 40707)
    [Thu Dec 19 11:15:02.022196 2019] [mpm_prefork:notice] [pid 5839] AH00169: caught SIGTERM, shutting down
    [Thu Dec 19 11:15:02.208061 2019] [ssl:warn] [pid 54271] AH01906: 127.0.1.1:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Dec 19 11:15:02.208129 2019] [ssl:warn] [pid 54271] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Dec 19 11:15:02.208261 2019] [ssl:error] [pid 54271] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: [email protected],CN=kis.gccm-informatik.com,OU=Hosting,O=GCCM Schmucki,L=Uzn$
    [Thu Dec 19 11:15:02.208273 2019] [ssl:error] [pid 54271] AH02604: Unable to configure certificate 127.0.1.1:443:0 for stapling
    [Thu Dec 19 11:15:02.208303 2019] [suexec:notice] [pid 54271] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Thu Dec 19 11:15:02.286186 2019] [:error] [pid 54283] python_init: Python version mismatch, expected '2.7.6', found '2.7.17'.
    [Thu Dec 19 11:15:02.286279 2019] [:error] [pid 54283] python_init: Python executable found '/usr/bin/python'.
    [Thu Dec 19 11:15:02.286285 2019] [:error] [pid 54283] python_init: Python path being used '/usr/lib/python2.7:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Thu Dec 19 11:15:02.286312 2019] [:notice] [pid 54283] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Thu Dec 19 11:15:02.286320 2019] [:notice] [pid 54283] mod_python: using mutex_directory /tmp
    [Thu Dec 19 11:15:02.300476 2019] [ssl:warn] [pid 54283] AH01906: 127.0.1.1:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Dec 19 11:15:02.302055 2019] [ssl:warn] [pid 54283] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Dec 19 11:15:02.302192 2019] [ssl:error] [pid 54283] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: [email protected],CN=kis.gccm-informatik.com,OU=Hosting,O=GCCM Schmucki,L=Uzn$
    [Thu Dec 19 11:15:02.302205 2019] [ssl:error] [pid 54283] AH02604: Unable to configure certificate 127.0.1.1:443:0 for stapling
    [Thu Dec 19 11:15:02.312258 2019] [mpm_prefork:notice] [pid 54283] AH00163: Apache/2.4.29 (Ubuntu) mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.17 OpenSSL/1.1.1 configured -- resuming normal operations
    [Thu Dec 19 11:15:02.312303 2019] [core:notice] [pid 54283] AH00094: Command line: '/usr/sbin/apache2'
    [Thu Dec 19 12:52:01.631717 2019] [mpm_prefork:notice] [pid 54283] AH00169: caught SIGTERM, shutting down
    [Thu Dec 19 12:52:08.938845 2019] [ssl:warn] [pid 60755] AH01906: 127.0.1.1:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Dec 19 12:52:08.938915 2019] [ssl:warn] [pid 60755] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
    [Thu Dec 19 12:52:08.939043 2019] [ssl:error] [pid 60755] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: [email protected],CN=kis.gccm-informatik.com,OU=Hosting,O=GCCM Schmucki,L=Uzn$
    [Thu Dec 19 12:52:08.939054 2019] [ssl:error] [pid 60755] AH02604: Unable to configure certificate 127.0.1.1:443:0 for stapling
    [Thu Dec 19 12:52:08.939082 2019] [suexec:notice] [pid 60755] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Thu Dec 19 12:52:09.012770 2019] [:error] [pid 60759] python_init: Python version mismatch, expected '2.7.6', found '2.7.17'.
    [Thu Dec 19 12:52:09.012874 2019] [:error] [pid 60759] python_init: Python executable found '/usr/bin/python'.
    [Thu Dec 19 12:52:09.012881 2019] [:error] [pid 60759] python_init: Python path being used '/usr/lib/python2.7:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Thu Dec 19 12:52:09.012935 2019] [:notice] [pid 60759] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Thu Dec 19 12:52:09.012943 2019] [:notice] [pid 60759] mod_python: using mutex_directory /tmp
    [Thu Dec 19 12:52:09.025042 2019] [ssl:warn] [pid 60759] AH01906: 127.0.1.1:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Dec 19 12:52:09.025073 2019] [ssl:warn] [pid 60759] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
    
     
  11. Steini86

    Steini86 Active Member

    Sorry, can't see your images. I still don't get the problem.
    I don't know with the ubuntu packages, but have a look in /var/lib/roundcube/logs ?
    Mail logs: /var/log/mail.log
    The guide sets
    Code:
    $config['default_host'] = 'localhost';
    However, if you use TLS with certificates, you have to set localhost to your mailname (mail.yourdomain.com), i.e. the domain that your postfix/dovecot certificate is valid for.
     
  12. GCCM

    GCCM New Member

    On this log File i got this:
    Code:
    Dec 17 12:52:27 weeb01 postfix/postfix-script[4661]: starting the Postfix mail system
    Dec 17 12:52:27 weeb01 postfix/master[4663]: daemon started -- version 3.3.0, configuration /etc/postfix
    Dec 17 12:52:40 weeb01 dovecot: master: Dovecot v2.2.33.2 (d6601f4ec) starting up without any protocols (core dumps disabled)
    Dec 17 12:52:40 weeb01 dovecot: ssl-params: Generating SSL parameters
    Dec 17 12:52:45 weeb01 dovecot: ssl-params: SSL parameters regeneration completed
    Dec 17 12:53:13 weeb01 dovecot: master: Warning: Killed with signal 15 (by pid=19618 uid=0 code=kill)
    Dec 17 12:53:13 weeb01 dovecot: master: Dovecot v2.2.33.2 (d6601f4ec) starting up for imap, lmtp, pop3 (core dumps disabled)
    Dec 17 12:54:10 weeb01 postfix/postfix-script[28992]: stopping the Postfix mail system
    Dec 17 12:54:10 weeb01 postfix/master[4663]: terminating on signal 15
    Dec 17 12:54:11 weeb01 postfix/postfix-script[29152]: starting the Postfix mail system
    Dec 17 12:54:11 weeb01 postfix/master[29154]: daemon started -- version 3.3.0, configuration /etc/postfix
    Dec 17 12:56:15 weeb01 postgrey[31602]: Process Backgrounded
    Dec 17 12:56:15 weeb01 postgrey[31602]: 2019/12/17-12:56:15 postgrey (type Net::Server::Multiplex) starting! pid(31602)
    Dec 17 12:56:15 weeb01 postgrey[31602]: Resolved [localhost]:10023 to [127.0.0.1]:10023, IPv4
    Dec 17 12:56:15 weeb01 postgrey[31602]: Binding to TCP port 10023 on host 127.0.0.1 with IPv4
    Dec 17 12:56:15 weeb01 postgrey[31602]: Setting gid to "121 121"
    Dec 17 12:56:15 weeb01 postgrey[31602]: Setting uid to "117"
    Dec 17 13:04:19 weeb01 postfix/smtps/smtpd[72295]: connect from localhost[127.0.0.1]
    Dec 17 13:04:38 weeb01 postfix/postfix-script[72313]: stopping the Postfix mail system
    Dec 17 13:04:38 weeb01 postfix/master[29154]: terminating on signal 15
    Dec 17 13:04:38 weeb01 postfix/postfix-script[72473]: starting the Postfix mail system
    Dec 17 13:04:38 weeb01 postfix/master[72475]: daemon started -- version 3.3.0, configuration /etc/postfix
    Dec 17 13:16:46 weeb01 postfix/postfix-script[83466]: stopping the Postfix mail system
    Dec 17 13:16:46 weeb01 postfix/master[72475]: terminating on signal 15
    Dec 17 13:16:46 weeb01 postfix/postfix-script[83626]: starting the Postfix mail system
    Dec 17 13:16:46 weeb01 postfix/master[83628]: daemon started -- version 3.3.0, configuration /etc/postfix
    Dec 17 13:16:47 weeb01 dovecot: master: Warning: Killed with signal 15 (by pid=83691 uid=0 code=kill)
    Dec 17 13:16:48 weeb01 dovecot: master: Dovecot v2.2.33.2 (d6601f4ec) starting up for imap, pop3 (core dumps disabled)
    Dec 17 13:16:48 weeb01 dovecot: config: Warning: /etc/dovecot/dovecot.conf line 68: Global setting mail_plugins won't change the setting inside an earlier filter at /etc/dovecot/dovecot.conf line 53 (if this is intentional, avoid this w$
    Dec 17 13:16:48 weeb01 postfix/smtps/smtpd[83945]: connect from localhost[127.0.0.1]
    Dec 17 13:19:25 weeb01 dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<pCxZLeaZItd/AAAB>
    Dec 17 13:19:25 weeb01 postfix/smtps/smtpd[82443]: connect from localhost[127.0.0.1]
    Dec 17 13:19:25 weeb01 postfix/smtps/smtpd[82443]: SSL_accept error from localhost[127.0.0.1]: lost connection
    Dec 17 13:19:25 weeb01 postfix/smtps/smtpd[82443]: lost connection after CONNECT from localhost[127.0.0.1]
    Dec 17 13:19:25 weeb01 postfix/smtps/smtpd[82443]: disconnect from localhost[127.0.0.1] commands=0/0
    Dec 17 13:19:25 weeb01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<A15ZLeaZQMt/AAAB>
    Dec 17 13:20:02 weeb01 postfix/smtps/smtpd[82443]: connect from localhost[127.0.0.1]
    Dec 17 13:20:02 weeb01 postfix/smtps/smtpd[82443]: SSL_accept error from localhost[127.0.0.1]: lost connection
    Dec 17 13:20:02 weeb01 postfix/smtps/smtpd[82443]: lost connection after CONNECT from localhost[127.0.0.1]
    Dec 17 13:20:02 weeb01 postfix/smtps/smtpd[82443]: disconnect from localhost[127.0.0.1] commands=0/0
    Dec 17 13:20:02 weeb01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<A2aEL+aZUMt/AAAB>
    Dec 17 13:20:02 weeb01 dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<5GeEL+aZMtd/AAAB>
    Dec 17 13:21:49 weeb01 postfix/smtps/smtpd[83945]: SSL_accept error from localhost[127.0.0.1]: Connection timed out
    Dec 17 13:21:49 weeb01 postfix/smtps/smtpd[83945]: lost connection after CONNECT from localhost[127.0.0.1]
    Dec 17 13:21:49 weeb01 postfix/smtps/smtpd[83945]: disconnect from localhost[127.0.0.1] commands=0/0
    Dec 17 13:25:01 weeb01 dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<ORleQeaZPtd/AAAB>
    Dec 17 13:25:01 weeb01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<x0NeQeaZXMt/AAAB>
    Dec 17 13:25:01 weeb01 postfix/smtps/smtpd[82980]: connect from localhost[127.0.0.1]
    Dec 17 13:25:01 weeb01 postfix/smtps/smtpd[82980]: SSL_accept error from localhost[127.0.0.1]: lost connection
    Dec 17 13:25:01 weeb01 postfix/smtps/smtpd[82980]: lost connection after CONNECT from localhost[127.0.0.1]
    Dec 17 13:25:01 weeb01 postfix/smtps/smtpd[82980]: disconnect from localhost[127.0.0.1] commands=0/0
    Dec 17 13:30:02 weeb01 dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<W5VPU+aZaMt/AAAB>
    Dec 17 13:30:02 weeb01 dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<fZ9PU+aZStd/AAAB>
    Dec 17 13:30:02 weeb01 postfix/smtps/smtpd[83178]: connect from localhost[127.0.0.1]
    Dec 17 13:30:02 weeb01 postfix/smtps/smtpd[83178]: SSL_accept error from localhost[127.0.0.1]: lost connection
    Dec 17 13:30:02 weeb01 postfix/smtps/smtpd[83178]: lost connection after CONNECT from localhost[127.0.0.1]
    Dec 17 13:30:02 weeb01 postfix/smtps/smtpd[83178]: disconnect from localhost[127.0.0.1] commands=0/0
    Dec 17 13:35:02 weeb01 dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<7vIwZeaZVtd/AAAB>
    
    but i try the change to the fqdn where i want to send mails
     
  13. GCCM

    GCCM New Member

    changed now the localhost to mail... but now i can't login to roundcube anymore. but Maybe it's a dns Problem.
     

Share This Page