Problem with recieving dir list

Discussion in 'General' started by Lukemob, Oct 12, 2010.

  1. Lukemob

    Lukemob New Member

    Hi there.

    Yesterday I unfortunately run a command "chown root:root *" in /var/www directory using Debian Lenny.

    Since then, the ftp for me doesn't work properly. It says:

    Reply: 227 Entering Passive Mode (109,169,41,67,129,206)
    Command: MLSD
    Reply: 150 Accepted data connection
    Reply: 226-ASCII
    Reply: 226-Sorry, we were unable to read [.]
    Reply: 226-Options: -l
    Reply: 226 0 matches total

    but if I manually enter a directory to change eg. web/ it works.

    Is there a way to fix it?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Edit a setting in every website, e.g. change quota and click on save. iSPConfig should set the correct owner for that website then again.

    By the way, good that you run just "chown root:root *" and not "chown -R root:root *" :)
  3. Lukemob

    Lukemob New Member

    Ahh thank you! :)

    By the way, is there an option to disable openbase_dir? As I'm tired of entering each path. Also, the field for openbase_dir seems to be too short :/
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Just enter / in the openbasedir field. The default is in the server settings. But be aware that this is very very insecure and should only be done on inhouse systems which are not connected to the internet.

Share This Page