Problem with receiving email's

Discussion in 'Installation/Configuration' started by gabrielloren, Sep 26, 2019.

  1. gabrielloren

    gabrielloren New Member

    Hello guys, how are you?
    I'm just writing here because I've tried all the possible options to solve this problem and I failed!
    I've followed this installation manual:
    And I'm with a domain, DNS configuration:
    type A : 3600
    type MX: 3600 Priority 10
    The problem: I can't receive emails. from external servers or from localhost
    I get always the same error:
    Sep 26 15:52:34 hospedagemvip postfix/smtp[9651]: connect to[]:10024: Connection refused

    I don't know if you want more information but please ask me then I send to you!

    Thank you very much!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The amavis service is not started on your server. start amavisd.
  3. gabrielloren

    gabrielloren New Member

    Thanks Till, service started but still not working. I've received a mail-back in my gmail with the message:
    550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that you do not have the domain anywhere in /etc/postfix/ or /etc/mailname. The hostname of a server must be a subdomain as shown in the install guides. So something like is ok but just is not ok.
  5. gabrielloren

    gabrielloren New Member

    The problem I got now is with the SSL... I've purged and reinstalled POSTFIX and DOVECOT
    And I get this error DOVECOT:
    And POSTFIX:
    /etc/postfix/ :
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This was not a good idea as you destroyed the config by doing this. To fix it, you must run an ispconfig update now with reconfigure services = yes. Beside that, the new config has still the same failure, I told you above what you have to do to fix it but you still did not do that. So after fixing the issues caused by the purge by running the ispconfig update, then follow the instructions I posted above to fix the original issue.
  7. gabrielloren

    gabrielloren New Member

    I'm sorry about that... I've formatted all my VPS and reinstalled. Now I still have the problem but can't send or receive emails.
    I can't start the clamav process. Then the amavis exit.
    I will show you first the processes running:
    Last edited: Sep 27, 2019
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    mydestination = $myhostname,,,, localhost
    I think that breaks your mail system. Like @till pointed out in #4. Where did that line come from? The 16.04 Perfect Server quide does not tell you to write that.
    Why are you installing on Ubuntu 16.04? Why not 18.04?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    No problem, it just was not necessary.

    Seems as if freshclam failed to load the database, this then caused clamav to fail. But anavis should work even without clamav, so there might be a different issue with amavis, maybe hostname related. Please post the result of the command:

    hostname -f

    and then run the command:


    to see if it is able to load the abtivirus database noe.

Share This Page