Problem with quota? Virtual Users And Domains With Postfix, Courier, MySQL And Squirr

Discussion in 'HOWTO-Related Questions' started by liberty_nz, Sep 2, 2009.

  1. liberty_nz

    liberty_nz New Member

    How do I remove (or at least adjust upwards) the quota for an email account?
    I have tried updating the value in mysql by setting the QUOTA value to NULL but no joy.

    Adjusting the number to a higher value doesn't seem to adjust the quota from the original 10485760 bytes either. The cron job to notify me of my 'impending quota doom' still runs.

    Is there a change I should be making to a postfix config file? Perhaps /etc/postfix/
    I have tried restarting postfix after changes but no joy. Any suggestions?

    This relates to Virtual Users And Domains With Postfix, Courier, MySQL And Squirrelmail using Ubuntu 8.10 (and others like it).
  2. falko

    falko Super Moderator ISPConfig Developer

    All you have to change is the quota value in the database. If that doesn't work, then there's probably something wrong with your setup.
  3. edo660

    edo660 New Member

    dragging an old thread back here...but i have the exact same problem. getting 'over quota' errors (Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Debian Lenny)) but adjusting the db value does nothing

    current maildir size is about 110mb, i've raised the limit to 1gb (6gb free space on server)

    the strange thing about this is that i can still receive emails, i just cant move them to my other imap folders

    any suggestions? have updated everything, done the postfix quota patch, increased the value in the db...

    i would have thought if my setup wasn't working that other parts would be failing?
  4. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
  5. edo660

    edo660 New Member

    no errors at all (and nothing in mail.err/.info.warn relating to quotas or even the account doing it)

    basically i'm using imap, and have an imap folder. when i originally setup the account i gave it 100mb quota, and now it seems to have reached that (the vmail folder for the account is around 100mb)

    the thing is, i can still receive emails but i cant move them from one imap folder to another
  6. edo660

    edo660 New Member

    i think i just found the the virtual mailbox folder there's a maildirsize file, containing a hardcoded value (which was the original value when i setup the accounts)

    changed that, and it's all sweet

Share This Page