Problem with PureFTPd

Discussion in 'Installation/Configuration' started by user2012, Sep 4, 2012.

  1. user2012

    user2012 New Member

    hi all, follow the steps according to Howto http://www.howtoforge.com/virtual-hosting-with-pureftpd-and-mysql-incl-quota-and-bandwidth-management-on-ubuntu-12.04.

    the problem is that I can not connect to the server via FTP Filezilla for example. what I see in the file var / log / auth.log is:

    Server pure-ftpd: pam_unix (pure-ftpd: auth): check pass; unknown user
    Server pure-ftpd: pam_unix (pure-ftpd: auth): authentication failure; logname = uid = 0 euid = 0 tty = pure-ftpd ruser = rhost = exampleuser

    and in the /var/log/message I get the following:

    *Server pure-ftpd: (? @ 100.x.x.x) [INFO] New connection from 100.x.x.x
    Server pure-ftpd: (? @ 100.x.x.x) [INFO] PAM_RHOST enabled. Getting the peer address
    Sep 4 11:45:12 server pure-ftpd: (? @ 100.x.x.x) [WARNING] Authentication failed for user [exampleuser]
    Sep 4 11:45:12 server pure-ftpd: (? @ 100.x.x.x) [INFO] Logout.

    if I can help with this, thank you very much

    Alex
    Santiago
    Chile.
     
    Last edited: Sep 4, 2012
  2. falko

    falko Super Moderator ISPConfig Developer

    Is this a virtual machine or a physical server?
     
  3. user2012

    user2012 New Member

    is a physical server,

    thanks
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you follow the tutorial as close as possible? Maybe you made a typo or some other error somewhere...
     
  5. user2012

    user2012 New Member

    I do not think, do the same installation 2 times, reinstalled operating system to rule out any errors.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Did you try both active and passive transfers in your FTP client?
     
  7. user2012

    user2012 New Member

    estimated, modify parameters (Active and Pasive) in FTP client does not work. when I try to connect to the FTP server via LAN, via console, I get the following message:

    220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 09:40. Server port: 21.
    220-This is a private system - No anonymous login
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    Name (100.x.x.x:user): exampleuser
    331 User exampleuser OK. Password required
    Password:
    530 Login authentication failed
    Login failed.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp>

    thanks.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Looks like you're using a wrong password. Have you tried to set another one?

    If that doesn't help: do your passwords contain special characters?
     
  9. user2012

    user2012 New Member

    I tried putting in MD5 password, ENCRYPT and neither works. I have no special characters, just plain text. not connected.

    thanks.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Not sure what's wrong, but you must have done something wrong. I know that the tutorial works as described, I've used it many times. Please double-check.
     
  11. user2012

    user2012 New Member

    is rare, I followed the steps as it appears.

    when I create a user in phpmyadmin, typing ls-l did not appear

    drwxr-xr-x 2 ftpuser ftpgroup 3 July 4096 22:23 www.example.com

    the user and group are created, but do not appear to write ls-l. or have to connect the user via filezilla to ftp folder is created in / home?

    thanks,
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Yes, you have to connect with FileZilla. The folder will then be created automatically.
     
  13. user2012

    user2012 New Member

    friends, I could not connect to the FTP server, I tested with Windows XP and Seven and the same thing happens. the server is in a LAN.
     
  14. falko

    falko Super Moderator ISPConfig Developer

    Any errors messages?

    Did you check your firewall settings? Did you try active and passive FTP?
     
  15. babixeddu

    babixeddu New Member

    Hate this s...stuff

    It's very frustrating read all, and at the end... ta tannn :eek: where the f*** is your problem? is gone? how did you have solved this problem? eh? :confused: eh? Hate this. Hate this.

    I've the same problem. I've followed the same tutorial as is, and at the end I can't connect:

    - auth.log
    Code:
    [...] pure-ftpd: pam_unix(pure-ftpd:auth): check pass; user unknown
    [...] pure-ftpd: pam_unix(pure-ftpd:auth): authentication failure; logname= uid=0 euid=0 tty=pure-ftpd ruser=exampleuser rhost=dynamic-adsl[...]
    
    - syslog
    Code:
    [...]  [ERROR] The SQL server seems to be down [Can't connect to local MySQL server through socket '*****/var/run/mysqld/mysqld.sock' (2)]
    [...]  [INFO] PAM_RHOST enabled. Getting the peer address
    [...]  [WARNING] Authentication failed for user [exampleuser]
    [...]  [INFO] Logout.
    
    - /etc/pure-ftpd/db/mysql.conf is the same (naturally I've changed the psw, which contains a special char, can be this?).

    - Port 3306 it's closed to the world but the connection is made with the mysql.sock so it's irrelevant. 21 is - naturally - open.

    Any thought?

    Thanks

    ---- EDIT ----

    It seems to be solved: the problem was on the folder permission and probably on the /etc/pure-ftpd/db/mysql.conf ... So:

    1) when copying the code made by falko, it's better to double check if the pasted code is good.
    2) I've created an "ftp" folder under /home (so: /home/ftp) and I've assigned the owner with chown root.ftpgroup -R to the ftp folder.
    3) I've changed the mysql row:

    INSERT INTO `ftpd` (`User`, `status`, `Password`, `Uid`, `Gid`, `Dir`, `ULBandwidth`, `DLBandwidth`, `comment`, `ipaccess`, `QuotaSize`, `QuotaFiles`) VALUES ('exampleuser', '1', MD5('secret'), '2001', '2001', '/home/ftp/www.example.com', '100', '100', '', '*', '50', '0');

    - Now I got a timeout error but the user is logged in and the folder is created under /home/ftp.

    ---- EDIT 2 ----
    The timeout error was generated when selecting "Passive mode" from Filezilla. Choosing "Active mode" solves the problem.

    Hope it's useful, cheers!
     
    Last edited: Nov 20, 2012
  16. user2012

    user2012 New Member

    dear, I did what you explained, but when trying to connect with the user created, reappears me the following information:

    Response: 220-Local time is now 12:37. Server port: 21.
    Response: 220-This is a private system - No anonymous login
    Response: 220-IPv6 connections are Also welcome on this server.
    Response: 220 You will be disconnected after 15 minutes of inactivity.
    Command: USER peter
    Response: 331 User peter OK. Password required
    Command: PASS ******
    Response: 530 Login authentication failed
    Error: Critical error
    Error: Could not connect to server

    assigning root.ftpgroup chown-R to the ftp folder, writing ls-l, is as follows:

    drwxr-xr-x 2 root 4096 Mar 26 12:12 ftp

    thanks
     
  17. user2012

    user2012 New Member

    if I try to connect to a system user, this connects seamlessly. with virtual users is where I can not connect.

    if you can help me please.
     
  18. mihail

    mihail New Member

    hello everyone. I have the same problem as the "user2012".
    Mar 29 13:10:26 hosting pure-ftpd: pam_unix(pure-ftpd:auth): check pass; user un known
    Mar 29 13:10:26 hosting pure-ftpd: pam_unix(pure-ftpd:auth): authentication fail ure; logname= uid=0 euid=0 tty=pure-ftpd ruser=anonymous rhost=host90-80-dynamic
     
  19. mihail

    mihail New Member

    here solve the problem with error 503:
    edit the file '#vi /etc/fail2ban/filter.d/pureftpd.conf'
    change the line: ' failregex = pure-ftpd(?:\[\d+\])?: (.+?@<HOST>) \[WARNING\] %(__errmsg)s \[.+\]$ '
    after the change will look like: ' failregex = pure-ftpd(?:\[\d+\])?: (.+?@<HOST>/)) \[WARNING\] %(__errmsg)s \[.+\]$ '
     

Share This Page