Problem with pure-ftpd-mysql

Discussion in 'Server Operation' started by Ricardo Bonino, Dec 3, 2019 at 12:40 PM.

  1. Ricardo Bonino

    Ricardo Bonino New Member

    Hello all,
    I am not very good with linux, but I have a virtual server with Debian and ISPConfig. Everything went fine until I need to upgrade the MariaDB on the server.

    After that the ftp (pure-ftpd-mysql) stop to work. So, I read some tutorials and remove previously pure-ftpd and installed a new one that I download on pure-ftpd website. So at first look, it is starting without any errors.

    But is look like the service is not listen on port 21.

    If I run the command: lsof -i -P -n | grop LISTEN, not is showing on port 21.

    And even after I enable verbose debug, not is showing on logs about ftp.

    So, I will be very glad if anyone can help me on identify the issue.

    Thank you,

    Ricardo Bonino
     
  2. Steini86

    Steini86 Active Member

    systemctl status pure-ftpd-mysql
    journalctl -u pure-ftpd-mysql
    Have you done reconfiguring services in ispconfig after installing the new service?
    (do an ispconfig update with reconfigure services = yes)
     
    Ricardo Bonino likes this.
  3. Ricardo Bonino

    Ricardo Bonino New Member

    I tried to execute ispconfig_update.sh, but it returns: There are no updates available for ISPConfig 3.1.15p2
    The ispconfig looks ok, the FTP appears active on Monitor, I can connect on database using the info on pure-ftpd conf files, the ftp users are on database. But the weird thing, is that even with verbose enabled, nothing is showing on logs, even if I try to connect on the FTP, even if a try to connect locally.

    Please find the outputs.
    Code:
    [email protected]:/# systemctl status pure-ftpd-mysql
      pure-ftpd-mysql.service
       Loaded: loaded (/etc/init.d/pure-ftpd-mysql; generated; vendor preset: enabled)
       Active: active (exited) since Tue 2019-12-03 08:19:44 -03; 22h ago
         Docs: man:systemd-sysv-generator(8)
      Process: 30260 ExecStop=/etc/init.d/pure-ftpd-mysql stop (code=exited, status=0/SUCCESS)
      Process: 30269 ExecStart=/etc/init.d/pure-ftpd-mysql start (code=exited, status=0/SUCCESS)
        Tasks: 0 (limit: 9830)
       CGroup: /system.slice/pure-ftpd-mysql.service
    
    Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
    [email protected]:/#
    
    Code:
    [email protected]:/# journalctl -u pure-ftpd-mysql
    -- No entries --
    [email protected]:/#
    
    Thanks,
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look into the pure ftpd log file directly in /var/log/.....
     
    Ricardo Bonino likes this.
  5. Ricardo Bonino

    Ricardo Bonino New Member

    Yesterday not was showing on logs, but now I can see only that. That's a point to investigate):

    Code:
    Dec  4 07:42:52 webserver pure-ftpd: ([email protected]?) [ERROR] Configuration error
    Dec  4 07:42:56 webserver pure-ftpd: ([email protected]?) [ERROR] Configuration error
    Dec  4 07:45:02 webserver pure-ftpd: ([email protected]) [INFO] New connection from localhost.localdomain
    Dec  4 07:45:02 webserver pure-ftpd: ([email protected]) [INFO] Logout.
    
    One thing I note on pure-ftp documentation, is that there is a need to have a file named
    pure-ftpd.conf on folder /etc/. But I donĀ“t have this file, only a folder pure-ftpd with others folders and a bunch of configuration files.

    Piece of Manual
    Code:
    A sample configuration file named pure-ftpd.conf should have been installed
    in /etc/, /usr/local/etc/ or another standard location derived from
    the package installation prefix.
    
    My etc folder
    Code:
    [email protected]:/etc# ls *ftp*
    ftpallow  ftpusers
    
    pure-ftpd:
    auth  conf  db  pureftpd-dir-aliases
    [email protected]:/etc#
    
     
  6. Steini86

    Steini86 Active Member

    Code:
    cd /tmp
    wget https://ispconfig.org/downloads/ISPConfig-3.1.15p2.tar.gz
    tar xvfz ISPConfig-3.1.15p2.tar.gz
    cd ispconfig3_install/install
    php -q update.php
     
    Ricardo Bonino likes this.
  7. Ricardo Bonino

    Ricardo Bonino New Member

    Uhuuuuuuuuuuu. Finally I could enable again my FTP service.
    First of all I remove all configuration files for pure-ftpd and the previous installed pure-ftpd app.
    After that I follow the steps here (found this guide here on forum that apply a patch on Pure-ftpd to work on latest MariaDB): https://gitlab.com/jisse44/pure-ftpd/blob/master/HowTo.txt

    And at last follow the steps mentioned above by @Steini86
    And now, I can log in again.

    Thank you very much for your help. :)
     
    Steini86 and ahrasis like this.

Share This Page