problem with pure-ftp

Discussion in 'Installation/Configuration' started by Oitsuki, Oct 15, 2018.

Tags:
  1. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What do you not want?
     
  2. Oitsuki

    Oitsuki Member

    Ftp does no start
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I checked on my host, there is no file
    Code:
    /etc/ssl/private/pure-ftpd-dhparams.pem
    Have you in addition to following the Perfect Server Guide also installed certificates with Let's Encrypt?
    Is your pure ftp using self signed or LE certificates?
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You wrote that in the first message of this thread, It was not true then.
     
  5. Oitsuki

    Oitsuki Member

    I must delete this file ?
    /etc/ssl/private/pure-ftpd-dhparams.pem
    and what next to access via ftp.
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Where did that file come from?
    Is this a fresh installation of ISPConfig?
    How long has it been running?
    What happened before FTP connections started failing?
     
  7. Oitsuki

    Oitsuki Member

    No it's not a fresh installation.
    I use yesterday the ftp, I have not problem with that.
    I remember one time my ftp was out, I reboot the system and it come back.
    I try also on another computer to connect by ftp, the problem is the same.
    Thank you for your time.
     
  8. Oitsuki

    Oitsuki Member

    also it can help : filezilla write this
    Erreur : Erreur GnuTLS -50 dans gnutls_priority_set_direct: The request is invalid.
    Erreur : Impossible d'initialiser le protocole TLS.
    Erreur : Impossible d'├ętablir une connexion au serveur
     
  9. Oitsuki

    Oitsuki Member

  10. Oitsuki

    Oitsuki Member

  11. Oitsuki

    Oitsuki Member

    I don't find solution, an expert can help m, please, else I have no solution to format my server. I don't want that.
    tk.
     
  12. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    What is in /etc/pure-ftpd/conf/TLS?

    Did you setup a passive port range for pure-ftpd, and allow it in your firewall(s) and any Nat?
     
  13. Oitsuki

    Oitsuki Member

  14. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Why is there 2 when the Guide tells you to write 1?
    This is from the chapter I told you to check in messages #15 and #17 in this thread:
     
    ahrasis likes this.
  15. Oitsuki

    Oitsuki Member

    I do not change anything on that, this a default value.Also I read and verify eveything about the configuration.
     
  16. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If you do
    Code:
    cat /etc/pure-ftpd/conf/TLS
    and it shows 2, go change it to 1 and try FTP.
     
  17. Oitsuki

    Oitsuki Member

    I make that, I have the same result
     
  18. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I forgot to say, restart pure-ftpd.
     
  19. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    did you restart pure-ftpd after changing that? setting to 1 makes TLS optional, so if that doesn't work, I'd guess your certificate is bad (still/again), as @Taleman first asked about.
    did you remove the old certificate before "recreating" it? ie. 'rm -f /etc/ssl/private/pure-ftpd.pem' ? I believe by default openssl will append the key/certificate/whatever to a file, rather than overwriting, so if you did not remove it you probably still have the same (potentially bad) original certificate in the file (possibly with new ones appended below it).
     
  20. Oitsuki

    Oitsuki Member

    I removed the certificate, recreate another (follow the tutorial)
    restart pure ftp
    TLS on 1
    It's work with this approach
    I changed my FTP paramters on Chiffrement : FTP connexion simple

    Tk for your help and patience
     
    ahrasis likes this.

Share This Page