Problem with Postfix

Discussion in 'Installation/Configuration' started by OrvUx, Jun 18, 2009.

  1. OrvUx

    OrvUx New Member

    Hi everybody, i have installed a Mail Server with virtual users using Debian Etch, all went fine except that when i try to send and email the server ask for the user and password over and over, i enabled the logging for mysql and the log is the follow:

    090617 20:04:30 9 Connect mail_admin@localhost on mail
    9 Init DB mail
    9 Query SELECT password FROM users WHERE email = 'orvux'


    Then i have changed in the mail client (evolution,outlook) the username to: orvux@orvux.net@orvux.net

    (Yes, double @orvux.net) and the email send fine, asking for the password one time only, and the server logs:

    090617 20:42:50 17 Connect mail_admin@localhost on mail
    17 Init DB mail
    17 Query SELECT password FROM users WHERE email = 'orvux@orvux.net'
    17 Quit

    I have searched in all the files and the only one which contains this query is the:
    /etc/postfix/sasl/smtpd.conf

    i have changed the query to:
    sql_select: select password from users where email = '%u@%d'

    but nothing have changed, i hope somebody can help me, i have almost a week with this error and i don't know what more to do...

    Thanks in advance.

    OrvUx
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please double-check all your configuration files, maybe you made a typo somewhere.
     
  3. OrvUx

    OrvUx New Member

    Hi Falko thanks for your reply, really i have rechecked all the config files but i don't know what is wrong, all seems fine.

    Thanks.


    OrvUx
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you double-check all the mysql*.cf files?
     
  5. OrvUx

    OrvUx New Member

    Hi falko, i found the solution, for a very strange reason i omited to download, patch and compile the postfix source code to create the debian packages, then after doing it all is working very good.

    Thanks.
     

Share This Page