Problem with postfix

Discussion in 'Server Operation' started by jcole, May 1, 2009.

  1. jcole

    jcole New Member

    I installed the perfect spamsnake and aside from an increase of spam just recently, it has worked great.

    Last night however, it started rejecting mail to one of the domains in my relay_domains list. Nothing in the postfix config has changed. The domain still exists in relay_recipients/relay_domains. Nothing has changed yet it is rejecting e-mails for this one domain, the other 7 are fine. The server returns error "recipient address rejected: domain not found" when I try to send the e-mail from a telnet session.

    Any ideas?

    I have tried deleting the domain out of relay_domains/relay_recipients/transport and running postmap and then re-adding them but that did not help me.
     
    Last edited: May 1, 2009
  2. Rocky

    Rocky New Member

    Hi,

    Are you doing a:

    postfix reload

    after recreating the file and running postmap?

    Thanks,

    Rocky
     
  3. jcole

    jcole New Member

    Yes sir. I did do that.
     
  4. Rocky

    Rocky New Member

    Hmm,

    Really weird problem. You are doing the corect steps, removing the entries, running postmap, restarting postfix.

    It'll reject them as necessary. After that, readd them to the files, postmap and restart postfix. See it that works for you.

    Rocky
     
  5. jcole

    jcole New Member

    I tried that and it is still rejecting e-mails to that domain. Is there anything else I can try?

    I am only deleting the line item for the one domain I am having trouble with. Should I delete relay_domains and relay_recipients and re-create those files?
     
    Last edited: May 1, 2009
  6. CarbonCopy

    CarbonCopy New Member

    Are you using virtual domains and if so, is the requested domain in the table/file?
     

Share This Page