Problem with Postfix not sending out emails to "outside" domains

Discussion in 'Server Operation' started by MiniMe, Oct 6, 2011.

  1. MiniMe

    MiniMe New Member

    I am having a problem with Postfix on a Debian Squeeze 6.0.2 box.
    I think the issue has come since i did an apt-get update & upgrade recently.

    Anyway, the issue is that whenever i try to send email to a domain which is not listed in the $mydestinations= /etc/postfix/local_host_names directive it just gives a message bounce / bounced error and that it cannot find the recipient in the recipient list.

    hereunder is my recently adjusted main.cf file ( i had problems with SASLauthd and stuff due to the package upgrades but those are fixed ) :

    Code:
    alias_database = hash:/etc/aliases
    #mydestination = Aphrodite-Artemis, localhost.localdomain, localhost
    recipient_delimiter = +
    default_transport = error
    relay_transport = error
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
    masquerade_exceptions = root
    masquerade_classes = envelope_sender, header_sender, header_recipient
    myhostname = mail.evil-hannie.eu
    program_directory = /usr/lib/postfix
    mydomain = evil-hannie.eu
    inet_interfaces = 188.40.33.123 localhost
    masquerade_domains =
    #mydestination = $myhostname, localhost.$mydomain, localhost
    mydestination = /etc/postfix/local-host-names
    defer_transports =
    mynetworks = 127.0.0.0/8
    mynetworks_style = subnet
    #mailbox_command =
    disable_dns_lookups = no
    relayhost =
    relay_domains = $mydestination
    mailbox_transport =
    strict_8bitmime = no
    disable_mime_output_conversion = no
    smtpd_sender_restrictions =
    #hash:/etc/postfix/access
    smtpd_client_restrictions =
    smtpd_helo_required = no
    smtpd_helo_restrictions =
    strict_rfc821_envelopes = no
    #smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
    smtp_sasl_auth_enable = no
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtdp_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_reject_unlisted_recipient = no
    smtpd_sasl_local_domain =
    smtpd_tls_auth_only = no
    smtpd_use_tls = yes
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    alias_maps = hash:/etc/aliases
    mailbox_size_limit = 0
    message_size_limit = 10240000
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    home_mailbox = Maildir/
    mailbox_command =
    Content of /etc/postfix/local-host-names is as follows :
    Code:
    localhost
    evil-hannie.eu
    mail.evil-hannie.eu
    
    Any help would be very much appreciated.
    Thank you.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post the error messages from your mail log?

    Do the external domains resolve to an external server?
     
  3. MiniMe

    MiniMe New Member

    The external domains resolve just fine to external existing servers.
    They also resolve perfectly to MX records and such.

    Here is the exact error / warning message that is located in my mail log files :
    Please note that this is an example and counts for all external domains ...

    Code:
    Oct  6 21:16:55 Aphrodite-Artemis postfix/qmgr[7520]: EE56CCAEE4B: from=<[email protected]>, size=792, nrcpt=1 (queue active)
    Oct  6 21:16:55 Aphrodite-Artemis amavis[5294]: (05294-19) Passed CLEAN, LOCAL [127.0.0.1] [127.0.0.1] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: 0cWcSmbnF9Wp, Hits: -0.876, size: 351, queued_as: EE56CCAEE4B, 1538 ms
    Oct  6 21:16:55 Aphrodite-Artemis postfix/error[8463]: EE56CCAEE4B: to=<[email protected]>, relay=none, delay=0.01, delays=0.01/0/0/0, dsn=5.0.0, status=bounced (sjo.co)
    Oct  6 21:16:55 Aphrodite-Artemis postfix/cleanup[8456]: F165BCAEE4D: message-id=<[email protected]>
    Oct  6 21:16:55 Aphrodite-Artemis postfix/smtp[8457]: AA3C9CAEE4A: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=12, delays=11/0/0/1.5, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=05294-19, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as EE56CCAEE4B)
    Oct  6 21:16:55 Aphrodite-Artemis postfix/qmgr[7520]: AA3C9CAEE4A: removed
    Oct  6 21:16:55 Aphrodite-Artemis postfix/bounce[8464]: EE56CCAEE4B: sender non-delivery notification: F165BCAEE4D
    Oct  6 21:16:55 Aphrodite-Artemis postfix/qmgr[7520]: F165BCAEE4D: from=<>, size=2609, nrcpt=1 (queue active)
    Oct  6 21:16:55 Aphrodite-Artemis postfix/qmgr[7520]: EE56CCAEE4B: removed
    Oct  6 21:16:55 Aphrodite-Artemis postfix/local[8465]: F165BCAEE4D: to=<[email protected]>, relay=local, delay=0.01, delays=0/0/0/0, dsn=2.0.0, status=sent
    Oct  6 21:16:55 Aphrodite-Artemis postfix/qmgr[7520]: F165BCAEE4D: removed
    
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. MiniMe

    MiniMe New Member

  6. falko

    falko Super Moderator ISPConfig Developer

    Do you have this problem for each external domain, or just for certain ones?
     
  7. MiniMe

    MiniMe New Member

    Yes, this problem exists for EVERY external domain which is not listed in that file i mentioned in the first post ...
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Which tutorial did you use to set up the system?

    Do you have valid nameservers in /etc/resolv.conf?

    Shouldn't you have a virtual_maps line in your main.cf (like virtual_maps = hash:/etc/postfix/virtusertable for ISPConfig 2)?
     
  9. MiniMe

    MiniMe New Member

    yes, in etc are correct working nameservers cuz all my services / dns requests work just fine

    i dont have a virtual maps line in my main.cf because i do not use ISPConfig ... in all honesty.

    The tutorial i followed i have no idea about anymore, it has been 2 years ago :( all i do know is, everything worked fine up till 4 weeks ago
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Can you post the output of
    Code:
    ls -la /etc/postfix/
    so that I see what other files you have?
     
  11. MiniMe

    MiniMe New Member

    yes, ofcourse here goes :

    Code:
    Aphrodite-Artemis:~# ls -la /etc/postfix
    total 112K
    drwxr-xr-x   4 root root 4.0K Jun  3 15:57 .
    drwxr-xr-x 111 root root  12K Oct  6 23:53 ..
    -rw-r--r--   1 root root  318 Oct 11  2009 dynamicmaps.cf
    -rw-r--r--   1 root root   46 Oct  6 22:57 local-host-names
    -rw-r--r--   1 root root 2.9K Oct  6 23:29 main.cf
    -rw-r--r--   1 root root 4.9K Apr 21  2010 master.cf
    -rw-r--r--   1 root root  19K May  4 21:17 postfix-files
    -rwxr-xr-x   1 root root 8.6K May  4 21:17 postfix-script
    -rwxr-xr-x   1 root root  24K May  4 21:17 post-install
    drwxr-xr-x   2 root root 4.0K Oct  6 20:01 sasl
    -rw-r--r--   1 root root  12K Oct 11  2009 sender_canonical.db
    drwxr-xr-x   2 root root 4.0K Oct 11  2009 ssl
    
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Hm, I was expecting some kind of file that contains the mailbox definitions, but that doesn't seem to exist...
     
  13. MiniMe

    MiniMe New Member

    hmmm :( , well its been always like that and i can promise you nothing has been altered...
     
  14. falko

    falko Super Moderator ISPConfig Developer

    I'm running out of ideas... :(
     
  15. MiniMe

    MiniMe New Member

    pitty :(
    postfix is poo :p
     

Share This Page