Problem with postfix, ISPconfig on a Strato vServer

Discussion in 'Server Operation' started by Been Told, Dec 2, 2008.

  1. Been Told

    Been Told Member

    I have the following setup that I recently installed ISPconfig on:
    vServer Strato
    Debian Etch
    ISPconfig 2.2.7
    The assumed domain name here is domain.tld
    My postfix/ is the following (xxxxx replaces the server name)
    Datei: /etc/postfix/
    myhostname =
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination =,,, localhost
    relayhost =
    mynetworks =
    mailbox_command =
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
    The Problem I am having is that when I try to send e-Mail via Outlook, I get the following e-mail back:
    Your message did not reach some or all of the intended recipients.
          Subject:	Wir prüfen
          Sent:	02.12.2008 16:35
    The following recipient(s) cannot be reached:
          '[email protected]' on 02.12.2008 16:35
                554 5.7.1 <[email protected]>: Relay access denied
    And the e-mail doesn't get sent.
    When I send an e-mail TO the account, I get the following e-Mail back:

    Reporting-MTA: dns;
    X-Postfix-Queue-ID: 5A3AD21838A
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Tue,  2 Dec 2008 16:51:02 +0100 (CET)
    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822;[email protected]
    Action: failed
    Status: 5.4.4
    Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
        for type=A: Host not found
    Now, this is only my second server I've ever administered and I may have made a misstake.
    On my other server, when ISPconfig asked me what server name and domain I wanted to use, I always used server1 as the server name and an assumed domain.tld the domain.
    But on this occasion I used instead of server1.domain.tld.

    Could that be the cause of the problem?

    I have added A records for, but the problem still exists.
  2. Been Told

    Been Told Member

    The relevant error message:
    Dec  2 21:15:06 XXXXXXXX courierpop3login: LOGIN, user=web1_email, ip=[::ffff:]
    Dec  2 21:15:06 XXXXXXXX courierpop3login: LOGOUT, user=web1_email, ip=[::ffff:], top=0, retr=0, rcvd=12, sent=39, time=0
    Dec  2 21:15:07 XXXXXXXX postfix/smtpd[9753]: connect from ******[]
    Dec  2 21:15:07 XXXXXXXX postfix/smtpd[9753]: NOQUEUE: reject: RCPT from ******[]: 554 5.7.1 <[email protected]>: Rela$
    Dec  2 21:15:07 XXXXXXXX postfix/smtpd[9753]: disconnect from ******[]
    XXXXXXXX is the server name.
  3. falko

    falko Super Moderator ISPConfig Developer

    You must enable "Server requires authentication" in your email client.

    What are the outputs of
    hostname -f
    and what's in /etc/hosts?
  4. Been Told

    Been Told Member

    It was enabled from the start.
    hostname and hostname -f both return:
    /etc/hosts is:
    Code:  localhost.localdomain localhost
    Thanks for your reply falko. :)
  5. Been Told

    Been Told Member

    Looks like the matter is settled. The guy I'm installing the server software for has decided to go with openSUSE and Plesk. Thanks for your help falko. :)

Share This Page