Problem with POSTFIX install - as per how-to

Discussion in 'HOWTO-Related Questions' started by joelee, Sep 7, 2006.

  1. joelee

    joelee New Member

    Hi All,

    I am new to linux and following the postfix install how-to from this link:
    http://howtoforge.com/virtual_postfix_mysql_quota_courier

    After doing step 1, all seems to go well until I tryed to do step 2 (Apply Quota Patch To Postfix).

    For step 2, When I try to enter the command:
    apt-get install build-essential dpkg-dev fakeroot debhelper libdb4.2-dev...etc...

    I get the following error msg:

    Err http://ftp.us.debian.org stable/main Packages
    Temporary failure resolving 'ftp.us.debian.org'
    Err http://ftp.us.debian.org stable/main Release
    Temporary failure resolving 'ftp.us.debian.org'
    Err http://ftp.us.debian.org stable/main Sources
    Temporary failure resolving 'ftp.us.debian.org'
    <SNIP>
    Failed to fetch http://ftp.us.debian.org/debian/dists/stable/main/binary-i386/Packages.gz Temporary failure resolving 'ftp.us.debian.org'
    Failed to fetch http://ftp.us.debian.org/debian/dists/stable/main/binary-i386/Release Temporary failure resolving 'ftp.us.debian.org'
    Failed to fetch http://ftp.us.debian.org/debian/dists/stable/main/source/Sources.gz Temporary failure resolving 'ftp.us.debian.org'
    Failed to fetch http://ftp.us.debian.org/debian/dists/stable/main/source/Release Temporary failure resolving 'ftp.us.
    <SNIP>

    After noticing the above errors I find that I can't do any apt-get update command. My source.list has not changed. Also, noticed that I can't ping any external or even my intenal IP address. When I tried to ping my local IP I get error:

    mx1:~# ping 192.168.1.103
    socket: No buffer space available

    I am puzzled by why I would get the error "No buffer space available".

    NOTE: I am doing this install on a VPS server using OpenVZ. Have not had a problem with this as I have other VPS server installed and running (DNS).
    FYI: I running on a debian sarge install!

    I trying to figure out if this is a VPS config issue or something with the how-to instructions.

    Any help would be appreciated!
    -joe
     
  2. jjw

    jjw New Member

    I was trying the Debian install and when I got the unable to resolve message, it was because I had the wrong eth tuuned on. what had been eth0 on Fedora was now eth1 on Debain (and vice-versa). I can't speak to the buffer issue, but are you sure the right eth device is up?

    Sorry if you already thought of this; I'm a noob here. :)
     
  3. joelee

    joelee New Member

    I seem to have been able to resolve the above problem by restarting networking. For some reason, it appears that after running the step1 first command after it installs the listed packages networking is somehow disabled.

    However, I am now running into 2 different problem. After running step 1, I observe the following error pertaining to mysql:

    Setting up mysql-client (4.0.24-10sarge2) ...
    Setting up mysql-server (4.0.24-10sarge2) ...
    Stopping MySQL database server: mysqld.
    Starting MySQL database server: mysqld...failed.
    Please take a look at the syslog.
    /usr/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (12)'
    Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!

    Setting up php4 (4.3.10-16) ...

    Setting up php4-mysql (4.3.10-16) ...

    The other error I am running into is after I run the command:
    > dpkg-buildpackage
    I get see the following errors:

    make: Leaving directory `/usr/src/postfix-2.1.5/src/postcat'
    [src/postconf]
    make: Entering directory `/usr/src/postfix-2.1.5/src/postconf'
    awk -f extract.awk ../*/*.c
    Inconsistency detected by ld.so: dl-minimal.c: 84: __libc_memalign: Assertion `page != ((void *) -1)' failed!
    make: *** [time_vars.h] Broken pipe
    make: *** Deleting file `time_vars.h'
    make: Leaving directory `/usr/src/postfix-2.1.5/src/postconf'
    make[1]: *** [update] Error 1
    make[1]: Leaving directory `/usr/src/postfix-2.1.5'
    make: *** [build] Error 2
    mx1:/usr/src/postfix-2.1.5#

    -Joe
     
  4. falko

    falko Super Moderator

    I think all these problems are due to the fact that you run an OpenVZ system...

    What's in the logs? What's the output of
    Code:
    ls -la /var/run/mysqld
    ?
     

Share This Page