problem with postfix during upgrade debian 8 to 9 :/

Discussion in 'Server Operation' started by bastard79, Jul 18, 2017.

  1. bastard79

    bastard79 New Member

    today i'm upgraded debian server to new stable 9, and my working ispconfig configuration now is broken, monitor show SMTP server is offline :/
    i dont know where is the problem, dont installed new config files, only upgrade packages. maybe need to upgrade new config master.cf ?

    some logs
    postfix: Postfix is running with backwards-compatible default settings
    postfix: See http://www.postfix.org/COMPATIBILITY_README.html for details
    postfix: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"
    postqueue: fatal: Cannot flush mail queue - mail system is down

    ps. sorry for my english
     
  2. sjau

    sjau Local Meanie Moderator

    after upgrading, did you select to reconfigure all the services again?
     
  3. bastard79

    bastard79 New Member

    hmm, when upgrading get question to restart services by apt or after restart, i choose by apt, but dont remeber question for reconfigure - maybe yes :(, only I just kept an eye on not to overwrite configuration files
     
  4. sjau

    sjau Local Meanie Moderator

    you can run the ispconfig update from the cli and then at the end you'll be asked to reconfigure services... select "y" to restore them back to default
     
  5. bastard79

    bastard79 New Member

    i'm upgrade ispconfig to 3.1.6
    one problem solved - must set sql_mode = NO_ENGINE_SUBSTITUTION to finish update, after that monitor says all services are running

    postfix status is
    ‚óŹ postfix.service - Postfix Mail Transport Agent
    Loaded: loaded (/lib/systemd/system/postfix.service; enabled; vendor preset: enabled)
    Active: active (exited) since Thu 2017-07-20 15:33:51 CEST; 4min 53s ago
    Process: 1246 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
    Main PID: 1246 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
    CGroup: /system.slice/postfix.service

    lip 20 15:33:51 hosting systemd[1]: Starting Postfix Mail Transport Agent...
    lip 20 15:33:51 hosting systemd[1]: Started Postfix Mail Transport Agent.


    but mailq says
    postqueue: fatal: Queue report unavailable - mail system is down

    i dont undarstand why :/
     
  6. sjau

    sjau Local Meanie Moderator

    no idea about that.
     

Share This Page