Problem with Postfix and SMTP port 25

Discussion in 'Installation/Configuration' started by laidbackwebsage, Feb 18, 2009.

  1. laidbackwebsage

    laidbackwebsage New Member

    I followed the "Perfect Hardy Heron Ubuntu Server" step by step, but I am still unable to access my remote SMTP server from my desktop (i.e., I cannot send a test email using Thunderbird.)

    The server resides on a VPS host, and I can send mail from the command line. However, I cannot connect to the SMTP server via Thunderbird, not can I telnet to port 25.

    How do I:
    1. Test if port 25 is open?
    2. Open it safely if it isn't?
    3. Change the port if my local ISP is blocking it?

    Thanks!

    Kevin J
     
  2. joel_griego

    joel_griego New Member

    If your server has local ip address for example 192.168.1.1 you can command to another local computer:
    telnet 192.168.1.1 25

    it should show the smtp greeting.

    If your ISP is blocking port 25, maybe you can consider using submission port.


    cheer,
    Joel
     
  3. falko

    falko Super Moderator

    What's the output of
    Code:
    netstat -tap
    ? any errors in your mail log?
     
  4. laidbackwebsage

    laidbackwebsage New Member

    Netstat and logs

    Here's the output of sudo netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:mysql *:* LISTEN 7856/mysqld
    tcp 0 0 *:www *:* LISTEN 9585/apache2
    tcp 0 0 <FQDN> *:* LISTEN 7318/named
    tcp 0 0 localhost:domain *:* LISTEN 7318/named
    tcp 0 0 *:smtp *:* LISTEN 11732/master
    tcp 0 0 localhost:953 *:* LISTEN 7318/named
    tcp 0 0 *:https *:* LISTEN 9585/apache2
    tcp6 0 0 [::]:imaps [::]:* LISTEN 9181/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 9088/couriertcpd
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 9023/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 9124/couriertcpd
    tcp6 0 0 [::]:ftp [::]:* LISTEN 11019/proftpd: (acc
    tcp6 0 0 [::]:domain [::]:* LISTEN 7318/named
    tcp6 0 0 [::]:ssh [::]:* LISTEN 3487/sshd
    tcp6 0 0 [::]:smtp [::]:* LISTEN 11732/master
    tcp6 0 0 ::1%##########:953 [::]:* LISTEN 7318/named
    tcp6 0 1200 <FQDN>:ssh ip###############:54923 ESTABLISHED 21688/sshd: ## [

    "mail.err" is empty, and "mail.log" loks fine. Saw something in "mail.info", though; what does this mean?

    Feb 18 20:26:30 mail imapd: chdir Maildir: No such file or directory

    BTW, many thanks, All, for your assistance!

    Kevin J
     
  5. falko

    falko Super Moderator

    Looks good.

    Is there a firewall that is blocking port 25?
     
  6. laidbackwebsage

    laidbackwebsage New Member

    Firewall?

    How do I tell? :p

    (Thanks.)

    Kevin J
     
  7. falko

    falko Super Moderator

    What's the output of
    Code:
    iptables -L
    ?
     
  8. laidbackwebsage

    laidbackwebsage New Member

    IP Tables output

    Here it is; I haven't set up any rules, yet, evidently:

    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
     
  9. falko

    falko Super Moderator

    Is the server located in a data center, or is it hosted on a DSL line or something similar? In the latter case, make sure that your ISP doesn't block port 25.
     
  10. laidbackwebsage

    laidbackwebsage New Member

    It's a virtual server that I have complete control over, other than assigning the IP address.

    I access the Internet via a high-speed connection through my cable company. At this point, I'm guessing they don't allow access to port 25 on any domain except their own.

    How do I tweak my postfix settings to allow access on a differetn port, and what ports would be suggested?

    Falko, thanks for your help; it is greatly appreciated.

    Kevin J
     
  11. joel_griego

    joel_griego New Member

    You can use submission port. Just modify your master.cf.

    Joel
     

Share This Page