problem with php 5.5 installation (

Discussion in 'Installation/Configuration' started by harryps, Aug 8, 2014.

  1. harryps

    harryps New Member


    I followed this tutorial

    but after installing the memcached extension and restarting php-fpm I get this warning

    NOTICE: PHP message: PHP Warning: PHP Startup: Unable to load dynamic library '/opt/php-5.5.7/lib/php/extensions/no-debug-non-zts-20121212/' - /opt/php-5.5.7/lib/php/extensions/no-debug-non-zts-20121212/ cannot open shared object file: No such file or directory in Unknown on line 0

    The file is not in the directory so how do I install the extension properly so I don't get this warning?

    Thanks for any help
  2. harryps

    harryps New Member

    figured it out :)

    reinstalled libmemcached and installed memcached again
    cd /opt/php-5.5.7/etc
    apt-get remove libmemcached-dev
    apt-get install libmemcached-dev
    pecl -C ./pear.conf install memcached

    the file should be in the right place now
  3. srijan

    srijan New Member HowtoForge Supporter

    Thanks for the update, so we can consider the thread as close.

Share This Page