problem with noexec in .htaccess

Discussion in 'Server Operation' started by gral, Sep 7, 2007.

  1. gral

    gral Member

    Hello everybody... im having trouble trying to config a directory without exec via .htaccess.. i 've read many .htaccess docs but i still with trouble to disable the exec in a directory..

    Here is my .htaccess

    <Directory "/var/www/folder/folder/folder">
    Options NoExec
    AllowOverride All

    Any tip to fix my problem will be very helpfully!!


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you get any error messages?
  3. gral

    gral Member

    Hey till, thanks a lot for your reply... buts nothing at all in the logs, nothing in the access or errorlog... is like this access never happend :(

    I still trying... any tip will be helpfully!


  4. falko

    falko Super Moderator ISPConfig Developer

    You must not use <Directory ...> in .htaccess files because the directives in an .htaccess file always refer to the directory where .htaccess is located. Also, Options and AllowOverride don't work in .htaccess. You must put these directives in the main Apache configuration.

Share This Page