Problem with mydnsconfig

Discussion in 'General' started by pmsfo, Feb 7, 2006.

  1. smelkomar

    smelkomar Guest

    Omg

    OMG, DNS server isn't working... I use IP 213.145.104.20 for Primary DNS under WinXP SP2 and there's "dns lookup error". What this mean... I speacially try this to check all is ok:
    Code:
    dig @213.145.104.20 www.google.com
    This is the output:
    Code:
    ; <<>> DiG 9.2.4 <<>> @213.145.104.20 www.google.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 3484
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.google.com.                        IN      A
    
    ;; ANSWER SECTION:
    www.google.com.         439902  IN      CNAME   www.l.google.com.
    www.l.google.com.       300     IN      A       216.239.59.104
    www.l.google.com.       300     IN      A       216.239.59.99
    www.l.google.com.       300     IN      A       216.239.59.147
    www.l.google.com.       300     IN      A       216.239.59.103
    
    ;; Query time: 352 msec
    ;; SERVER: 213.145.104.20#53(213.145.104.20)
    ;; WHEN: Mon Apr 10 14:31:59 2006
    ;; MSG SIZE  rcvd: 116
    This is the output from "mtr www.google.com":
    Code:
     My traceroute  [v0.67]
    mydns (0.0.0.0)(tos=0x0 psize=64 bitpattern=0x00)                                                    Mon Apr 10 14:35:28 2006
    Resolver error: No error returned but no answers given. of fields   quit
                                                                                         Packets               Pings
     Host                                                                              Loss%   Snt   Last   Avg  Best  Wrst StDev
     1. 213.145.104.7                                                                   0.0%    11    0.4   0.6   0.4   1.4   0.4
     2. 212.116.143.65                                                                  0.0%    11    1.5   2.3   1.2   5.3   1.3
     3. 213.145.99.42                                                                   0.0%    11    1.5   1.7   1.1   2.3   0.4
     4. ge1-3-0-255.sof1core1.pantel.net                                                0.0%    11    2.8   2.5   1.9   3.4   0.4
     5. ge-1-1-0.bud4core1.pantel.net                                                   0.0%    11   27.6  33.0  27.3  82.8  16.5
     6. bpt-b2-geth2-2.telia.net                                                        0.0%    11   28.2  28.1  27.1  29.0   0.7
     7. hbg-bb2-pos7-3-2.telia.net                                                      0.0%    11   49.5  48.5  48.0  49.5   0.5
     8. hbg-b2-link.telia.net                                                           0.0%    11   48.4  48.6  47.9  49.8   0.6
     9. google-110073-hbg-b2.c.telia.net                                                0.0%    11   51.2  54.0  50.7  75.1   7.1
    10. 66.249.95.135                                                                   9.1%    11   52.0  51.5  50.5  52.4   0.5
    11. 72.14.232.140                                                                   9.1%    11   50.9  51.4  50.6  53.0   0.8
    12. 216.239.43.90                                                                   0.0%    11   58.4  61.5  58.1  75.9   5.3
        216.239.48.146
    13. 66.249.95.164                                                                   0.0%    11   85.4  73.4  71.3  85.4   4.1
        216.239.49.254
    14. 64.233.174.43                                                                   0.0%    11   68.8  74.7  68.5 132.0  19.0
        216.239.48.158
    15. 64.233.174.186                                                                  0.0%    11   69.0  70.6  68.5  74.4   2.4
        64.233.174.18
    16. 64.233.174.14                                                                  20.0%    10   71.1  70.4  69.1  71.2   0.8
        66.102.9.99
    17. 66.102.9.99                                                                     0.0%    10   69.3  69.8  68.9  72.0   1.0
    What's goin' on?! :confused:
     
    Last edited by a moderator: Apr 10, 2006
  2. smelkomar

    smelkomar Guest

    Any ideas? :(
     
  3. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Try to use other nameservers, e.g. 145.253.2.75 and 193.174.32.18.
     
  4. smelkomar

    smelkomar Guest

    Different IPs for DNS like 212. and 213. or ...? For MyDNS 212.xxx.x... and for djdns 213.xxx.x... ?
     
    Last edited by a moderator: Apr 13, 2006
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    No, your Windows client PCs should use other name servers, e.g. 145.253.2.75 and 193.174.32.18.
     
  6. smelkomar

    smelkomar Guest

    Hmmm, I understood from the "howto" that this DNS server works and as usual DNS resolving machine? For my needs - for LAN with approx. 200 hosts
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Yes, if you configure it right. Make sure you tell your Windows client PCs to use the correct IP address (the one dnscache runs on, not MyDNS).
     
  8. smelkomar

    smelkomar Guest

    Somehow we're talking in diff. languages :D I use the correct IP address - 213.145.104.20, which is the dnscache's IP :eek: Look my post with "dig @213.145.104.20" and "mtr www.google.com" commands - with MTR there isn't answer but Resolver works :eek:
     
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I don't know why mtr isn't working, but if the resolver is working, then everything's fine.
     
  10. smelkomar

    smelkomar Guest

    Code:
    Resolver error: No error returned but no answers given
    Yes, reslover works... I don't know there is no answers, under the server and XP test machine :mad: Perhaps that I used v1.1.0 instead of 1.0.0 from "howto" :confused:
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is maybe your firewall preventing your resolver from doing his work?
     
  12. smelkomar

    smelkomar Guest

    Code:
    apt-get remove --purge iptables
    ???
     
  13. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Maybe your router's firewall?
     
  14. smelkomar

    smelkomar Guest

    OK, this morning I found something unusuall... When I use DNS 213.145.104.20 on machine with IP 10.10.1.3 from our internal network I can surf... but when I use it on machine with real static IP I can't :confused:
     
  15. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    This really looks like some kind of firewall problem...
     

Share This Page