Problem with my VPS and /etc/fstab

Discussion in 'Installation/Configuration' started by francx, Apr 16, 2012.

  1. francx

    francx New Member

    Hi!

    I try to install ISPConfig on my new VPS running on OpenVZ, but I have problem with /etc/fstab.

    /etc/fstab
    Code:
    # UNCONFIGURED FSTAB FOR BASE SYSTEM
    Have anyone solution for this?

    Thank you!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok, just skip the quota configuration step as quota is provided by the host system for your vps.
     
  3. francx

    francx New Member

    Must I install quota and quotatool?
     
  4. dclardy

    dclardy Member

    These do not need to be installed on the system, but they are required for limiting a user's resources. If you don't have that, then they can use as much as they want.

    If you don't install it, everything still works.
     
  5. francx

    francx New Member

    Thank you!
     
  6. francx

    francx New Member

    I have quotas problem. Virtual software is KVM.

    Code:
    proc /proc proc defaults 0 0
    none /dev/pts devpts gid=5,mode=620 0 0
    # /dev/hda1 during Installation (RescueSystem)
    UUID=20709486-1b7b-4f58-8014-32557739f4a0 none swap sw 0 0
    # /dev/hda2 during Installation (RescueSystem)
    UUID=fa4a5398-894e-4481-b179-91a56d09c788 /boot ext3 0 0
    # /dev/hda3 during Installation (RescueSystem)
    UUID=5b076400-defd-4c83-ae75-663777754c16 / ext4 defaults 0 0
    
    Can you please help me? How to setup quotas?
     
  7. falko

    falko Super Moderator ISPConfig Developer

  8. francx

    francx New Member

    Where must I add
    Code:
    ,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0
    ?

    I don't have
    Code:
    errors=remount-ro
    line.

    Is that ok?
    Code:
    proc /proc proc defaults 0 0
    none /dev/pts devpts gid=5,mode=620 0 0
    # /dev/hda1 during Installation (RescueSystem)
    UUID=70eab295-8d67-4a80-8448-1b0163be9a8b none swap sw 0 0
    # /dev/hda2 during Installation (RescueSystem)
    UUID=e40f7587-412c-4905-99dd-4748293f34a3 /boot ext3 defaults 0 0
    # /dev/hda3 during Installation (RescueSystem)
    UUID=66ca563b-447e-4efb-8828-75b2d5c510d0 / ext4 errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0     0
     
    Last edited: Apr 23, 2012
  9. dclardy

    dclardy Member

    Why does your system say Rescue-System? Did you install from a rescue cd? I would try to reinstall it.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Yes, looks good.
     
  11. zaphod beeblebrox

    zaphod beeblebrox New Member

    The content of my /etc/fstab is different from anything mentioned previously so I am unsure where to add the line ,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0

    I got
    proc /proc proc defaults 0 0
    none /dev/pts devpts rw,gid=5,mode=620 0 0
    none /run/shm tmpfs defaults 0 0
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    That's a fstab from a virtual machine which has no mount point for the hard disk. On such a system the quota has to be enabled on the host server for this VM. Ask your ISP to enable Linux filesystem quota for the VM and leave the fstab file unchanged.
     
    zaphod beeblebrox likes this.

Share This Page