problem with mx record and ispconfig

Discussion in 'Installation/Configuration' started by lrider, Nov 6, 2006.

  1. lrider

    lrider Member

    Hello,

    Some email programs will not send emails to domains that do not have a MX record.

    I have created and deleted a domain with all the combinations of options that I found regarding dns, and could not create the MX for the domain in question.

    I had to do it manually. Is there a way of doing it by default when I add a domain to a site or whe I create the site?

    Thank's in advance.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you enable the create MX checkbox when you created the website and the co-domain?
     
  3. lrider

    lrider Member

    Yes, I did so.
    But the only MX created was with the server hostname and domain.
    Example:

    ispconfig server hostname : "ns1"
    ispconfig server domain name: "activa-icard.com"
    new domain to add : www.telemara.com

    After I created the site the following appears in the DNS-Manager
    A Record
    Ip-Address Hostname
    195.76.213.194 www

    MX Record
    MailServer Hostname
    ns1.activa-icard.com www

    MX created to "ns1.activa-icard.com" instead of "www.telemara.com".
    With this configuration, some tools like the one present in www.checkdns.net show that there are no MX record for the domain created.
    (http://www.checkdns.net/quickcheck.aspx?domain=telemara.com&detailed=1).
     
  4. ego

    ego New Member

    My server does the same. I just go in and creat my own MX such as mail.fqdn.com, works well for me.

    the default goes to www.fqdn.com which works also, but I like the mail.fqdn.com

    I am no DNS expert, but has this domain been moved? It may take a bit for the dns to replicate before it starts showing correctly.
     
  5. lrider

    lrider Member

    Maybe I am not focusing correctly the problem.

    The problem is that whatever I do, it is not beeing recognised as a MX record unless I do it by hand.

    This is what I have to put in the DNS record for it to be recognised as a MX record.
    I also want to point out that I am not an expert in DNS so I may be doing something wrong.

    ******************************
    A Record
    Ip-Address.....Hostname
    -------------- -------------
    195.76.213.194 www
    195.76.213.194 mail IN
    MX
    MailServer........Hostname
    ----------------- -----------
    mail.telemara.com @ IN


    ******************************
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is that the automatic co-domain creation (the co-domain with empty host field) does not create a MX for this co-domain automatically.

    I've added it to our todo list.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    That's fine.
    Because you created an MX record for www.telemara.com, not telemara.com.
     
  8. lrider

    lrider Member

    I disagree.

    As you can see in the example I posted, the MX created was to "ns1.activa-icard.com" and not to "www.telemara.com".

    The domain I just added is "telemara.com".

    And it does not matter if you are creating a new domain or adding a co-domain.

    The problem is the same one.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    You created an MX record for www.telemara.com which points to ns1.activa-icard.com. What's the problem with this?
     
  10. lrider

    lrider Member

    No problem for it to be with other name (like ns1.activa-icard.com).

    The problem is that it is not beeing recognised as a MX record.

    Right now the domain "telemara.eu" is created with the default values of ispconfig.

    Check in the following places and see how it does not recognise the MX record.

    http://www.checkdns.net/quickcheck.aspx?domain=telemara.eu&detailed=1

    http://www.dnsreport.com/tools/dnsreport.ch?domain=telemara.eu

    This is a copy of the configuration of the DNS in ispconfig:

    A Record
    ------------------------------------------------------------------
    IP-Adresse Hostname
    195.76.213.194 www
    ------------------------------------------------------------------
    CNAME
    ------------------------------------------------------------------
    Hostname Target
    ------------------------------------------------------------------
    MX
    ------------------------------------------------------------------
    Mailserver Hostname
    ns1.activa-icard.com www
    ns1.activa-icard.com
    ------------------------------------------------------------------
    SPF
    ------------------------------------------------------------------
    Hostname
    ------------------------------------------------------------------
     
  11. falko

    falko Super Moderator ISPConfig Developer

    There's a problem with your NS records:

    Code:
    mh1:~# dig ns telemara.eu
    
    ; <<>> DiG 9.2.1 <<>> ns telemara.eu
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56991
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;telemara.eu.                   IN      NS
    
    ;; ANSWER SECTION:
    [B][COLOR="Red"]telemara.eu.            86386   IN      NS      195.76.213.194.
    telemara.eu.            86386   IN      NS      195.76.213.195.[/COLOR][/B]
    
    ;; Query time: 2 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Tue Nov 14 14:45:21 2006
    ;; MSG SIZE  rcvd: 85
    These must be FQDNs, not IP addresses.
     
  12. lrider

    lrider Member

    I am not sure what I have done, but things seem to be working ok now.

    Any way, I would sugest a new option:

    If you want a dns record for MX to choose between:

    your isponfig server (ns1.activa-icard.com on my case)
    or
    mail."your domain" (mail.telemara.eu)

    When you are serving diferent domains for privates, the prefer to have things personalised. (www.mydomain.com, ftp.mydomain.com, mail.mydomain.com, pop3.mydomain.com, smtp.mydomain.com, etc.).

    Thank's for the help given.
     

Share This Page