Problem with monitoring service freezed

Discussion in 'General' started by RioSif, Mar 8, 2012.

  1. RioSif

    RioSif Member

    Hello. I installed my vps server following the instructions of the perfect server tutorial centos 6.2+apache2.
    After making configurations for security etc and everything worked i yesterday saw that the monitoring service of the ispconfig is freezed. As an example:
    Code:
    Server Load (Server : mydomain.org)
    
    Data from: 2012-03-06 03:05Server online since:	3 days, 20:09 hours
    Users Online:	1
    System load 1 minute:	0
    System load 5 minutes:	0
    System load 15 minutes:	0
    and this is how it looks right now.
    Same "Data from" date for every report.

    What could go wrong? I'm taking rsnapsots backup. Is there any easy way to recover from those files? Some command maybe to say to copy and overwrite files from the backup over the original files which was modified after a specified date and time?

    Thank you
     
  2. till

    till Super Moderator

  3. RioSif

    RioSif Member

    I'll check that out and reply, thanks
     
  4. RioSif

    RioSif Member

    I think i found my problem. I caused this one :(
    Code:
    08.03.2012-11:08 - DEBUG - Found 2 changes, starting update process.
    PHP Parse error:  syntax error, unexpected '}' in /usr/local/ispconfig/server/lib/classes/monitor_tools.inc.php on line 128
    
    where can i find the default monitor_tools.inc.php?

    Will it need any change for my server?


    EDIT: I found and copied it from here http://fossies.org/unix/privat/ISPC...tall/server/lib/classes/monitor_tools.inc.php

    At the crontabs i have
    and not

    is that right or i have to make it log to cron.log?

    Problem is still there. There're no error at the log but logs are still stack at 6 of march 3am...
     
    Last edited: Mar 8, 2012
  5. RioSif

    RioSif Member

    I just checked ispconfig log:
    There should be some problem with mysql. Can you help me with a solution to this?

    Thanks
     
  6. RioSif

    RioSif Member

    It works!!
    The problem was with the monitor_tools.inc.php! The mysql errors had nothing to do with that.
     

Share This Page