Problem with main domain.

Discussion in 'General' started by xciso, Aug 28, 2011.

  1. xciso

    xciso New Member

    Hi.
    I have a few domains on my server with diffrent clients.
    The main domain i use for isp config is: (example) dot.com

    If i try to view dot.com i get "not found"
    I tryed to create a reseller and within the reseller account i create dns and a website for dot.com, but i cant view this site..

    What am i doing wrong?

    My nameservers is for example: ns1.dot.com and ns2.dot.com
    And i will use my domain dot.com to show up for clients/customer as "my" site.

    Big thanks!!
     
  2. mentes

    mentes New Member

    You need create a site for dot.com but don't need add it to any client or reseller, and of course you need to create a dns zone.

    What is the output of ...?

    Code:
    dig dot.com
    Code:
    dig www.dot.com
     
  3. xciso

    xciso New Member

    If i
    Code:
    dig www.mydomain.se
    Its just this i see, no ns:

    Code:
    ; <<>> DiG 9.7.3 <<>> www.mydomain.se
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 51446
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.mydomain.se.                    IN      A
    
    ;; Query time: 4 msec
    ;; SERVER: 79.99.4.100#53(79.99.4.100)
    ;; WHEN: Mon Aug 29 09:36:15 2011
    ;; MSG SIZE  rcvd: 28
    
    server1:~# dig mydomain.se
    
    ; <<>> DiG 9.7.3 <<>> mydomain.se
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 45570
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mydomain.se.                                IN      A
    
    ;; Query time: 5 msec
    ;; SERVER: 79.99.4.100#53(79.99.4.100)
    ;; WHEN: Mon Aug 29 09:36:21 2011
    ;; MSG SIZE  rcvd: 24
    
    If i look in the file /etc/resolv.conf i see the ip above (79.99.4.100), but i dont own this ip, this ip owns by my isp.
    This server is a OpenVz vps.
    Should i change in resolv.conf to my real ip number that i own for my vps?

    But why are every other domains i have working perfect?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    If this is your ISP's nameserver, then this is correct.

    Please check your domain on www.intodns.com
     
  5. mentes

    mentes New Member

    Your DNS are not configured.

    You need to create an A records, at least one like this:

    A mydomain.se. 11.22.33.44

    Where 11.22.33.44 is the server ip.

    You can check your DNS configurations with intodns.com & dig command.

    When DNS is well configured you will get output dig command like this:

    ispconfig.org. 86400 IN A 78.46.59.59
     
  6. xciso

    xciso New Member

    The ip above is my isp nameservers. I want to have my own ns so i change this in resolv.conf.
    My domain are now working, but i dont se any ns if i do "dig w..b..h-se"
    (ofcurse without all the dots) My own ip is 79...99...6...201
     
  7. mentes

    mentes New Member

    For have your own nameservers, delegate your ip in your domain register and then you need create a dns records, like:

    A ns1 11.22.33.44
    A ns2 11.22.33.55
     
  8. xciso

    xciso New Member

    Hi.
    I have now set it like this:
    [​IMG]

    Right or wrong?
     
  9. mentes

    mentes New Member

    Wrong, but don't worry. DNS are a headache for me too.

    Edit this records:

    A ns1.wbh.se 79.99.6.201

    It should be:

    A ns1 79.99.6.201

    The others seems well.

    Do you have one ip only?
     

Share This Page