Problem with maildrop: Unable to create a dot-lock

Discussion in 'General' started by mislav, Nov 29, 2012.

  1. mislav

    mislav New Member

    First of all, hello to all!

    I've searched google and forums and I've found tons of problems/solutions/threads regarding this problem, but none of them was solution to my problem or I'm doing something wrong.

    So for start, this is the my actual problem:
    # cat /var/log/mail.log | grep "[email protected]"

    Log is full of this kids of errors.

    Please note that:
    - all mailboxes are created from ISPConfig itself
    - this problem occures only for one e-mail address
    - e-mails are not received
    - there is no spam filter activated on any created mailbox
    - whole /var/vmail is chown recursively vmail:vmail

    Result from:
    # ls -la /usr/bin/maildrop
    # grep vmail /etc/passwd
    Folder for this account has path like this (and other email accounts also):

    ISPConfig -> System -> Server Config -> server -> tab "Mail":
    [​IMG]


    Server was install through this tutorial:
    http://www.howtoforge.com/perfect-server-debian-squeeze-with-bind-and-courier-ispconfig-3-p3

    My /etc/postfix/main.cf:
    And /etc/postfix/master.cf:
    If there is anything else that could help with finding solution, please let me know. Thanks in advance to all.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The most likely reason for this issue are file permission problems. Run:

    chown vmail:vmail /var/vmail/<DOMAIN.COM>

    to fix them
     
  3. mislav

    mislav New Member

    As i mentioned.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    have you tried to delete the affected mailbox and then recreate it?
     
  5. mislav

    mislav New Member

    No, i don't have permission from client to do that.
     
  6. mislav

    mislav New Member

    Hello, I've noticed on server same problem:
    I've checked in /var/vmail and this folder/user didn't exist, but as suggested here:
    http://www.cyberciti.biz/tips/force-sendmail-to-deliver-a-message-in-sendmails-mail-queue.html

    i run the command:
    # sendmail -v -q

    and e-mail was sent/folder/user was created in /var/vmail.

    Any idea what is the problem here ?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

  8. mislav

    mislav New Member

    Linux 2.6.32-5-amd64 x86_64

    Distributor ID: Debian
    Description: Debian GNU/Linux 6.0.6 (squeeze)
    Release: 6.0.6
    Codename: squeeze

    ISPConfig 3.0.4.6

    Cronjobs runs and write on disk every one minute.

    Email - courier

    When I tried to send e-mail from webmail, mail didn't pass. When i wrote:
    # mailq

    i saw this:
    Same problem in /var/log/mail.log.

    Solved problem as explained above.
     
    Last edited: Jan 7, 2013

Share This Page