Problem with mail server and subdomains

Discussion in 'General' started by MyKE, Feb 25, 2010.

  1. MyKE

    MyKE New Member

    Hi.

    My first problem is with subdomain. I create subdomain example. host.wzk.cz and it works. When i try www.host.wzk.cz it doesn't work. I must create always 2 subdomains, first host and second www.host. Do you know how to create subdomains automaticaly with www? There are my records (correct):

    [​IMG]

    Second problem is with mail server. I followed The Perfect Server Ubuntu 8.10 ISPConfig 3. I create e-mail domain with users... I go to my local ip 192.168.1.7/mailbox because domain/webmail doesn't work (i don't know later i will search problem), and login to mailbox. I send mail and he doesn't come to destination. And receiving same as send. Monitor is ok:

    SMTP-Server: Online
    POP3-Server: Online
    IMAP-Server: Online

    But Mail-Queue:

    Code:
    .
    .
    .
    
    0851B61932 995 Thu Feb 25 17:50:35 www-data@server
    (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    warezwinz@xxx.com
    
    02F6961800 887 Wed Feb 24 08:47:46 www-data@server
    (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    kajo0123@xxx.sk
    
    22225617FC 982 Wed Feb 24 08:47:47 www-data@server
    (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    warezwinz@xxx.com
    
    DBB6461934 896 Thu Feb 25 17:50:35 www-data@server
    (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    popchoc18@xxx.cz
    
    553CC61770 985 Sun Feb 21 19:03:08 www-data@server
    (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    warezwinz@xxx.com
    
    836F6617FD 906 Sun Feb 21 22:00:59 www-data@server
    (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    xgadgetsk@xxx.com
    
    -- 30 Kbytes in 22 Requests.
    
    And Mail-Log:

    Code:
    .
    .
    .
    .
    Feb 25 18:00:01 server postfix/smtpd[32185]: connect from localhost[127.0.0.1]
    Feb 25 18:00:01 server postfix/smtpd[32185]: lost connection after CONNECT from localhost[127.0.0.1]
    Feb 25 18:00:01 server postfix/smtpd[32185]: disconnect from localhost[127.0.0.1]
    Feb 25 18:01:26 server postfix/scache[32149]: statistics: start interval Feb 25 17:58:06
    Feb 25 18:01:26 server postfix/scache[32149]: statistics: domain lookup hits=0 miss=2 success=0%
    Feb 25 18:01:26 server postfix/scache[32149]: statistics: address lookup hits=0 miss=2 success=0%
    Feb 25 18:05:01 server pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 25 18:05:01 server pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Feb 25 18:05:01 server imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 25 18:05:01 server imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Feb 25 18:05:01 server postfix/smtpd[32279]: connect from localhost[127.0.0.1]
    Feb 25 18:05:01 server postfix/smtpd[32279]: lost connection after CONNECT from localhost[127.0.0.1]
    Feb 25 18:05:01 server postfix/smtpd[32279]: disconnect from localhost[127.0.0.1]
    Feb 25 18:08:06 server postfix/qmgr[24051]: 0851B61932: from=, size=995, nrcpt=1 (queue active)
    Feb 25 18:08:06 server postfix/qmgr[24051]: DBB6461934: from=, size=896, nrcpt=1 (queue active)
    Feb 25 18:08:06 server postfix/smtp[32309]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Feb 25 18:08:06 server postfix/smtp[32311]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Feb 25 18:08:06 server postfix/smtp[32309]: 0851B61932: to=, relay=none, delay=1051, delays=1051/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Feb 25 18:08:06 server postfix/smtp[32311]: DBB6461934: to=, relay=none, delay=1051, delays=1051/0.03/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Feb 25 18:10:01 server imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 25 18:10:01 server imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Feb 25 18:10:01 server pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 25 18:10:01 server pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Feb 25 18:10:01 server postfix/smtpd[32351]: connect from localhost[127.0.0.1]
    Feb 25 18:10:01 server postfix/smtpd[32351]: lost connection after CONNECT from localhost[127.0.0.1]
    Feb 25 18:10:01 server postfix/smtpd[32351]: disconnect from localhost[127.0.0.1]
    
    And last Mail-Warn:

    Code:
    Feb 21 17:27:52 server postfix/smtpd[19738]: warning: 113.190.184.239: address not listed for hostname localhost
    Feb 24 12:30:53 server postfix/smtpd[8607]: warning: 113.168.161.95: address not listed for hostname localhost
    
    Thanks for support.
     
  2. till

    till Super Moderator

    Thats the way the internet domain name system works. You have to create a record befoire you can use it.

    Regarding your mail problem: Post the output of:

    hostname

    and

    hostname -f
     
  3. MyKE

    MyKE New Member

    Output:
    admin@server:~$ hostname
    server
    admin@server:~$ hostname -f
    server



    I thought that * in cname automaticaly add www. Is another way how to automaticaly add www in records?

    Thanks
     
  4. till

    till Super Moderator

    Server is not a valid fqdn which causes amavisd to stop. Please enter a full hostname like:

    server.example.com

    into the file /etc/hostname and then run:

    hostname -F /etc/hostname

    and then restart amavisd and postfix.

    Regarding your other problem. I just checked it and the problem that you have is not related to dns at all. Every subdomain of wzk.cz is pointing to yor server lready. I guess you just missed to enable auto subdomain www for the website and aliasdomain that you created.
     
  5. MyKE

    MyKE New Member

    ok I edited /etc/hostname to server.wzk.cz then run hostname -F /etc/hostname and restarted postfix and amavis.

    Then i restart amavis, says:

    admin@server:~$ sudo /etc/init.d/amavis restart
    Stopping amavisd: amavisd-new.
    Starting amavisd: head: „/etc/mailname“ can't open for read: No such file or directory
    amavisd-new.

    Is this error or only warning?
     
  6. till

    till Super Moderator

    Looks as if the file /etc/mailname was deleted on your system. Thats not a big problem as /etc/mailname contains the same then /etc/hostname. So run:

    cp /etc/hostname /etc/mailname

    and restart amavisd
     
  7. MyKE

    MyKE New Member

    Thanks till! Last 6 months i had problem with our mail system. After ISPConfig and your help it works :eek:! Thank you till! Thank you till! :D
     
  8. MyKE

    MyKE New Member

    Hi till i have next problem. Yesterday i changed hostname and next day all works but in ISP Cron-log were warnings. I deleted them and reboot server and i thought that isp-cron log any problems and nothing logged... There is log:

    [​IMG]

    I saw in log that server "can't update" and I run:


    Code:
    root@server:~# apt-get update
    Err http://cz.archive.ubuntu.com karmic Release.gpg
      Unable to connect to cz.archive.ubuntu.com:80 (217.31.205.123). - connect (111: Connection refused)
    Err http://cz.archive.ubuntu.com karmic/main Translation-cs
      Unable to connect to cz.archive.ubuntu.com:80 (217.31.205.123). - connect (111: Connection refused)
    Cíl http://security.ubuntu.com karmic-security Release.gpg
    .
    .
    .
    
    Can't update but ping works.


    And in log was: apache2 Could not reliably determine.... When i restart apache there is not this error. I don't know what is this...

    Do you know where is problem? Thanks.

    //EDIT: i look in isp cron log and there is only :
    In picture what i send perhaps was old log with apache domain name etc before hostname update....

    //EDIT: it works not problem... Sorry. Maybe upgrade server error....
     
    Last edited: Feb 26, 2010

Share This Page