Problem with mail permissions

Discussion in 'Installation/Configuration' started by tecnea, Dec 6, 2011.

  1. tecnea

    tecnea New Member

    I Have a ISPconfig server (wich I'd setup a few months ago with the perfect server guide with debian lenny + dovecot + bind + ISPConfig Version: 3.0.3.3) and is working great. Now I'm setting up a new server (with better hardware) with debian squeeze + dovecot + bind + ISPConfig 3.0.4. In the new one I have problems with mails. When I create a mail box, the system create the folder in /var/vmail with root as owner:group (in the other server the mailboxes are created as vmail:vamil owner:gropup) and I have to changue owner/group to make this box work. I'd found a thread (http://www.howtoforge.com/forums/showthread.php?t=52164) that says that could be the configuration under system > server config > email > dovecot; but I had dovecot selected. Any Ideas??

    Thank in advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You should update your server to the latest ISPConfig version, which is 3.0.4.1. The thread you mentioned applies to ISPConfig 3.0.3.2 only.
     
  3. tecnea

    tecnea New Member

    It's updated, I'm setting up a new server and I'd installed the last version of ISPconfig, and I'm having this error with ISPConfig 3.0.4.1
     
    Last edited: Dec 7, 2011
  4. cbj4074

    cbj4074 Member HowtoForge Supporter

    I'm using ISPConfig 3.0.4.1, too, and my setup is virtually identical to yours, tecnea.

    However, when I create a new mailbox, the owner:group is vmail:vmail, as expected.

    In ISPConfig, when you browse to System -> Server Config -> example.com -> Mail tab, what values appear for "Mailuser Name" and "Mailuser Group"? root:root or vmail:vmail?
     
    Last edited: Dec 7, 2011
  5. tecnea

    tecnea New Member

    Thanks for your replys cbj4070 and till.The values in System -> Server Config -> example.com -> Mail tab are vmail:vmail for "Mailuser Name" and "Mailuser Group"
     
  6. tecnea

    tecnea New Member

    I'd changed the values for mailuser name and mailusergoup in System -> Server Config -> example.com -> Mail tab for another user and another group and then change again for vmail:vmail and now the mal folders for mailuser are created with vmail:vamil; but my problem persists. Because when you create a mailbox (for example "[email protected]") the system creates a folder in /var/vmail named "mydomain.com" and inside this folder creates another one for "someuser". Well my system now is creating the folder "someuser" as vmail:vmail, but creates the folder "mydomain.com" as root:root and the mail system still not work. If I change the owner:group for vmail:vmail of "mydomain.com" the mail server works

    (sorry if there are some errors, my english is not the best; I speak spanish)
     
  7. cbj4074

    cbj4074 Member HowtoForge Supporter

    Okay, so the fundamental issue here is that you changed the default values on the Mail tab and it caused problems with the permissions on /var/vmail, but you later changed the values back to what you thought were the defaults, yet the problem is not resolved.

    More specifically, after changing the values back to the presumed defaults, newly-created /var/vmail/example.com directories have root:root ownership. So, it is then necessary to change the the ownernship to vmail:vmail, at which point you are able to create new mailboxes that have the correct vmail:vmail ownership, e.g., at /var/vmail/example.com/webmaster.

    Is all of this correct?

    If so, what values do you have for "Mailuser UID" and "Mailuser GID" on that Mail tab? 5000 for both?
     
  8. tecnea

    tecnea New Member

    cbj4074 the problem begans after finishing the perfect server guide (http://www.howtoforge.com/perfect-server-debian-squeeze-with-bind-and-dovecot-ispconfig-3) because I realized that mailboxes doesn't work. Then, trying to fix this I changed the default values on the Mail tab. I Know the default values of setup and permissions because I can see them in my other server (remember that I said that I have one ISPconfig server working great and I'm setting up another one with better hardware to migrate my sites and mailboxes) I'm thinking about setting up the server again because I tried the perfect server guide in a couple of virtual machines and everything works and when I'd setup my first server (the one that is working perfect) everything works instantly.
    The values for "Mailuser UID" and "Mailuser GID" on the Mail tab are both 5000
     
  9. cbj4074

    cbj4074 Member HowtoForge Supporter

    Unfortunately, I'm not sufficiently familiar with the inner-workings of ISPConfig to offer additional help.

    Given that we've already spent so much time troubleshooting, I would just start over. It's possible that a fundamental step was missed the first time.
     
  10. tecnea

    tecnea New Member

    Ok cbj4074.... thanks anyway. I would try to start over
     

Share This Page