Problem with loop?

Discussion in 'General' started by erkan, May 15, 2012.

  1. erkan

    erkan New Member

    I have just set up a new VPS server with Debian 6 and ISPConfig

    I followed this guide:

    The problem is that the server is consuming all of my RAM. It doesn´t matter if I give the server more RAM it just keeping eating it.

    The strange thing is that I have no working site on the server yet but it still eats up my RAM. The only thing I have installed are what the guide says I should install.

    My VPS host says that it maybe is apache that is eating the RAM, some kind of loop?

    Is there something I can do to find out what is causing this?
  2. dclardy

    dclardy Member

    How much ram are you trying to install this on?
  3. erkan

    erkan New Member

    At first 1,5 GB. It worked fine for a few hours but after that it had eaten it all up. So then I changed it up to 2 GB, and then to 3 GB and then to 4 GB. It consumed that to.
  4. erkan

    erkan New Member

    Maybe I should mention that if I restar apache then all RAM memory is free again but after a few hours it fills up again.
  5. falko

    falko Super Moderator ISPConfig Developer

  6. erkan

    erkan New Member

    No I don´t have munin, how do I install and use that?

    I don´t use xcaxhe or apc, I think. No I haven´t done anything with my apache, just installed it.

    It worked fine och another server that runs EHCP sp I thought it would work fine with ISPConfig also.
  7. erkan

    erkan New Member

  8. erkan

    erkan New Member

    I have put a test site on my server with ISPConfig now but the site is really unstable:

    Most of the time it won´t load and from time to time the server CPU goes up to 200% load.

    I managed to get the RAM under control by changing the FastCGI Children and FastCGI max request to 4 and 200.

    But something must be very wrong in the server configuration since the site won´t load most of the time and gives me internal server error sometimes.

    It seems only to be unstable when i am using fcgi. Instead of mod_php.
  9. falko

    falko Super Moderator ISPConfig Developer

Share This Page