Problem with Link

Discussion in 'ISPConfig 3 Priority Support' started by Quaxth, Jun 29, 2017.

  1. Quaxth

    Quaxth Member

    Get the following error:
    checking for cURL support... yes
    checking for cURL in default path... not found
    configure: error: Please reinstall the libcurl distribution -
    easy.h should be in <curl-dir>/include/curl/
    [email protected]:/usr/local/src/php5-build/php-5.6.30#
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    first make, then make install.
     
  3. Quaxth

    Quaxth Member

    OK, what's about that libcurl distribution of that error above?
    Thanks.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ok, so you have to install curl and then run the configure again.

    apt-get install curl libcurl3
     
  5. Quaxth

    Quaxth Member

    got the same error again after running apt-get install curl libcurl3 and configure:
    checking for cURL in default path... not found
    configure: error: Please reinstall the libcurl distribution -
    easy.h should be in <curl-dir>/include/curl/
    [email protected]:/usr/local/src/php5-build/php-5.6.30# checking whether to enable calendar conversion support... yes
    checking for cURL in default path... not found
    configure: error: Please reinstall the libcurl distribution -
    easy.h should be in <curl-dir>/include/curl/
    [email protected]:/usr/local/src/php5-build/php-5.6.30#
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Try this:

    cd /usr/local/include
    ln -s /usr/include/x86_64-linux-gnu/curl curl
    apt-get install libcurl4-gnutls-dev
    cd /usr/local/src/php5-build/php-5.6.30

    and then configure again.
     
  7. Quaxth

    Quaxth Member

    Now I get this:
    [email protected]:/usr/local/src/php5-build/php-5.6.30# cd /usr/local/include
    [email protected]:/usr/local/include# ln -s /usr/include/x86_64-linux-gnu/curl curl
    [email protected]:/usr/local/include# apt-get install libcurl4-gnutls-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Suggested packages:
    libcurl4-doc libcurl3-dbg libgnutls28-dev libldap2-dev librtmp-dev libssh2-1-dev
    The following packages will be REMOVED:
    libcurl4-openssl-dev
    The following NEW packages will be installed:
    libcurl4-gnutls-dev
    0 upgraded, 1 newly installed, 1 to remove and 2 not upgraded.
    Need to get 371 kB of archives.
    After this operation, 6,144 B disk space will be freed.
    Do you want to continue? [Y/n] y
    Abort.
    [email protected]:/usr/local/include#
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    not sure why it was aborted, maybe you hit a wrong key. try to run these commands again:

    apt-get install libcurl4-gnutls-dev
    cd /usr/local/src/php5-build/php-5.6.30
     
  9. Quaxth

    Quaxth Member

    Had run configure now and that needed much longer. It ended up with no errors!! Now I'll run make and make install
     
  10. Quaxth

    Quaxth Member

    A lot of errors now! Please look the attached file.
    What that? Thanks.
     

    Attached Files:

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, ok. Probably because I installed gnutls above instead of openssl.

    Please try this:

    apt-get install libcurl4-openssl-dev

    then:
    cd /usr/local/src/php5-build/php-5.6.30
    make clean

    and then the configure command again and then make.
     
  12. Quaxth

    Quaxth Member

    Thanks Till. Is on working now with configure gone ok, no error, now on MAKE and MAKE INSTALL!

    But noe get an error again:
    Code:
    Makefile:635: recipe for target 'ext/openssl/openssl.lo' failed
    make: *** [ext/openssl/openssl.lo] Error 1
    [email protected]:/usr/local/src/php5-build/php-5.6.30# make install
    
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, it might be that the OpenSSL version of Debian 9 is too new for this php version. I guess that's nothing that we can solve here on the fly. Maybe you have to try to find some precompiled old php versions for Debian 9 or check out if the guys from phpbrew have a version of their scripts for Debian 9 or wait until I find the time to make a tutorial for php compilation. I asked @Croydon as well as I know he has a PHP compile script in use but he was not sure if it is compatible with Debian 9 yet, it might be that he posts here later today after he tested it.
     
  14. Quaxth

    Quaxth Member

    OK and thanks a lot for the help.
    I'll stop with this for now and maybe I need to go back to Debian 8(?) if more errors occurring with PHP7! Will see what Croydon will have to say.

    Maybe I try to get the old server back working, need only to connect that HDD and start up! Just the problem with MySQL and so on!!

    Enough for today, it's already near midnight (again) and I've to wake up early!

    Again, thanks a lot and have a good night and Weekend to come. Cheers!
     
  15. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Try this script (chmod to 700 and run as root or via sudo!). Apart from this my opinion is that you should not have your own server hosting websites when you are not used to administrating the OS. You will run into problems sooner or later (sooner, I assume).

    As openssl 1.1 is not supported by PHP 5.6 openssl extension, you need to compile an older openssl version. Limitations: I could not get the imap extension to run, yet. So it is excluded.

    Code:
    #!/bin/bash
    
    PHPVERS="5.6.30"
    FPM="yes";
    
    apt-get install -q -y libapache2-mod-fcgid apache2-suexec-custom libpcre3-dev libpcre++-dev libpng12-0 libbz2-dev libcurl4-openssl-dev libc-client2007e-dev libjpeg-dev libgif-dev libgif4 libpthread-stubs0-dev libx11-dev libxau-dev libxcb1-dev libxdmcp-dev libxpm-dev x11proto-core-dev x11proto-input-dev x11proto-kb-dev xtrans-dev libxml2-dev libmysqlclient-dev libfreetype6-dev libmcrypt-dev libpq-dev libxslt-dev libkrb5-dev libldap2-dev libmagickwand-dev
    
    
    if [[ ! -d "/opt/openssl" ]] ; then
       cd /tmp
       wget "https://www.openssl.org/source/old/1.0.1/openssl-1.0.1t.tar.gz"
       tar xzf openssl-1.0.1t.tar.gz
       cd openssl-1.0.1t
       ./config shared --prefix=/opt/openssl
       make -j $(nproc) && make install
       ln -s /opt/openssl/lib /opt/openssl/lib/x86_64-linux-gnu
       
       echo "/opt/openssl/lib" > /etc/ld.so.conf.d/openssl.conf
       ldconfig
    fi
    
    
    cd /tmp
    if [[ ! -d "php-${PHPVERS}" ]] ; then
       if [[ -e "/tmp/php.tar.bz2" ]] ; then
         rm -v /tmp/php.tar.bz2 ;
       fi
    
       wget "http://de.php.net/get/php-${PHPVERS}.tar.bz2/from/this/mirror" -O php.tar.bz2
    
       if [[ ! -s "/tmp/php.tar.bz2" ]] ; then
         exit 1;
       fi
       tar xjf php.tar.bz2
    fi
    
    mkdir /usr/include/freetype2/freetype
    ln -s /usr/include/freetype2/freetype.h /usr/include/freetype2/freetype/freetype.h 2>/dev/null
    
    cd php-${PHPVERS}
    
    FCGIFPM="--enable-fastcgi --enable-fpm"
    PHPPATH=php56 ;
    CONFIGURE="--enable-libxml --enable-session --enable-xml --enable-simplexml --enable-filter --disable-debug --enable-inline-optimization --disable-rpath --disable-static --enable-shared --with-pic --with-gnu-ld --with-mysql --with-gd --with-jpeg-dir --with-png-dir --with-xpm-dir --enable-exif --with-zlib --with-bz2 --with-curl --with-mysqli --with-freetype-dir --enable-soap --enable-sockets --enable-calendar --enable-ftp --enable-mbstring --enable-gd-native-ttf --enable-bcmath --enable-zip --with-pear --with-openssl=/opt/openssl --with-kerberos --enable-phar --enable-pdo --with-pdo-mysql --with-mysqli --with-mcrypt --enable-pcntl --enable-mbregex --enable-sysvsem --enable-sysvshm --with-gettext --with-mhash --with-pcre-regex --with-pdo-pgsql --with-pgsql --with-xmlrpc --with-xsl --with-zlib-dir --enable-opcache  ${FCGIFPM}" ;
    
    LIBDIR="lib/i386-linux-gnu"
    CHECK=`uname -a | grep -E '(amd64|x86_64)'`
    if [[ "$CHECK" == "" ]] ; then
      # 32 bit
      if [[ ! -e "/usr/lib/i386-linux-gnu/libc-client.a" ]] ; then
      ln -s /usr/lib/libc-client.a /usr/lib/i386-linux-gnu/libc-client.a ;
      fi
      ln -s /usr/include/i386-linux-gnu/curl /usr/include/curl 2>/dev/null
    else
      # 64 bit
      if [[ ! -e "/usr/lib/x86_64-linux-gnu/libc-client.a" ]] ; then
      ln -s /usr/lib/libc-client.a /usr/lib/x86_64-linux-gnu/libc-client.a ;
      fi
       ln -s /usr/include/x86_64-linux-gnu/curl /usr/include/curl 2>/dev/null
       
      LIBDIR="lib/x86_64-linux-gnu" ;
    fi
    
    ./configure --prefix=/opt/${PHPPATH} --datadir=/opt/${PHPPATH} --mandir=/opt/${PHPPATH} --bindir=/opt/${PHPPATH} --with-libdir=${LIBDIR} --includedir=/opt/${PHPPATH} --sysconfdir=/opt/${PHPPATH}/etc --with-config-file-path=/opt/${PHPPATH}/etc --with-config-file-scan-dir=/opt/${PHPPATH}/etc/conf.d ${CONFIGURE};
    
    make -j $(nproc) && make install
    
    exit 0;
    
     
  16. Quaxth

    Quaxth Member

    Sorry for not answer before! I just back from up Country.

    At this moment I got some more problems with my own Server and another Server also running Debian (just 8, Jessie) and ISPConfig 3.1.3.

    Now I face a problem with to be able to start Softaculous from within ISPConfig. It was working just fine on the other Server, with no problems and my own Server on Debian 9 Stretch with problems of PHP7, just Softaculous was accessible.
    Just at Saturday evening, as I was trying to run Softaculous for to install some script, I wasn't able to start Softaculous and got an error: "Forbidden: You don't have permission to access /softaculous on this server."
    So, I was thinking it's a browser problem and deleted the browsing data include Cookies and temp file etc.! Same problem! Started the first time MS Edge browser: SAME! Took my Tablet, which works with 4G and a different ISP and Network: SAME! Then I was trying to access Softaculous on my Friend Server: SAME!

    I'm now in touch with the Softaculous people about that! Maybe I also will have to go back with my own Server to Debian 8 Jessie, because of those PHP7 Problems anyway! Just, what is really suspicious, is that I face the same problem with that Server of my Friend! THAT, I couldn't understand.

    Thanks.
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you able to access softacolous by tyoing in the full url in the browser manually?
     
  18. Quaxth

    Quaxth Member

    NO!
    Firstly I need to open ISPConfig, which works ok, then I have to click Tools following by Softaculous. Done that I get the permission error! Same happens if I just use the direct link https://[public IP or domain]:8899/softaculous
    I delete all browsing data, cookies and temp files also, the outcome the same error!
     
  19. HSorgYves

    HSorgYves Active Member HowtoForge Supporter

    zsalab (https://github.com/zsalab) has recently created a pull request (https://github.com/php/php-src/pull/2667) to improve the OpenSSL compatibility in php 5.6(.31). Using the attached patch file for php 5.6.31 you will be able to compile it against default Stretch packages (i.e. no need to compile a custom openssl).
     

    Attached Files:

    till likes this.

Share This Page