problem with lighttpd + php + python for trac

Discussion in 'Server Operation' started by asaso, May 12, 2009.

  1. asaso

    asaso New Member

    Hey guys,
    you are doing a great work here, keep it up :)
    I am having a configuration problem trying to use lighttpd with php and python for my trac installation.
    It is related to FastCGI Configuration as looks like there is some thing wrong with the parentheses ! :confused:
    here is the config in lighttpd.conf

    Code:
        226 #/# FastCGI Configuration
        227 var.fcgi_binary="/usr/lib/python2.4/site-packages/trac/web/fcgi_frontend.py"
        228 fastcgi.server = ( ".php" => ((
        229                      "bin-path" => "/usr/bin/php-cgi",
        230                      "socket" => "/tmp/php.socket"
        231                  )))
        232 #/# Configurations for Trac
        233                  ( "trac" =>
        234                         ("trac" =>
        235                           ("socket" => "/tmp/trac-fastcgi.sock",
        236                             "bin-path" => fcgi_binary,
        237                             "check-local" => "disable",
        238                             "bin-environment" =>
        239                                ("TRAC_ENV_PARENT_DIR" => "/srv/www/trac")
        240                           )
        241                         )
        242                  )
    now when i restart the service, i get the following error
    Code:
    Starting lighttpd: 2009-05-12 16:56:02: (configfile.c.864) source: /etc/lighttpd/lighttpd.conf line: 233 pos: 11 parser failed somehow near here: ( 
                                                               [FAILED]
    
    Where do you think the problem is ?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Try this:

    Code:
        226 #/# FastCGI Configuration
        227 var.fcgi_binary="/usr/lib/python2.4/site-packages/trac/web/fcgi_frontend.py"
        228 fastcgi.server = ( ".php" => ((
        229                      "bin-path" => "/usr/bin/php-cgi",
        230                      "socket" => "/tmp/php.socket"
        231                  )),
        232 #/# Configurations for Trac
        233                  "trac" =>
        234                         ("trac" =>
        235                           ("socket" => "/tmp/trac-fastcgi.sock",
        236                             "bin-path" => fcgi_binary,
        237                             "check-local" => "disable",
        238                             "bin-environment" =>
        239                                ("TRAC_ENV_PARENT_DIR" => "/srv/www/trac")
        240                           )
        241                         )
        242                  )
     
  3. asaso

    asaso New Member

    Worked

    Thanks falko it worked good now..
    But looks like i am having problems with authentication, here is my config:
    Code:
        281 #/# Authentication for the Trac Installation
        282 auth.backend               = "htpasswd"
        283 # Separated password files for each project
        284 # See "Conditional Configuration" in
        285 # http://trac.lighttpd.net/trac/file/branches/lighttpd-merge-1.4.x/doc/configuration.txt
        286 
        287 $HTTP["url"] =~ "^/lab/" {
        288   auth.backend.htpasswd.userfile = "/srv/www/trac/lab/htpasswd.htaccess"
        289 }
        290 #$HTTP["url"] =~ "^/second/" {
        291 #  auth.backend.htpasswd.userfile = "/path/to/projenv-second/htpasswd.htaccess"
        292 #}
        293 
        294 # Enable auth on trac URLs, see
        295 # http://trac.lighttpd.net/trac/file/branches/lighttpd-merge-1.4.x/doc/authentication.txt
        296 
        297 #auth.require = ("/lab/login" =>
        298                  ("method"  => "basic",
        299                   "realm"   => "lab",
        300                   "require" => "valid-user"
        301                  )
        302 #                "/second/login" =>
        303 #                ("method"  => "basic",
        304 #                 "realm"   => "Second project",
        305 #                 "require" => "valid-user"
        306 #                )
        307                ) 
    and When i restart the service i get the following errors:
    Code:
    Starting lighttpd: 2009-05-15 00:16:23: (configfile.c.496) source: /etc/lighttpd/lighttpd.conf line: 282 pos: 28 use => for assignments in arrays 
    2009-05-15 00:16:23: (configfile.c.861) configfile parser failed at: auth.backend 
                                                               [FAILED]
    take in consideration that i already created the password file with htpasswd
     
  4. falko

    falko Super Moderator ISPConfig Developer

    It seems as if there's another problem with the parentheses...
     

Share This Page