Problem with languages encoding in ISPConfig 3.0.2.1

Discussion in 'Installation/Configuration' started by radim_h, Apr 18, 2010.

  1. radim_h

    radim_h Member

    Hello,

    i have installed ISPC 3.0.2.1, but there is some kind of problem with some languages,
    i tried en, ge, pl, hu, es and it all loks OK

    Then i tried slovak language (sk) and all the national character are gone, also in language files,,,
    you can see here http://mixx.org/pic/ispc/wrongsk.jpg

    Then i imported my own czech language file /originaly from 3.0.1.6/ and as you can see, result is same wrong
    http://mixx.org/pic/ispc/wrongcz.jpg

    National charecters in original language file was destroyed, here is part of
    /usr/local/ispconfig/interface/lib/lang/cz.lng

    before import
    $wb['301'] = 'Modul není pro aktuálního uživatele povolen.';
    $wb['302'] = 'Nefunční modul.';
    $wb['1001'] = 'Je třeba vyplnit uživatelské jméno a heslo!';
    $wb['1002'] = 'Nesprávné uživatelské jméno a/nebo heslo !';
    $wb['1003'] = 'Uživatel je deaktivován !';
    $wb['delete_confirmation'] = 'Opravdu chcete smazat tento záznam ?';
    $wb['error_no_view_permission'] = 'Nemáte oprávnění pro prohlížení tohoto záznamu nebo záznam neexistuje !';
    $wb['error_no_delete_permission'] = 'Nemáte oprávnění smazat tento záznam !';


    after import
    $wb['301'] = 'Modul nen� pro aktu�ln�ho u�ivatele povolen.';
    $wb['302'] = 'Nefun�n� modul.';
    $wb['1001'] = 'Je t�eba vyplnit u�ivatelsk� jm�no a heslo!';
    $wb['1002'] = 'Nespr�vn� u�ivatelsk� jm�no a/nebo heslo !';
    $wb['1003'] = 'U�ivatel je deaktivov�n !';
    $wb['delete_confirmation'] = 'Opravdu chcete smazat tento z�znam ?';
    $wb['error_no_view_permission'] = 'Nem�te opr�vn�n� pro prohl��en� tohoto z�znamu nebo z�znam neexistuje !';
    $wb['error_no_delete_permission'] = 'Nem�te opr�vn�n� smazat tento z�znam !';

    as instead all national character in nano editor there is only square character, something wrong is happening with UTF8


    Regards

    RH
     
    Last edited: Sep 2, 2010
  2. radim_h

    radim_h Member

    i had to copy all the files from old version manually (114 files if i count right)
    Then merge went fine. So update is not destroyng files, export import does

    I Have no courrage try to export and import lang file back...
     
    Last edited: Sep 2, 2010
  3. Eagle

    Eagle New Member

    Yes, it's true. Slovak translation is wrong.

    1. Slovak letters are not displayed correctly
    2. The grammar is poor, contains many errors

    How can I help correct translation? Who do I send the corrected files?
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please see here:

    http://www.faqforge.com/linux/controlpanels/ispconfig3/ispconfig-3-translating-the-interface/

    The file that you import has to be encoded in utf-8 format or you will loose the special language characters.
     

Share This Page