Problem with Jailkit

Discussion in 'Installation/Configuration' started by marcgeldon, Oct 19, 2009.

  1. marcgeldon

    marcgeldon New Member

    I installed our new server like described in this How-To:
    http://www.howtoforge.com/perfect-server-ubuntu-8.10-ispconfig-3

    Everything works fine.

    But no I've created a new shell user with "Chroot Shell" = Jailkit.

    If I try to login with the correct shell username and password via SSH the server just disconnects.

    I have no problem login if I set the "Chroot Shell" to "none".

    Can somebody help?

    Best wishes,

    Marc
     
  2. till

    till Super Moderator

    Take a lok at your syslog, auth.log and messages log to get more details on this problem.
     
  3. marcgeldon

    marcgeldon New Member

    SYSLOG
    Code:
    Oct 19 12:25:15 server301 console-kit-daemon[13803]: CRITICAL: cannot initialize libpolkit
    
    AUTH.LOG
    Code:
    Oct 19 12:23:24 server301 sshd[13495]: Accepted password for XXX from 95.116.241.178 port 63005 ssh2
    Oct 19 12:23:24 server301 sshd[13495]: pam_unix(sshd:session): session opened for user XXX by (uid=0)
    Oct 19 12:23:24 server301 jk_chrootsh[13563]: abort, the group ID from /etc/passwd (5004) does not match the group ID we run with (5005)
    Oct 19 12:23:24 server301 sshd[13495]: pam_unix(sshd:session): session closed for user XXX
    
     
  4. till

    till Super Moderator

    Please try to delete the shell user and recreate it. Also make sure that you dont have selinux enabled.
     
  5. marcgeldon

    marcgeldon New Member

    I've deleted the user and recreated it. Still does not work. Same problems in logfiles.

    SELinux is NOT enabled on my system.
     
  6. marcgeldon

    marcgeldon New Member

    I deleted the site and recreated it (also the shell users). Now it works.
     

Share This Page