Problem with ISPconfig sending mail

Discussion in 'Installation/Configuration' started by opensource82, Dec 17, 2014.

  1. opensource82

    opensource82 New Member

    Hi,
    I have new ISPconfig installed on Centos 6.2. I can't send any test mail and in maillog I can see below.


    Dec 18 00:55:17 wessam imapd: Connection, ip=[::1]
    Dec 18 00:55:17 wessam imapd: LOGIN, user=wessam@client1.local, ip=[::1], port=[53055], protocol=IMAP
    Dec 18 00:55:17 wessam imapd: LOGOUT, user=wessam@client1.local, ip=[::1], headers=0, body=0, rcvd=625, sent=203, time=0
    Dec 18 00:55:18 wessam postfix/pickup[1517]: 04542613FE: uid=48 from=<wessam@client1.local>
    Dec 18 00:55:18 wessam postfix/cleanup[2866]: 04542613FE: message-id=<dd566373f65fcc42247889636be3ead7.squirrel@192.168.204.131>
    Dec 18 00:55:18 wessam postfix/qmgr[1518]: 04542613FE: from=<wessam@client1.local>, size=658, nrcpt=1 (queue active)
    Dec 18 00:55:18 wessam imapd: Connection, ip=[::1]
    Dec 18 00:55:18 wessam imapd: LOGIN, user=wessam@client1.local, ip=[::1], port=[53057], protocol=IMAP
    Dec 18 00:55:18 wessam imapd: LOGOUT, user=wessam@client1.local, ip=[::1], headers=1430, body=0, rcvd=296, sent=3488, time=0
    Dec 18 00:55:19 wessam postfix/smtpd[2875]: connect from unknown[127.0.0.1]
    Dec 18 00:55:19 wessam postfix/smtpd[2875]: warning: SASL: Connect to private/auth failed: Connection refused
    Dec 18 00:55:19 wessam postfix/smtpd[2875]: fatal: no SASL authentication mechanisms
    Dec 18 00:55:20 wessam amavis[1561]: (01561-05) (!)ob8Of02yyrNU FWD from <wessam@client1.local> -> <wessam@client1.local>, 451 4.5.0 From MTA() during fwd-connect (No greeting, dt: 1.074 s): id=01561-05
    Dec 18 00:55:20 wessam postfix/master[1509]: warning: process /usr/libexec/postfix/smtpd pid 2875 exit status 1
    Dec 18 00:55:20 wessam postfix/master[1509]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Dec 18 00:55:20 wessam amavis[1561]: (01561-05) Blocked MTA-BLOCKED {TempFailedOpenRelay}, [192.168.204.1] <wessam@client1.local> -> <wessam@client1.local>, Message-ID: <dd566373f65fcc42247889636be3ead7.squirrel@192.168.204.131>, mail_id: ob8Of02yyrNU, Hits: 0.799, size: 658, 2228 ms
    Dec 18 00:55:20 wessam postfix/smtp[2871]: 04542613FE: to=<wessam@client1.local>, relay=127.0.0.1[127.0.0.1]:10024, delay=2.7, delays=0.39/0.1/0.03/2.2, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=01561-05 - Temporary MTA failure on relaying, From MTA() during fwd-connect (No greeting, dt: 1.074 s): id=01561-05 (in reply to end of DATA command))


    I tried to search over the internet but didn't find a solution. Any idea?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    seems as if ispconfig can not connect to dovecot. please check if you have dovecot or courier imap running at the moment.
     
  3. opensource82

    opensource82 New Member

    I should have courier


    [root@wessam ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:783 *:* LISTEN 1321/spamd.pid
    tcp 0 0 *:ftp *:* LISTEN 1478/pure-ftpd (SER
    tcp 0 0 192.168.204.131:domain *:* LISTEN 1078/named
    tcp 0 0 localhost:domain *:* LISTEN 1078/named
    tcp 0 0 *:ssh *:* LISTEN 1141/sshd
    tcp 0 0 *:smtp *:* LISTEN 1438/master
    tcp 0 0 localhost:rndc *:* LISTEN 1078/named
    tcp 0 0 *:amqp *:* LISTEN 1491/qpidd
    tcp 0 0 localhost:10024 *:* LISTEN 1331/amavisd (maste
    tcp 0 0 localhost:10025 *:* LISTEN 1438/master
    tcp 0 0 *:mysql *:* LISTEN 1278/mysqld
    tcp 0 0 localhost:45286 localhost:mysql ESTABLISHED 1494/amavisd (ch2-a
    tcp 0 0 localhost:mysql localhost:45285 ESTABLISHED 1278/mysqld
    tcp 0 0 localhost:45285 localhost:mysql ESTABLISHED 1493/amavisd (ch2-a
    tcp 0 0 localhost:mysql localhost:45286 ESTABLISHED 1278/mysqld
    tcp 0 608 192.168.204.131:ssh 192.168.204.1:50742 ESTABLISHED 1666/sshd
    tcp 0 0 *:pop3 *:* LISTEN 1357/couriertcpd
    tcp 0 0 *:imap *:* LISTEN 1344/couriertcpd
    tcp 0 0 *:webcache *:* LISTEN 1461/httpd
    tcp 0 0 *:http *:* LISTEN 1461/httpd
    tcp 0 0 *:tproxy *:* LISTEN 1461/httpd
    tcp 0 0 *:ftp *:* LISTEN 1478/pure-ftpd (SER
    tcp 0 0 *:domain *:* LISTEN 1078/named
    tcp 0 0 *:ssh *:* LISTEN 1141/sshd
    tcp 0 0 *:smtp *:* LISTEN 1438/master
    tcp 0 0 localhost:rndc *:* LISTEN 1078/named
    tcp 0 0 *:https *:* LISTEN 1461/httpd
    tcp 0 0 *:imaps *:* LISTEN 1351/couriertcpd
    tcp 0 0 *:pop3s *:* LISTEN 1363/couriertcpd
    tcp 0 0 localhost:10024 *:* LISTEN 1331/amavisd (maste
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:50996 TIME_WAIT -
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:50987 TIME_WAIT -
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:50991 TIME_WAIT -
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:51008 TIME_WAIT -
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:50976 TIME_WAIT -
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:50988 TIME_WAIT -
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:50979 TIME_WAIT -
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:51004 TIME_WAIT -
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:51009 TIME_WAIT -
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:50997 TIME_WAIT -
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:51000 TIME_WAIT -
    tcp 0 0 ::ffff:192.168.204:webcache ::ffff:192.168.204.1:50989 TIME_WAIT -
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It might be that you have dovecot and courier installed which confused the ispconfig installer.

    Please post the output of:

    which dovecot
     
  5. opensource82

    opensource82 New Member

    [root@wessam ~]# which dovecot
    /usr/bin/which: no dovecot in (/usr/lib/courier-imap/sbin:/usr/lib/courier-imap/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
     
  6. opensource82

    opensource82 New Member

    I can provide any other configuration files or logs if needed. Just let me know if there anything that would help here. This is a test environment to check if ispconfig is a good Control Panel that we can relay on. I can do any changes if needed.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post your postfix main.cf file.
     
  8. opensource82

    opensource82 New Member

    Check Attached.
     

    Attached Files:

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    The main.cf contains lines for dovecot, so there must have been dovecot installed at the time the ispconfig installer was run as it checks for the existence of dovecot with "which dovecot". Maybe you switched to courer later?

    To fix that, please run:

    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php

    and choose yes when the updater asks if services hall be reconfigured.

    Btw, why do you test ispconfig on such a old Linux version and not centos 7 or at least 6.5? The recommended distribution for ispconfig is debian btw.
     
  10. opensource82

    opensource82 New Member

    Thanks Till for your reply. I did php -q update.php but problem persists. The same error appeared and I am not able to send any mails. Also I noticed that main.cf still has some dovecot lines after the update.

    I didn't know that the recommended distribution is Debian. That might be a problem here as we are planing to use Centos.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to comment out the dovecot lines from main.cf and restart postfixm especially the sasl related ones.

    Which tutorial did you use to prepare the server for the ispconfig install?

    Centos works as well. Its just more expensive on the admin side as yum tends to break config files during system updates while apt from debian will leave them intact.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    And if you wont to use centos, why ont you use a recent version? centos 6.2 is from 2011.
     
  13. opensource82

    opensource82 New Member

    Thanks Till for your help. I tried to comment those lines and restart the service but problem persists. I rebooted the server but the same issue. I will try to install it on another Centos 7 server.

    By the way, I followed link below for the installation.

    http://www.ispconfig.org/page/en/documentation.html
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that will be better. All current guides use dovecot.
     

Share This Page