Problem with ISPconfig / joomla

Discussion in 'General' started by tremor, May 30, 2009.

  1. tremor

    tremor New Member


    I'm trying to set up a couple of different sites on a server using joomla and ISPconfig but I ran into som problems so I hope someone here can help me out.

    First I created client A and site A in ISPc. I enabled php-scripts and mysql for the site (along with mail user login, those were the only three options that I checked). Then I set up a database for joomla and copied all the joomla files to the web directory. Finally I went through the joomla webinstallation procedure and everything worked out just perfectly! I'm sort of a newbie here so it's a huge relief for me everytime something do work out just like I inteded it to... :)

    So time for site B... I create a new client, client B, and a new site, site B. I enable php scripts and mysql (no mail user login this time, that's the only difference from site A). I copy the joomla files (same files as before) but this time when I go to the site to do the webinstallation of joomla the index.php file does not execute but is instead displayed in firefox as plain text. I also tried IE but then index.php just downloads to my computer.

    There is one difference between site A and B and that is that I have not yet recieved the domain for site B. I solved this by creating a symlink from the sharedip directory (where I ended up when I typed in the ip-address to the server in my browser) to the web-directory of site B. So now when I type in I come to the default index.html file of site B and when I type in I come to the joomla index.php file, but like I said, it just comes up on the screen as plain text.

    So I guess my question is why doesn't the php-code execute on site B when it did (and still do) on site A? Hope someone out there can help me out!!!
  2. shajazzi

    shajazzi Member

    Hi tremor,
    Did you set some limits like in the example image below?


    Attached Files:

  3. tremor

    tremor New Member


    No, I did not set any limits. In the checkboxes part I enabled php-scripts and mysql (1 database) and nothing else.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    and that exactly your problem. You can not access websites trogh a symlink from the shared IP directory. >ou have to access the site trogh its domain name, if the domain has not been registered yet, then add it to the hosts file on your workstation to be able to use it to access the site.
  5. tremor

    tremor New Member

    That's it! Thanks a lot! :)

Share This Page