problem with ISPConfig install

Discussion in 'ISPConfig 3 Priority Support' started by jpcyrenne, Mar 4, 2018.

  1. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Good day,
    Trying to launch ISPConfig onn CentOS 7.4 (latest) with MariaDB 10.2.
    I followed the Perfect Server procedure:
    https://www.howtoforge.com/perfect-server-centos-7-x86_64-nginx-dovecot-ispconfig-3

    I have 3 issues:

    1)
    MySQL database to create [dbispconfig]:
    MySQL charset [utf8]:

    PHP Warning: mysqli_connect(): Headers and client library minor version mismatch. Headers:50556 Library:100130 in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 81
    Wrong SQL-mode. You should use NO_ENGINE_SUBSTITUTION. Add

    sql-mode="NO_ENGINE_SUBSTITUTION"

    to the mysqld-section in your mysql-config on this server and restart mysqld afterwards


    So added sql-mode="NO_ENGINE_SUBSTITUTION" to vi /etc/my.cnf.d/server.cnf and restartted MariaDB.
    service mysql restart

    Got a warning but it went through... Is this OK?
    PHP Warning: mysqli_connect(): Headers and client library minor version mismatch. Headers:50556 Library:100130 in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 81
    PHP Warning: mysqli_connect(): Headers and client library minor version mismatch. Headers:50556 Library:100130 in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 110

    Apache and nginx detected. Select server to use for ISPConfig: (apache,nginx) [apache]:
    Chose nginx (i have no apache or httpd on this machine - confirmed).

    - Failed to restart [email protected]: Unit not found.
    - Job for pure-ftpd.service failed because the control process exited with error code. See "systemctl status pure-ftpd.service" and "journalctl -xe" for details.
    Installation completed.

    2) Not sure what to do with the [email protected] issue. It installed OK from what I remember.

    [[email protected] install]# service amavisd status
    Redirecting to /bin/systemctl status amavisd.service
    ● amavisd.service - Amavisd-new is an interface between MTA and content checkers.
    Loaded: loaded (/usr/lib/systemd/system/amavisd.service; enabled; vendor preset: disabled)
    Active: active (running) since Sun 2018-03-04 21:02:41 UTC; 2min 50s ago
    Docs: http://www.ijs.si/software/amavisd/#doc
    Process: 19445 ExecStart=/usr/sbin/amavisd -c /etc/amavisd/amavisd.conf (code=exited, status=0/SUCCESS)
    Main PID: 19446 (/usr/sbin/amavi)
    CGroup: /system.slice/amavisd.service
    ├─19446 /usr/sbin/amavisd (master)
    ├─19467 /usr/sbin/amavisd (virgin child)
    └─19468 /usr/sbin/amavisd (virgin child)

    Mar 04 21:02:41 host.xxxx.com amavis[19446]: Net::Server: Group Not Defined. Defaulting to EGID '991 991'
    Mar 04 21:02:41 host.xxxx.com amavis[19446]: Net::Server: User Not Defined. Defaulting to EUID '994'
    Mar 04 21:02:41 host.xxxx.com systemd[1]: Started Amavisd-new is an interface between MTA and content checkers..
    Mar 04 21:02:41 host.xxxx.com amavis[19446]: No ext program for .rar, tried: rar, unrar
    Mar 04 21:02:41 host.xxxx.com amavis[19446]: No ext program for .lha, tried: lha
    Mar 04 21:02:41 host.xxxx.com amavis[19446]: No ext program for .tnef, tried: tnef
    Mar 04 21:02:41 host.xxxx.com amavis[19446]: No decoder for .lha
    Mar 04 21:02:41 host.xxxx.com amavis[19446]: No decoder for .rar
    Mar 04 21:02:41 host.xxxx.com amavis[19446]: Using primary internal av scanner code for ClamAV-clamd
    Mar 04 21:02:41 host.jpcyrenne.com amavis[19446]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan

    3)
    Pure-ftpd won't start
    I followed this with no success: https://www.howtoforge.com/community/threads/error-pure-ftpd-and-mysql.75059/
    Service failed because the control process exited with error code. See "systemctl status pure-ftpd.service" and "journalctl -xe" for details.
    [[email protected] install]# systemctl status pure-ftpd.service
    ● pure-ftpd.service - Pure-FTPd FTP server
    Loaded: loaded (/usr/lib/systemd/system/pure-ftpd.service; enabled; vendor preset: disabled)
    Active: failed (Result: exit-code) since Sun 2018-03-04 21:10:34 UTC; 15s ago
    Process: 19650 ExecStart=/usr/sbin/pure-config.pl /etc/pure-ftpd/pure-ftpd.conf --daemonize (code=exited, status=252)

    Mar 04 21:10:34 host.xxxx.com systemd[1]: Starting Pure-FTPd FTP server...
    Mar 04 21:10:34 host.xxxx.com systemd[1]: pure-ftpd.service: control process exited, code=exited status=252
    Mar 04 21:10:34 host.xxxx.com systemd[1]: Failed to start Pure-FTPd FTP server.
    Mar 04 21:10:34 host.xxxx.com systemd[1]: Unit pure-ftpd.service entered failed state.
    Mar 04 21:10:34 host.xxxx.com systemd[1]: pure-ftpd.service failed.

    Thank you,
    JP
     
  2. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    4) when I tweaked mailman language couldn't restart...
    vi /usr/lib/mailman/Mailman/mm_cfg.py

    5) can't get to configure roundcube...
    http://MyIP:8081/roundcubemail/installer : 404 page not found

    6) I created a domain, tried to create a SSL certificate and nothing happens...

    Ouffff, spent 1/2 day on this... Used to love ISPConfig on CentOS6, having a hard time on CentOS7.

    JP
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    1) The PHP warnings can be ignored. Did you install a different PHP version than the one that ships with CentOS by default?
    2) Clamav: don't know why this fails, maybe centOS renamed the service again, they tend to do that from time to time even in minor releases.
    3) Not sure why it fails as there is no usable error message in the output, at least I don't see it. Maybe a problem with an ssl cert? But you might be able to find a more useful error in one of the system log files.
    4) Try to change the language back to it's original value, if it worked before.
    5) Try if you can reach roundcube on port 80 instead of 8081 or try /webmail instead of /roundcube.
    6) Did you tried creating a self signed ssl cert or a letsencrypt ssl cert.

    Just a personal not: Such problems as the ones above are the reason why I prefer Debian and Ubuntu over CentOS. Much easier to setup and way more stable. You might want to consider using e.g. an Ubuntu LTS instead.
     
  4. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    OK let's close this ticket. I feel there's a lot to debug for now on CentOS7. I did try Debian9 two months ago and had a few issues. I'll give Ubuntu a try. Ubuntu is EOL in 2021, CentOS7 is 2024. If I go with Ubuntu I have to start planing a move in 2-3 years.

    JP
     

Share This Page