Problem with ISPC 3 and DNS

Discussion in 'Installation/Configuration' started by JaguarFR, May 30, 2011.

  1. JaguarFR

    JaguarFR New Member

    Hello,
    I added the new domain name ke-00042.com to my ISPC:
    dns.jpg
    But it doesn't work. http://www.ke-00042.com doesn't reach my server. :mad:

    My server was installed following "The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3]".
    I use ISPC 3.0.3.3
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The dns records look fine so far. Please post the output of this command run on your server:

    dig @localhost www.ke-00042.com
     
  3. JaguarFR

    JaguarFR New Member

    Hello Till,

    Thanks for your quick answer.

    Code:
    root@ks23447:~# dig @localhost www.ke-00042.com
    
    ; <<>> DiG 9.7.3 <<>> @localhost www.ke-00042.com
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41959
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3
    
    ;; QUESTION SECTION:
    ;www.ke-00042.com.		IN	A
    
    ;; ANSWER SECTION:
    www.ke-00042.com.	86400	IN	A	91.121.13.102
    
    ;; AUTHORITY SECTION:
    ke-00042.com.		86400	IN	NS	ks23447.kimsufi.com.
    ke-00042.com.		86400	IN	NS	ns.kimsufi.com.
    
    ;; ADDITIONAL SECTION:
    ns.kimsufi.com.		15192	IN	A	213.186.33.199
    ns.kimsufi.com.		15192	IN	AAAA	2001:41d0:3:1c7::1
    ks23447.kimsufi.com.	50034	IN	A	91.121.13.102
    
    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon May 30 16:34:12 2011
    ;; MSG SIZE  rcvd: 157
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok, so your DNS server seems to be configured correctly. Please check the settings for the domain ke-00042.com at your domain registry and make sure that the primary dns server for this domain is ks23447.kimsufi.com

    Also be aware that changes in DNS may take up to 48 hours to propagate.
     
  5. JaguarFR

    JaguarFR New Member

    I already checked this:
    dns.png

    And I waited more than one week. :confused:
     
  6. pititis

    pititis Member

    Your settings in the register control panel are missing...

    Cheers

    Code:
    
    ; <<>> DiG 9.7.1-P2 <<>> any ke-00042.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 60147
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;ke-00042.com.			IN	ANY
    
    ;; Query time: 66 msec
    ;; SERVER: 192.168.42.129#53(192.168.42.129)
    ;; WHEN: Mon May 30 19:20:22 2011
    ;; MSG SIZE  rcvd: 30
    
    
     
  7. JaguarFR

    JaguarFR New Member

    Hello Pititis,

    Thanks for your answer.

    About which control panel do you speak? In the register of the domain name, everything seems to be OK: http://www.dnssy.com displays that NS records are OK:
    Code:
    ks23447.kimsufi.com [91.121.13.102] TTL 172800
    ns.kimsufi.com [213.186.33.199] TTL 172800
    But your "dig @91.121.13.102 www.ke-00042.com" finds "ANSWER: 0". Why?
     
  8. mundoff

    mundoff New Member

    Hi, I have exactly the same problem but I have follow the tutorial "The Perfect Server - Ubuntu 10.10 [ISPConfig 3]" and yes, I have my server in kimsufi.com

    Any solution? :(


    Edit:

    I have solved, it's simple:

    Code:
    sudo nano /etc/bind/named.conf.options
    and put your file like me:

    Code:
    options {
            directory "/var/cache/bind";
    
            // If there is a firewall between you and nameservers you want
            // to talk to, you may need to fix the firewall to allow multiple
            // ports to talk.  See http://www.kb.cert.org/vuls/id/800113
    
            // If your ISP provided one or more IP addresses for stable
            // nameservers, you probably want to use them as forwarders.
            // Uncomment the following block, and insert the addresses replacing
            // the all-0's placeholder.
    
            // forwarders {
            //      0.0.0.0;
            // };
    
            //auth-nxdomain no;    # conform to RFC1035
            //listen-on port 53 { any; };
            //listen-on-v6 port 53 { any; };
            //allow-query     { any; };
            //allow-recursion { 127.0.0.1; };
    
    	auth-nxdomain no;    # conform to RFC1035
            listen-on port 53 { 127.0.0.1; };
            listen-on-v6 port 53 { ::1; };
            allow-query     { 127.0.0.1; };
            allow-recursion { 127.0.0.1; };
    };
    Then restart the bind9:

    Code:
    /etc/init.d/bind9 restart
    Now, test it.

    PD: Remember, I'm using Ubuntu, the directory can change in you dist.
     
    Last edited: Jun 3, 2011
  9. JaguarFR

    JaguarFR New Member

    Still no solution

    Hello,
    I tried everything.
    I tried changing my file named.conf.options as described Mundoff.
    But I still have the same problem: my domain name ke-00042.com still does not reach my website :( :( .
     
  10. mundoff

    mundoff New Member

    Hi, you must use the commented config, this:

    Code:
    auth-nxdomain no;    # conform to RFC1035
    listen-on port 53 { any; };
    listen-on-v6 port 53 { any; };
    allow-query     { any; };
    allow-recursion { 127.0.0.1; };
    Try and it must go, the no-commented config is more secured but it doesn't go in kimsufi. :S
     
    Last edited: Jun 9, 2011
  11. JaguarFR

    JaguarFR New Member

    I replaced my etc/bind/named.conf.options file with:
    Code:
    options {
    	directory "/var/cache/bind";
    
    	// If there is a firewall between you and nameservers you want
    	// to talk to, you may need to fix the firewall to allow multiple
    	// ports to talk.  See http://www.kb.cert.org/vuls/id/800113
    
    	// If your ISP provided one or more IP addresses for stable 
    	// nameservers, you probably want to use them as forwarders.  
    	// Uncomment the following block, and insert the addresses replacing 
    	// the all-0's placeholder.
    
    	// forwarders {
    	// 	0.0.0.0;
    	// };
    
     auth-nxdomain no;    # conform to RFC1035
     listen-on port 53 { any; };
     listen-on-v6 port 53 { any; };
     allow-query     { any; };
     allow-recursion { 127.0.0.1; };	
    	
    };
    Then I restarted bind9:
    Code:
    /etc/init.d/bind9 restart
    And...everything works perfectly! :)
    The problem that bothers me for 10 days is solved!
    Thanks a lot Mundoff!
     

Share This Page