problem with installing ispconfig

Discussion in 'Installation/Configuration' started by darkscythe002, Apr 25, 2009.

  1. darkscythe002

    darkscythe002 New Member

    hi, i'm having a problem with installing/setting up ispconfig. i went to the guide for setting up fedora 8, and then at the end setting up ispconfig. i got all the way down to the part where you have to enter information for mysql. when i tried to enter the password, i tried to enter one for about 15 min or so. after that i decided to ctrl z and try to fix the password for it by resetting the password for mysql, which i was successful in doing. however, when i deleted the install_ispconfig directory like it said to do, and then re running the setup, the only questions i was able to answer was what language i wanted to do the setup in, and then it would say that it's installed. the problem is that i didn't get to finish answering the questions, and now i don't know what to do to get the info for them, so i was never able to put a http or https interface for it. is there a way for me to uninstall ispconfig and reinstall it to where i can answer those questions, or is there another way that i can input that information that i missed (basically the whole paragraph starting at please enter your mysql server)? there are other errors that show up throughout it installing, but i think that's b/c i didn't put in the info to those questions.
     
    Last edited: Apr 25, 2009
  2. darkscythe002

    darkscythe002 New Member

    well, i got a friend to help me delete the right directories, and after uninstalling and reinstalling mysql, along with a few line changes in the my.cnf file, i got it to work.
     
  3. darkscythe002

    darkscythe002 New Member

    ok, i got it to install, but when i try to go to the site www.hostip.com:81, it won't load. the only thing that loads is the fedora test page when i type www.hostip.com. it won't even load when i type the host name rather than the ip. how can i get it so that i can actually access my ispconfig control panel?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    /etc/init.d/ispconfig_server restart
    and try again.
     
  5. darkscythe002

    darkscythe002 New Member

    i tried restarting the whole server, and nothing happened. i couldn't do that line b/c it said that the directory doesn't exist.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    This probably means that ISPConfig isn't installed properly. Did you notice any error messages during installation? What are the outputs of
    Code:
    ls -la /root/ispconfig
    ,
    Code:
    ls -la /home/admispconfig
    and
    Code:
    df -h
    ?
     
  7. darkscythe002

    darkscythe002 New Member

    ls -la /root/ispconfig
    total 16
    drwxr-xr-x 3 root root 4096 2009-04-25 14:46 .
    drwxr-x--- 22 root root 4096 2009-04-25 15:49 ..
    drwxr-xr-x 3 root root 4096 2009-04-25 14:46 isp

    ls -la /home/admispconfig
    total 16
    drwxr-xr-x 3 root root 4096 2009-04-24 19:10 .
    drwxr-xr-x 5 root root 4096 2009-04-25 03:40 ..
    drwxr-xr-x 3 root root 4096 2009-04-24 22:41 ispconfig

    df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/mapper/VolGroup00-LogVol00
    35G 4.8G 28G 15% /
    /dev/sda1 193M 19M 165M 11% /boot
    tmpfs 363M 0 363M 0% /dev/shm
     
  8. falko

    falko Super Moderator ISPConfig Developer

    There are some directories missing in /root/ispconfig. I suggest you install ISPConfig again. Make sure that SELinux is disabled.
     
  9. darkscythe002

    darkscythe002 New Member

    ok, deleting it and reinstalling worked. i can now access the :81 control panel. thanks for all your help.
     
    Last edited: Apr 30, 2009

Share This Page