Problem with instalation

Discussion in 'Installation/Configuration' started by indicator72, Nov 15, 2005.

  1. indicator72

    indicator72 New Member

    I have tried to install ISPConfig, but something went wrong. I got this messange. For some reason the database is not created. How do I solve this problem.

    ######### INSTALLATION ##########

    Preparing files. Please wait a moment...
    All prerequisites are fulfilled.
    Here we go...


    Warning: mysql_connect(): Access denied for user 'ispconfig'@'192.168.1.15' (using password: YES) in /opt/ISPConfig/install_ispconfig/install.php on line 634
    Could not connect to db ispconfig
    Restarting some services...
    Shutting down httpd2: [ O.k. ]
    Starting httpd2: [ O.k. ]
    ./setup2: line 883: [: ==: unary operator expected
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    fopen: No such file or directory
    ispconfig_httpd: could not open document config file /root/ispconfig/httpd/conf/httpd.conf
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    Could not connect to MySQL server!Can't change dir to /home/admispconfig/ispconfig/tools/clamav/share/clamav
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    The MySQL user and password you entered seem to be wrong. It should be the MySQL user root and his password. Try to install again, but run

    Code:
    rm -fr /root/ispconfig
    rm -fr /home/admispconfig
    before. Also delete the old install_ispconfig (if it still exists) and unpack the ISPConfig sources again.
     
  3. indicator72

    indicator72 New Member

    I was never asked for the root password for MySQL :)
     
  4. falko

    falko Super Moderator ISPConfig Developer

    When the installer asks you for a MySQL user, you enter root, and in the next step root's MySQL password.
     
  5. indicator72

    indicator72 New Member

    I am really not sure what I am doing. If you send me your IP (so I can add it to hosts.allow) I can give you access via SSH. I am afraid I have messed it up :-( My mailadress is mik@mikbis.dk

    Kind regaards

    Mikael, Denmark
     
  6. indicator72

    indicator72 New Member

    That is just the thing. I was never asked
     
  7. indicator72

    indicator72 New Member

  8. indicator72

    indicator72 New Member

    I got the mysql connection to work. But when I got to the next step it failed. What should I write?

    Please enter the IP address of the ISPConfig web (e.g. 192.168.0.1):192.168.1.15
    ERROR: The IP address you provided is not reachable! The installation routine stops here!

    The instalationprocess is pretty unforgiving. One mistake and you are out :)
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    I assume you have run the installer several times? Have you deleted the directories /home/admispconfig, /root/ispconfig and install_ispconfig before you run the installer again as described in the installation manual?
     
  10. indicator72

    indicator72 New Member

    Yes I have :) My problem is what I posted 12:44 :)
     
    Last edited: Nov 15, 2005
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The only time the installer does not ask for mysql host, user and password is when it finds an ISPConfig installation on your server.

    Delete these directories /home/admispconfig, /root/ispconfig and install_ispconfig and run the installer again, it will ask you for the mysql data, 'iam sure :)
     
  12. indicator72

    indicator72 New Member

    I wonder if it has something to do with my firewall
     
  13. indicator72

    indicator72 New Member

    Yes I found that out :) But what am I suppossed to write in what I posted 12:44 ? I tried 192.168.1.15, which is the IP it runs on, but that didn't work :mad:
     
  14. mphayesuk

    mphayesuk New Member

    I would turn off any firewalls for now until you get everything installed.

    Also perhaps try to put your host name and domain in instead of the ip address.
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you use the IP 192.168.1.15 for the mysql setup or for ISPConfig? For MySQL i recommend to use "localhost" and for the ISPConfig IP and domain make shure that you can ping them from your server.
     
  16. indicator72

    indicator72 New Member

    It is getting a little old. I will try one more time with my firewall off
     
  17. falko

    falko Super Moderator ISPConfig Developer

    The installer tries to ping the IP address, so make sure that you can access 192.168.1.15 from your network (the network connection must work on the ISPConfig server), and that no firewall blocks ping attempts to that IP address.
     
  18. indicator72

    indicator72 New Member

    Everytting is messed up now
     
  19. indicator72

    indicator72 New Member

    I wish you would just help me
     
  20. indicator72

    indicator72 New Member

    I am no nerd
     

Share This Page