problem with incoming email

Discussion in 'Installation/Configuration' started by sumwoman, Jan 16, 2007.

  1. sumwoman

    sumwoman New Member

    Greetings!

    I have installed ISPConfig as instructed by Perfect Setup Fedora Core 6,
    (in fact, in the last month I have installed Linux and ISPConfig more times than I have had sex...but perhaps I am sharing too much information with you.)

    : )

    This time around, everything is working save for incoming email.

    I am connected via cable modem behind a router
    NAT is enable and the necessary ports are open
    Firewall is disabled

    I have setup several domains running on the same IP address
    and installed joomla on several of them and they all work fine.

    FTP works fine

    Squirrelmail can send but can't receive mail. (all accounts)

    I can send email using outlook but can not receive email. (all accounts)

    The only time I can receive email, is when I email from one of my own domains
    to the another one of my own domains...(both reside on the same server).



    here is error message from a gmail account from which I sent a test email
    which was returned.

    Delivery Status Notification
    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 9): 554 5.7.1 <xxxxxxx@writersblot.com>: Relay access denied


    The master DNS / webserver is ns3.bchost.info and this appears in the co-domain section for all the other websites.

    I spent quite a lot of time sorting through threads on this forum
    but none of the proscribed answers worked for me.


    Maildir is enabled in ISPConfig


    /etc/postfix/main.cf (includes the following at the bottom of the page)

    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names



    /etc/posftfix/local-host-names
    contains a list of all domains

    /etc/postfix/virtualtable
    contains a list all domains


    Please help me, as I need to get a life, but have decided not to,
    until I figure out how to receive email for all of my domains currently
    installed on ISPConfig.

    Thanks so much.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Is this your external IP?

    207.232.110.45

    Which errors do you get in the mail.log of your server?

    What is the output of:

    grep writersblot.com /etc/postfix/local-host-names
     
  3. sumwoman

    sumwoman New Member

    Thanks you Till for your response.

    207.232.110.45

    was the previous IP for this domain, but it was changed several days ago.
    It took just as long before I could even view WWW pages for this domain.

    NEW external IP : 70.68.xxx.xx
    internal IP: 192.168.2.152

    Here is the output for:
    grep www.writersxxxx.com /etc/postfix/local-host-names

    www.writersxxxx.com
    writersblot.com


    error messges is 'mail.log'

    Not sure if this is the file you are referring to
    Here is a copy of a file called 'maillog' (no dot in between the two words)
    /var/log/maillog

    --starts here


    Jan 15 23:59:04 ns3 sendmail[9203]: alias database /etc/aliases rebuilt by root
    Jan 15 23:59:04 ns3 sendmail[9203]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
    Jan 15 23:59:08 ns3 postfix/postfix-script: starting the Postfix mail system
    Jan 15 23:59:08 ns3 postfix/master[9321]: daemon started -- version 2.3.3, configuration /etc/postfix
    Jan 16 00:54:27 ns3 postfix/smtpd[10181]: connect from colo182-01.dedicated.netrino.co.uk[84.234.17.54]
    Jan 16 00:54:27 ns3 postfix/smtpd[10181]: lost connection after CONNECT from colo182-01.dedicated.netrino.co.uk[84.234.17.54]
    Jan 16 00:54:27 ns3 postfix/smtpd[10181]: disconnect from colo182-01.dedicated.netrino.co.uk[84.234.17.54]
    Jan 16 00:57:47 ns3 postfix/anvil[10184]: statistics: max connection rate 1/60s for (smtp:84.234.17.54) at Jan 16 00:54:27
    Jan 16 00:57:47 ns3 postfix/anvil[10184]: statistics: max connection count 1 for (smtp:84.234.17.54) at Jan 16 00:54:27
    Jan 16 00:57:47 ns3 postfix/anvil[10184]: statistics: max cache size 1 at Jan 16 00:54:27
    Jan 16 04:03:56 ns3 sendmail[13099]: l0GC2oa5013099: from=root, size=10317, class=0, nrcpts=1, msgid=<200701161202.l0GC2oa5013099@ns3.bchost.info>, relay=root@localhost
    Jan 16 04:03:56 ns3 postfix/smtpd[13350]: connect from localhost.localdomain[127.0.0.1]
    Jan 16 04:03:56 ns3 postfix/smtpd[13350]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    Jan 16 04:03:56 ns3 postfix/smtpd[13350]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Jan 16 04:03:56 ns3 sendmail[13099]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    Jan 16 04:03:56 ns3 postfix/smtpd[13350]: B245C4F17C6: client=localhost.localdomain[127.0.0.1], sasl_sender=root@ns3.bchost.info
    Jan 16 04:03:56 ns3 postfix/cleanup[13353]: B245C4F17C6: message-id=<200701161202.l0GC2oa5013099@ns3.bchost.info>
    Jan 16 04:03:56 ns3 sendmail[13099]: l0GC2oa5013099: to=root, ctladdr=root (0/0), delay=00:01:06, xdelay=00:00:00, mailer=relay, pri=40317, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as B245C4F17C6)
    Jan 16 04:03:56 ns3 postfix/qmgr[9323]: B245C4F17C6: from=<root@ns3.bcxxxx.info>, size=11123, nrcpt=1 (queue active)
    Jan 16 04:03:56 ns3 postfix/smtpd[13350]: disconnect from localhost.localdomain[127.0.0.1]
    Jan 16 04:03:56 ns3 postfix/local[13354]: B245C4F17C6: to=<root@ns3.bcxxxx.info>, relay=local, delay=0.16, delays=0.05/0.07/0/0.04, dsn=2.0.0, status=sent (delivered to maildir)
    Jan 16 04:03:56 ns3 postfix/qmgr[9323]: B245C4F17C6: removed

    --ends here


    Sorry if this is not the file you requested.
    Please tell me where I can find the file called 'mail.log' on my server.

    Thanks again!
     
    Last edited: Jun 21, 2007
  4. sumwoman

    sumwoman New Member

    I would like to correct one detail included in my initial posting

    --starts here

    The master DNS / webserver is ns3.bchost.info and this appears in the co-domain section for all the other websites.

    --endshere



    the master DNS is indeed ns3.bcxxxx.info




    However...


    In DNS Manger section there is a tab called 'Co-Domains'
    and each domain has an entry...


    for example www.writersxxxx

    Co-Domains
    192.168.x.xxx www.writersxxxx





    for example www.indyxxxx.info

    Co-Domains
    192.168.2.152 www.indyxxxx.info



    Presently each domain has an entry in the Co-Domains section
    which refers to one and the same IP Address
    and its own respective domain name.




    As well, within Co-Domains tab when I click on the IP address
    there appears another set of tabs 'Forward' and 'Options'

    In 'Options' tab there is a a drop down menu with the following choices.

    External Mail Server
    Internal Mail Server

    Currently, Internal Mail Server is selected. (all accounts)



    HELP! I have not received email through my regular mailbox for a week now...I miss my spam...!!
     
    Last edited: Jun 21, 2007
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The MX record for your domain is wrong:

    Code:
    mh1:~# dig mx writersblot.com
    
    ; <<>> DiG 9.2.1 <<>> mx writersblot.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34390
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;writersblot.com.               IN      MX
    
    ;; ANSWER SECTION:
    writersblot.com.        172800  IN      MX      0 mail.writersblot.com.
    
    ;; ADDITIONAL SECTION:
    mail.writersblot.com.   172800  IN      A       [B][COLOR="Red"]207.232.110.45[/COLOR][/B]
    
    ;; Query time: 412 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Wed Jan 17 18:21:52 2007
    ;; MSG SIZE  rcvd: 70
    You must make mail.writersblot.com point to 70.68.195.65 instead.
    The authoritative nameservers for your domain are:

    Code:
    mh1:~# dig ns writersblot.com
    
    ; <<>> DiG 9.2.1 <<>> ns writersblot.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50252
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;writersblot.com.               IN      NS
    
    ;; ANSWER SECTION:
    writersblot.com.        864     IN      NS      [B][COLOR="Red"]ns2.bchost.info[/COLOR][/B].
    writersblot.com.        864     IN      NS      [B][COLOR="Red"]ns3.bchost.info[/COLOR][/B].
    
    ;; ADDITIONAL SECTION:
    ns3.bchost.info.        86263   IN      A       70.68.195.65
    ns2.bchost.info.        86263   IN      A       207.232.110.41
    
    ;; Query time: 373 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Wed Jan 17 18:24:09 2007
    ;; MSG SIZE  rcvd: 112
    so you must change the DNS record there, not on your ISPConfig server.
     
  6. sumwoman

    sumwoman New Member

    This is what I get when I use 'dig' command while logged on to ns3.bchost.info

    I think there are several issues at work here.
    To avoid confusion I'll just deal with one issue per post.

    I think I need to clear cache files from a demoted DNS server.
    ( cache files pertaining to ns and mx zone records)
    so...
    How should go about clearing cache files from a linux server and a window 2003 server?

    I did search for an answer to this question, both on google and this forum.
    No luck.
    Looking forward to your response. Thanks alot!
     
    Last edited: Jun 21, 2007
  7. sumwoman

    sumwoman New Member

    For the time being, consider the initial problem solved,
    or at least solvable.

    I'm connected via high speed cable and the ISP provider blocks port 25.
    No only that, yesterday, I found out they changed my public IP address.

    Now nothing works!

    Well anyway, thanks so much for time, Till and Falko.
     
  8. sumwoman

    sumwoman New Member

    SMTP problem solved

    Hello there,

    First of all, my ISP company does not block port 25,


    As per, Perfect Setup Core 6, after installing ISPConfig,
    the maildir option has to be checked, which is located in
    Management > settings > Email

    I have always done this.

    In previous installs, /etc/postfix/main.cf
    included the following lines, at the bottom of the page.

    home_mailbox = Maildir/
    mailbox_command =

    after another complete reinstall, I discovered, I could in fact receive email.
    I reviewed /etc/postfix/main.cf
    and saw the previous mentioned two lines missing,
    so I typed them in and restarted postfix, only to find out
    I could not receive email anymore.

    I deleted the two lines and sure enough I could receive email once again.

    Yippy! I'm back to deleting spam from my email box!
     
    Last edited: Jun 21, 2007

Share This Page