problem with htaccess

Discussion in 'Installation/Configuration' started by grofar, Aug 10, 2009.

  1. grofar

    grofar New Member

    Code:
    [Mon Aug 10 20:19:09 2009] [alert] [client 89.44.185.105] /var/www/web5/web/.htaccess: Options not allowed here
    [Mon Aug 10 20:19:09 2009] [alert] [client 89.44.185.105] /var/www/web5/web/.htaccess: Options not allowed here
    
    pls help me !!!
     
  2. Mark_NL

    Mark_NL New Member

  3. grofar

    grofar New Member

    it's not work :( outher help for this problem ???
     
  4. _X_

    _X_ New Member

    give us something ... what's in htaccess in /var/www/web5/web/

    strip out real info like ip or address ...

    what linux have you set and what Tutorial did you follow?
     
  5. nikita

    nikita New Member

    mod_rewrite issues here too

    Hello,
    First, thanks for ispconfig
    I have a similar problem and found no resolution on the forum yet. I have 1 site that is using mod_rewrite. here is the content of .htaccess:

    #ErrorDocument 403 /403.php
    #ErrorDocument 404 /404.php

    RewriteEngine On
    ##RewriteBase /



    RewriteRule ^referinte\/(.*)\-([0-9]*)\.html$ refferences.php?id=$2 [NC,L]
    RewriteRule ^articole\/(.*)\-([0-9]*)\.html$ articles.php?id=$2 [NC,L]
    RewriteRule ^oferte\/pachet\-life\-fitness\.html$ offers_lifefitness.php [NC,L]
    RewriteRule ^oferte\/pachet\-cybex\.html$ offers_cybex.php [NC,L]
    RewriteRule ^oferte\/pachet\-startrac\.html$ offers_startrac.php [NC,L]
    RewriteRule ^oferte\/pachet\-precor\.html$ offers_precor.php [NC,L]

    # Aparate Cardio
    RewriteRule ^catalog\/aparate-cardio\/$ catalog.php?sid=1 [NC,L]
    RewriteRule ^catalog\/aparate-cardio\/(.*)\-([0-9])\/$ catalog.php?sid=1&cat_id=$2 [NC,L]

    # Aparate de Culturism si Fitness
    RewriteRule ^catalog\/aparate-culturism-si-fitness\/$ catalog.php?sid=2 [NC,L]
    RewriteRule ^catalog\/aparate-culturism-si-fitness\/(.*)\-([0-9]*)/$ catalog.php?sid=2&cat_id=$2 [NC,L]
    RewriteRule ^catalog\/aparate-culturism-si-fitness\/(.*)\-([0-9]*)/(.*)\-([0-9]*).html$ catalog.php?sid=2&cat_id=$2&prod_id=$4 [NC,L]

    # Bari si gantere
    RewriteRule ^catalog/bari-si-gantere/$ catalog.php?sid=3 [NC,L]
    RewriteRule ^catalog/bari-si-gantere/(.*)\-([0-9]*)/$ catalog.php?sid=3&cat_id=$2 [NC,L]

    # Oferte Speciale
    RewriteRule ^catalog/oferte-speciale/$ catalog.php?sid=4 [NC,L]
    RewriteRule ^catalog/oferte-speciale/(.*)-([0-9]*)/$ catalog.php?sid=4&cat_id=$2 [NC,L]

    RewriteRule ^catalog\/aparate-culturism-si-fitness\/detalii-produs\/(.*)-([0-9]*)\.html$ produse.php?prod_id=$2 [NC,L]
    RewriteRule ^despre_noi.html$ about.php [NC,L]
    RewriteRule ^galerie.html$ gallery.php [NC,L]
    RewriteRule ^galerie\/(.*)\-([0-9]*)\.html$ gallery.php?id=$2 [NC,L]
    RewriteRule ^galerie\-sali\-de\-culturism\-si\-fitness\.html$ galleryp.php [NC,L]
    RewriteRule ^galerie\-antrenamente\.html$ gallerya.php [NC,L]
    RewriteRule ^catalog.html$ catalog.php [NC,L]
    RewriteRule ^referinte.html$ refferences.php [NC,L]
    RewriteRule ^noutati.html$ articles.php [NC,L]
    RewriteRule ^contact.html$ contact.php [NC,L]
    RewriteRule ^newsletter$ newsletter.php [NC,L]

    RewriteRule ^cauta\/cuvant\/(.*)$ search.php?keywords=$1 [NC,L]


    php_value output_handler ob_gzhandler

    I have put the directive as specified in the previous post and i still get:

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    in the error log i get:

    /srv/www/web12/web/.htaccess: php_value not alowed here

    i had tried with simpler test .httaccess and i get 404 error

    i use ispconfig2 on opensuse 11.1

    can you please help me a bit? i'm not that good with html, i'm an admin.
    Thank you very much
     
    Last edited: Aug 13, 2009
  6. grofar

    grofar New Member

    ok i use ispconfig 2 linux fedora 11 and tutorial perfect server with fedora 11 :)

    the .htaccess in web look likt this

    it's the joomla htacces and i try to fix the problem and the same problem i have NOT WORK !!!

    if i erase Options +FollowSymLinks it's work, in httpd.conf look like this

    i try with None default and still not work pls help me !
     
    Last edited: Aug 13, 2009
  7. _X_

    _X_ New Member

    @ nikita:

    obviously

    php_value output_handler ob_gzhandler

    line is problem. I really don't know what that line does but comment it out with # at beginning and see if that works for you.

    the rest of htaccess is just there to create SEF urls

    @ grofar

    http://www.howtoforge.com/forums/showpost.php?p=170555&postcount=8

    this is how to set ISPConfig to work with Joomla 1.0 or 1.5
     
  8. grofar

    grofar New Member

    tnx _X_ it's wotk with that htacces just i change it ( no change in httpd.conf ) :) tnx again !!!
     
  9. nikita

    nikita New Member

    great!

    Thanks! commenting out the php line solved that error. Actually, after putting the CORRECT directive php doesn't yell error anymore. it just does not work properly.

    now the problem is that it doesn't seem to load the pages corectly, and the links are giving 404 file not found.
    if you load www.fitness-shop.ro it's obvious that the page does not look corectly.

    the directives for the site are:
    <Directory /srv/www/web12/web/>
    Options FollowSymLinks
    AllowOverride All
    </Directory>

    the efect is the same as if i remove .htaccess


    any ideea?
    Thank you!
     
    Last edited: Aug 14, 2009
  10. _X_

    _X_ New Member

  11. nikita

    nikita New Member

    Yes it works like a charm now. I erased the directve and paste it again and it started to work.

    Thank you very much for the help!
     
  12. _X_

    _X_ New Member

    Glad I could help :)
     
  13. nikita

    nikita New Member

    yea

    you really did. next week i'll send some money for the project. whish ispconfig 3 was better documented already :)
     

Share This Page