Problem with fastcgi drupal and rewrite url

Discussion in 'Installation/Configuration' started by smartmobili, Dec 14, 2014.

  1. smartmobili

    smartmobili New Member


    I have migrated an old ubuntu server where I was configuring everything by hand to a brand new CentOS7 server using ISPConfig3. I have followed the guide and now I am trying to migrate my old website running under drupal7/mysql. So I have transferred database and files and there is a problem I think with url rewriting. When I go to the home page my website is displayed but as soon as I try to click on another link I get a 404 error.
    After some research I have found the following advice:

    1) Change the settings.php of drupal and set the base_url (I don't like to do something like that because it was working without it on my old server and doing it may hide other problems)

    2) Inside Site -> Website -> Web Domain -> Options tab add the following Apache directives:

    DirectoryIndex index.php

    RewriteEngine on
    RewriteCond %{REQUEST_URI} !=/favicon.ico
    RewriteRule ^(.*)$ /index.php?q=$1 [L,QSA]

    The problem with this fix is if I add those apache directives I cannot access the roundcube /webmail anymore. I tried to add some RewriteRule to ignore every url that begins with webmail but it doesn't work.

    I also found those answers but they look like what I have already done:

    How can I fix that ?

    Last edited: Dec 14, 2014
  2. smartmobili

    smartmobili New Member

    Ok I have found.
    I have just removed what I have added as Apache Directives and copied the .htaccess from my old server.


Share This Page