Problem with email routing

Discussion in 'ISPConfig 3 Priority Support' started by muekno, Mar 6, 2018.

  1. muekno

    muekno Member HowtoForge Supporter

    I added a new mail domain. The server shall forward all mails to the next mail server. What is done bei by creating a new transport in email routing
    After entering domain and transport I got in example smtp:[dsl1.gerdakloos.de] under transport and it works
    but now entering the same data for a new domain I get :[dsl1.gerdakloos.de] under transport and it does not forward mails
    running ISPConfig 3.1.1.1, Debian jessie latest patches

    Thanks for help
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to update your ISPConfig installation to git-stable, there was an issue in that form which has been fixed in the stable branch. Or wait for the 3.1.12 release.
     
    muekno likes this.
  3. muekno

    muekno Member HowtoForge Supporter

    Thank you, will have to go to git stable, although I do not like as it is a server at customer site. As it is urgent I can not wait for the .12 release
     
  4. muekno

    muekno Member HowtoForge Supporter

    OK fine it works, but theres another problem. I haven an incoming adress i.e. [email protected]_domain.tld but it should go to [email protected]_domain.tld. As I understand the manual I should use the email alias
    source [email protected]_domain.tld destination [email protected]_domain.tld, but the destination entry is not accepted returns empty without any error message. i tried [email protected]_domian.de and infox same problem
    Thanks for help
     
  5. muekno

    muekno Member HowtoForge Supporter

    additional problem, email routing doe not work for the new domain. I have followed documentation page 196 ff and it is not the first I am doing. So I did entries email routing and relay recipients. The server the user has his mailbox accepts mail for this user testet with telnet from the ispconfig mailserver console. sending mails from extern reaches the ispconfig mailserver but is rejectes with 550 5.1.1 All other mails for 2 existing existing domains on the same ispconfig mailserver forwarded to the same mailserver as for the new domain are going fine. can't see any difference in configiguration for the new domain to the existing domain.
    Thanks for help
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The destination is an existing email mailbox in ISPConfig?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Look into the mail.log file to see in detail why it gets rejected.
     
  8. muekno

    muekno Member HowtoForge Supporter

    Mail log
    Mar 7 09:16:59 mailserver postfix/smtpd[868]: connect from smtp1.gerdakloos.de[62.146.82.71]
    Mar 7 09:16:59 mailserver postfix/trivial-rewrite[870]: warning: do not list domain weres.de in BOTH virtual_mailbox_domains and relay_domains
    Mar 7 09:16:59 mailserver postfix/smtpd[868]: NOQUEUE: filter: RCPT from smtp1.gerdakloos.de[62.146.82.71]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<[email protected]> to=<[email protected]s.de> proto=ESMTP helo=<smtp1.gerdakloos.de>
    Mar 7 09:16:59 mailserver postfix/smtpd[868]: NOQUEUE: filter: RCPT from smtp1.gerdakloos.de[62.146.82.71]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10024; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<smtp1.gerdakloos.de>
    Mar 7 09:16:59 mailserver postfix/smtpd[868]: NOQUEUE: reject: RCPT from smtp1.gerdakloos.de[62.146.82.71]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in virtual mailbox table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<smtp1.gerdakloos.de>
    Mar 7 09:16:59 mailserver postfix/smtpd[868]: disconnect from smtp1.gerdakloos.de[62.146.82.71]
    Concerning the warning I have only entries in email forward and relay recipients linke on two other domains on the same server and about 10 other domains on other ISPConfig systems working. Running git-stable as recommended. Mailbox exists as I can write indernal mails via smtp
     
  9. muekno

    muekno Member HowtoForge Supporter

    P.S. tried to fix fix the alias problem with email forward but deleted the entry after warning above last night
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Here you have the error. A domain may exist either as transport or as email domain but not both. So when the email shall get forwarded to another server, then delete the email domain.
     
  11. muekno

    muekno Member HowtoForge Supporter

    Ok thanks, your right as always,
     

Share This Page