Problem with E-Mail

Discussion in 'Installation/Configuration' started by AndréS, Aug 24, 2007.

  1. AndréS

    AndréS New Member

    Hallo,

    ich habe das alles erfolgreich installiert. Und es läuft auch fast alles wunderbar.
    Ich verwende: Debian 4.0

    Ich habe
    • Webmail
    • RoundCube
    • SquirrelMail
    installiert. Nun ja, logge mich dann bei webmail ein und kann keine E-Mails empfangen oder senden. Er sagt zwar, erfolgreich gesendet, jedoch ist die nicht wirklich angekommen. Hier noch mal ein Screenshot.

    Englisch.

    Hello,
    i had installed all. And it works, but nor 100%.
    I´m using Debian 4.0 and have installed
    • Webmail
    • RoundCube
    • SquirrelMail
    with webmail I can´t recceived any Email oder send any email?
    where is the problem? I hope you can help me.

    Here a screenshot.
     

    Attached Files:

  2. AndréS

    AndréS New Member

    update:

    I have asked for my DNS. The DNS from hetzner-online ag is for Server in their station.
    Now I used this.

    xxx.133.98.98
    and
    xxx.133.99.99

    I can reeceive mails by arcor. But not by other webaccounts on the old Server. And if I answer to mails, their wont be deleiver.

    Do you need some logs?
    Please help me.
    Thx
     
    Last edited: Aug 24, 2007
  3. AndréS

    AndréS New Member

    Here is the /var/log/mail.err
    Code:
    Aug 24 12:15:34 Debian-40-etch-minimal postfix/smtp[26918]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:16:35 Debian-40-etch-minimal postfix/smtp[26940]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:17:36 Debian-40-etch-minimal postfix/smtp[26970]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:18:37 Debian-40-etch-minimal postfix/smtp[27010]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:19:38 Debian-40-etch-minimal postfix/smtp[27050]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:20:39 Debian-40-etch-minimal postfix/smtp[27063]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:21:40 Debian-40-etch-minimal postfix/smtp[27095]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:22:41 Debian-40-etch-minimal postfix/smtp[27108]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:23:42 Debian-40-etch-minimal postfix/smtp[27121]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:24:43 Debian-40-etch-minimal postfix/smtp[27134]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:25:44 Debian-40-etch-minimal postfix/smtp[27150]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:26:45 Debian-40-etch-minimal postfix/smtp[27361]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:27:46 Debian-40-etch-minimal postfix/smtp[27389]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:28:47 Debian-40-etch-minimal postfix/smtp[27406]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:29:48 Debian-40-etch-minimal postfix/smtp[27461]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:30:49 Debian-40-etch-minimal postfix/smtp[27481]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:31:50 Debian-40-etch-minimal postfix/smtp[27495]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:32:51 Debian-40-etch-minimal postfix/smtp[27508]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:33:52 Debian-40-etch-minimal postfix/smtp[27522]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:34:53 Debian-40-etch-minimal postfix/smtp[27535]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:35:54 Debian-40-etch-minimal postfix/smtp[27548]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 12:36:55 Debian-40-etch-minimal postfix/smtp[27561]: fatal: bad boolean c                                                           onfiguration: smtp_use_tls = yea
    Aug 24 15:21:10 localhost postfix[2522]: fatal: could not find any active networ                                                           k interfaces
    Aug 24 15:21:20 localhost postfix[2848]: fatal: could not find any active networ                                                           k interfaces
    Aug 24 15:21:25 localhost freshclam[2938]: Can't get information about database.                                                           clamav.net: Temporary DNS error
    Aug 24 15:21:35 localhost last message repeated 2 times
    
    I think it is enough, i did a mistake. Where can I repair this?

    Thx
     
  4. AndréS

    AndréS New Member

    here my postfix.conf
    Code:
    Debian-40-etch-minimal:~# cat /etc/postfix/main.cf
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = Debian-40-etch-minimal
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    #mydestination = debian4032m, localhost, localhost.localdomain, localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    #smtpd_sasl_auth_clients = yes
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = static.88-198-69-165.clients.your-server.de,localhost.static.88-198-69-165.clients.your-server.de,localhost.localadmin,localhost
    myorigin = /etc/mailname
    
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    postmap -e 'mydestination = /etc/postfix/local-host-names'
    and restart Postfix.
    Also, you should replace Debian-40-etch-minimal in the myhostname line with a real hostname (it should exist in DNS).
    What's in /etc/mailname?
     
  6. AndréS

    AndréS New Member

    with this order I get this error msg:
    Code:
    postmap: invalid option -- e
    postmap: fatal: usage: postmap [-Nfinoprsvw] [-c config_dir] [-d key] [qkey] [map_type:]file...
    
    this is in the /etc/mailname: static.88-198-69-165.clients.your-server.de
     
  7. AndréS

    AndréS New Member

    I wrot this into the main.cf by hand. No there is this:

    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = static.88-198-69-165.clients.your-server.de
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    #mydestination = debian4032m, localhost, localhost.localdomain, localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    #smtpd_sasl_auth_clients = yes
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,rejec
    t_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    myorigin = /etc/mailname
    
    and still it does not work :-(
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Have you restarted postfix?
    2) Which lines appaer in the mail logfile, when you send a email to a account that you created on the server?
     
  9. AndréS

    AndréS New Member

    I have now reinstalled ISPconfig. And I will take a look if that now work. I hope it. I keep you informed
     

Share This Page