Problem with Dyndns and E-Learning platform on lighttp

Discussion in 'Server Operation' started by easylearn, Jun 7, 2009.

  1. easylearn

    easylearn New Member

    Hello to all,
    as on title I have a problem with DynDNS and the e-learning platform Moodle.
    In particular, it happens that when I go to http://easylearn.homelinux.com/easylearn from a pc that is not in the same network the server can reach the portal page of the LMS with display problems also when I start the login procedure by clicking the link url in the browser refers to localhost (http://localhost/easylearn/ ....).
    What is due?

    Regards
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please make sure you're using the correct hostname in the Moodle configuration.
     
  3. easylearn

    easylearn New Member

    Hi,
    is it on the config.php in the moodle main folder?

    Many thanks

    Bye
     
  4. easylearn

    easylearn New Member

    Hi,
    I edited the config.php located in the main folder, following the file:

    <?php /// Moodle Configuration File



    unset($CFG);



    $CFG->dbtype = 'mysql';

    $CFG->dbhost = 'localhost';

    $CFG->dbname = 'easylearn';

    $CFG->dbuser = 'xxxxxx';

    $CFG->dbpass = 'xxxxx';

    $CFG->dbpersist = false;

    $CFG->prefix = 'mdl_';



    $CFG->wwwroot = 'http://easylearn.homelinux.com/easylearn';

    $CFG->dirroot = '/var/www/moodle';

    $CFG->dataroot = '/var/moodledata';

    $CFG->admin = 'admin';



    $CFG->directorypermissions = 00777; // try 02777 on a server in Safe Mode



    require_once("$CFG->dirroot/lib/setup.php");

    // MAKE SURE WHEN YOU EDIT THIS FILE THAT THERE ARE NO SPACES, BLANK LINES,

    // RETURNS, OR ANYTHING ELSE AFTER THE TWO CHARACTERS ON THE NEXT LINE.

    ?>

    I edited wwwroot and
    now outside the network it says 403 forbiden and inside the lan I have display problems.

    Do I need to install a dns server in my server?

    Bye
     
  5. easylearn

    easylearn New Member

    I sow $CFG->dirroot = '/var/www/moodle'; in the config above,
    I changed It to $CFG->dirroot = '/var/www/easylearn'; and It is the same.

    Bye
     
  6. easylearn

    easylearn New Member

    Hi everybody,
    it could be a problem of my modem settings in particular the NAT?

    Bye
     
  7. falko

    falko Super Moderator ISPConfig Developer

    I've never worked with Moodle so I can't tell exactly what needs to be changed.

    Your router should forward port 80 to your web server.
     
  8. easylearn

    easylearn New Member

    I did infact I see the page but with display problems, it seems to me it can't find just the css.

    Thanks, I let yuo know if I find something.
     
  9. easylearn

    easylearn New Member

    Hi falko,
    I solved the problem:

    I edited the file /etc/hostname and changed the name of the system, then I run:

    /etc/init.d/hostname.sh start


    Bye
     

Share This Page