problem with dovecot.conf file

Discussion in 'Server Operation' started by christopher94523, Feb 19, 2009.

  1. christopher94523

    christopher94523 New Member

    [FONT=Helvetica, Arial, sans-serif]I got an error message when starting dovecot when it was already supposedly running:

    [/FONT][FONT=Helvetica, Arial, sans-serif] [root /etc]# /etc/rc.d/init.d/dovecot start

    Starting Dovecot Imap: Error: Dovecot is already running
    with PID 7179 (read from /var/run/dovecot/master.pid)
    Fatal: Invalid configuration in /etc/dovecot.conf
    [FAILED]
    [/FONT]
    [FONT=Helvetica, Arial, sans-serif]
    [/FONT][FONT=Helvetica, Arial, sans-serif] ======================================================
    [/FONT]
    [FONT=Helvetica, Arial, sans-serif]The following was achieved at the /etc directory via the command:
    cat -s dovecot.conf | egrep -v "#|^$"
    [note that I have edited my ipAddress into "xxx.xxx.xx.xx"]

    ======================================================

    protocols = imap pop3 imaps pop3s
    listen = xxx.xxx.xx.xx
    disable_plaintext_auth = no
    log_timestamp = "%Y-%m-%d %H:%M:%S "
    ssl_listen =
    [/FONT][FONT=Helvetica, Arial, sans-serif]xxx.xxx.xx.xx[/FONT]
    [FONT=Helvetica, Arial, sans-serif] ssl_disable = yes
    mail_location = maildir:/home/%u/Maildir/%u

    protocol imap {
    login_executable = /usr/libexec/dovecot/imap-login
    mail_executable = /usr/libexec/dovecot/imap
    }

    protocol pop3 {
    login_executable = /usr/libexec/dovecot/pop3-login
    mail_executable = /usr/libexec/dovecot/pop3
    pop3_enable_last = no
    pop3_uidl_format = %08Xu%08Xv
    }

    protocol lda {
    postmaster_address = postmaster@example.com
    }

    auth default {
    mechanisms = plain

    passdb pam {
    }

    userdb passwd {
    }

    user = root
    }

    dict {
    }

    plugin {
    }

    [/FONT][FONT=Helvetica, Arial, sans-serif] ======================================================
    [/FONT]
    [FONT=Helvetica, Arial, sans-serif]The following shows my settings:
    [/FONT]
    [root /etc]# dovecot -n

    # 1.0.7: /etc/dovecot.conf
    log_timestamp: %Y-%m-%d %H:%M:%S
    protocols: imap pop3 imaps pop3s
    listen: xxx.xxx.xx.xx
    ssl_listen: xxx.xxx.xx.xx
    ssl_disable: yes
    login_dir: /var/run/dovecot/login
    login_executable(default): /usr/libexec/dovecot/imap-login
    login_executable(imap): /usr/libexec/dovecot/imap-login
    login_executable(pop3): /usr/libexec/dovecot/pop3-login
    mail_location: maildir:/home/%u/Maildir/%u
    mail_executable(default): /usr/libexec/dovecot/imap
    mail_executable(imap): /usr/libexec/dovecot/imap
    mail_executable(pop3): /usr/libexec/dovecot/pop3
    mail_plugin_dir(default): /usr/lib/dovecot/imap
    mail_plugin_dir(imap): /usr/lib/dovecot/imap
    mail_plugin_dir(pop3): /usr/lib/dovecot/pop3
    auth default:
    passdb:
    driver: pam
    userdb:
    driver: passwd
    [FONT=Helvetica, Arial, sans-serif] ======================================================

    I am running on a CentOS-5.2 based VPS.

    Can anyone spot my configuration and/or procedural error? ;-)
    Thanks much!

    best wishes,
    chris gray
    pleasant hill, ca
    [/FONT]
     
  2. topdog

    topdog HowtoForge Supporter

    You may be trying to start a process that is already running make sure dovecot is not running.

    Check your maillog it should give you the line number where the typo is in the dovecot config file.
     

Share This Page